aboutsummaryrefslogtreecommitdiff
path: root/security/py-sequoia
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2020-09-20 02:13:54 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2020-09-20 02:13:54 +0000
commit76af9b2b6996e4d2ffbeca53edfb2ca46277f398 (patch)
tree6f7a869fa334e964056b7ee9f3db23328df157a0 /security/py-sequoia
parenta75abc3efabd98b1378ecb5da4e6d5d0c081541a (diff)
downloadports-76af9b2b6996e4d2ffbeca53edfb2ca46277f398.tar.gz
ports-76af9b2b6996e4d2ffbeca53edfb2ca46277f398.zip
Add py-sequoia 0.19.0, python binding of sequoia.
PR: 249238 Submitted by: phryk-ports@wzff.de
Notes
Notes: svn path=/head/; revision=549083
Diffstat (limited to 'security/py-sequoia')
-rw-r--r--security/py-sequoia/Makefile33
-rw-r--r--security/py-sequoia/distinfo3
-rw-r--r--security/py-sequoia/files/patch-Makefile12
-rw-r--r--security/py-sequoia/files/patch-setup.py11
-rw-r--r--security/py-sequoia/pkg-descr4
5 files changed, 63 insertions, 0 deletions
diff --git a/security/py-sequoia/Makefile b/security/py-sequoia/Makefile
new file mode 100644
index 000000000000..4f4d9ccd707d
--- /dev/null
+++ b/security/py-sequoia/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= sequoia
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.19.0
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= phryk-ports@wzff.de
+COMMENT= Python binding of sequoia
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
+
+LIB_DEPENDS= libsequoia_ffi.so:security/sequoia
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1:devel/py-cffi@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1:devel/py-cffi@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+USE_GITLAB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GL_COMMIT}-${GL_COMMIT}/ffi/lang/python
+
+GL_ACCOUNT= sequoia-pgp
+GL_PROJECT= sequoia
+GL_COMMIT= 383133f6be990237044900a4df676488bf8dd71e
+CFLAGS+= -I${LOCALBASE}/include
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_sequoia.abi3.so
+
+.include <bsd.port.mk>
diff --git a/security/py-sequoia/distinfo b/security/py-sequoia/distinfo
new file mode 100644
index 000000000000..559cac3589de
--- /dev/null
+++ b/security/py-sequoia/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1599879269
+SHA256 (sequoia-pgp-sequoia-383133f6be990237044900a4df676488bf8dd71e_GL0.tar.gz) = 3c082bdbba219485ee00372748ff3638aea55e52184c01579bdc8166ac8cc807
+SIZE (sequoia-pgp-sequoia-383133f6be990237044900a4df676488bf8dd71e_GL0.tar.gz) = 2037544
diff --git a/security/py-sequoia/files/patch-Makefile b/security/py-sequoia/files/patch-Makefile
new file mode 100644
index 000000000000..ba1ed8a18104
--- /dev/null
+++ b/security/py-sequoia/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2020-08-21 08:30:55 UTC
++++ Makefile
+@@ -9,7 +9,8 @@ CFLAGS += -I../../include -I../../../openpgp-ffi/incl
+ PYTHON ?= python3
+ IPYTHON ?= ipython3
+ PYTEST ?= pytest-3
+-ifeq ($(shell uname -s), Darwin)
++
++ifneq ($(filter Darwin FreeBSD,$(shell uname -s)),"")
+ INSTALL ?= ginstall
+ else
+ INSTALL ?= install
diff --git a/security/py-sequoia/files/patch-setup.py b/security/py-sequoia/files/patch-setup.py
new file mode 100644
index 000000000000..2c2ece851c3e
--- /dev/null
+++ b/security/py-sequoia/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-08-21 08:30:55 UTC
++++ setup.py
+@@ -34,7 +34,7 @@ setup(
+
+ packages=['sequoia'],
+
+- setup_requires=["cffi>=1.0.0", "pytest-runner"],
++ setup_requires=["cffi>=1.0.0"],
+ cffi_modules=["sequoia/sequoia_build.py:ffibuilder"],
+ install_requires=["cffi>=1.0.0"],
+ tests_require=["pytest"],
diff --git a/security/py-sequoia/pkg-descr b/security/py-sequoia/pkg-descr
new file mode 100644
index 000000000000..c75c94a002b8
--- /dev/null
+++ b/security/py-sequoia/pkg-descr
@@ -0,0 +1,4 @@
+Sequoia is a cool new OpenPGP implementation. It consists of several crates,
+providing both a low-level and a high-level API for dealing with OpenPGP data.
+
+WWW: https://sequoia-pgp.org/