aboutsummaryrefslogtreecommitdiff
path: root/security/py-signedjson
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:37:09 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:37:09 +0000
commit3d051a94b5776ee23579be23095fc95752c1f76f (patch)
tree185712d39b4461f5aa7ef32c7474b8c488d93eee /security/py-signedjson
parent395f476cee5e5e186427b2a3f843f0cd38f95811 (diff)
downloadports-3d051a94b5776ee23579be23095fc95752c1f76f.tar.gz
ports-3d051a94b5776ee23579be23095fc95752c1f76f.zip
Notes
Diffstat (limited to 'security/py-signedjson')
-rw-r--r--security/py-signedjson/Makefile33
-rw-r--r--security/py-signedjson/distinfo2
-rw-r--r--security/py-signedjson/pkg-descr4
3 files changed, 39 insertions, 0 deletions
diff --git a/security/py-signedjson/Makefile b/security/py-signedjson/Makefile
new file mode 100644
index 000000000000..579016b25d80
--- /dev/null
+++ b/security/py-signedjson/Makefile
@@ -0,0 +1,33 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= signedjson
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Sign JSON with Ed25519 signatures
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:${PORTSDIR}/security/py-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=1.0.1:${PORTSDIR}/devel/py-unpaddedbase64 \
+ ${PYTHON_PKGNAMEPREFIX}canonicaljson>=1.0.0:${PORTSDIR}/devel/py-canonicaljson
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= matrix-org
+GH_PROJECT= python-signedjson
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} -m pytest tests)
+
+.include <bsd.port.mk>
diff --git a/security/py-signedjson/distinfo b/security/py-signedjson/distinfo
new file mode 100644
index 000000000000..9d9f45eeed07
--- /dev/null
+++ b/security/py-signedjson/distinfo
@@ -0,0 +1,2 @@
+SHA256 (matrix-org-python-signedjson-v1.0.0_GH0.tar.gz) = 9f50fbd678f3d0683e27c38533995c078d2bc2a2ee308f0b1161b5c7f8f68403
+SIZE (matrix-org-python-signedjson-v1.0.0_GH0.tar.gz) = 8563
diff --git a/security/py-signedjson/pkg-descr b/security/py-signedjson/pkg-descr
new file mode 100644
index 000000000000..ec1eed24fc19
--- /dev/null
+++ b/security/py-signedjson/pkg-descr
@@ -0,0 +1,4 @@
+python-signedjson allows more than one entity to sign an object, can sign with
+more than one key and replace ED25519 with a different algorithm.
+
+WWW: https://github.com/matrix-org/python-signedjson