aboutsummaryrefslogtreecommitdiff
path: root/security/py-ssh
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-20 06:31:36 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-20 06:31:36 +0000
commit869f2d6bd1c994e816176d012b3f70f0f7a5253e (patch)
treeaa89c2eb12e53b329e01fbe3586fc53d224e246e /security/py-ssh
parent22b6ab6708e5d2489a7f52f55f211eb7e84b50d4 (diff)
downloadports-869f2d6bd1c994e816176d012b3f70f0f7a5253e.tar.gz
ports-869f2d6bd1c994e816176d012b3f70f0f7a5253e.zip
- Remove explicit dependency in setup.py for `python ./setup.py test`
Requested by: clsung
Notes
Notes: svn path=/head/; revision=287714
Diffstat (limited to 'security/py-ssh')
-rw-r--r--security/py-ssh/Makefile2
-rw-r--r--security/py-ssh/files/patch-setup.py10
2 files changed, 11 insertions, 1 deletions
diff --git a/security/py-ssh/Makefile b/security/py-ssh/Makefile
index e5b28b959e45..50f125d2d2bc 100644
--- a/security/py-ssh/Makefile
+++ b/security/py-ssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssh
PORTVERSION= 1.7.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-ssh/files/patch-setup.py b/security/py-ssh/files/patch-setup.py
new file mode 100644
index 000000000000..162595012903
--- /dev/null
+++ b/security/py-ssh/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2011-12-20 14:19:49.418637581 +0800
++++ setup.py 2011-12-20 14:20:31.345637126 +0800
+@@ -38,7 +38,6 @@
+ try:
+ from setuptools import setup
+ kw = {
+- 'install_requires': 'pycrypto >= 2.1, != 2.4',
+ }
+ except ImportError:
+ from distutils.core import setup