aboutsummaryrefslogtreecommitdiff
path: root/security/py-stix/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-05-21 12:30:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-05-21 12:30:31 +0000
commitce4f36d22243aa164a0727e26899359c255b841f (patch)
treee5403cd4eeef18a98ebadf9eb5b0ca9a8cdab991 /security/py-stix/Makefile
parent8f393232b6c309d757405704c755b1e22f7db9d9 (diff)
downloadports-ce4f36d22243aa164a0727e26899359c255b841f.tar.gz
ports-ce4f36d22243aa164a0727e26899359c255b841f.zip
Notes
Diffstat (limited to 'security/py-stix/Makefile')
-rw-r--r--security/py-stix/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/security/py-stix/Makefile b/security/py-stix/Makefile
index 4b4d2a6645dd..c536b722df90 100644
--- a/security/py-stix/Makefile
+++ b/security/py-stix/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= stix
-PORTVERSION= 1.2.0.2
+PORTVERSION= 1.2.0.4
+DISTVERSIONPREFIX= v
CATEGORIES= security python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= antoine@FreeBSD.org
@@ -15,11 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}lxml>=2.3:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}cybox>=2.1.0.11:security/py-cybox \
- ${PYTHON_PKGNAMEPREFIX}mixbox>=1.0.1:security/py-mixbox
+ ${PYTHON_PKGNAMEPREFIX}cybox>=2.1.0.13:security/py-cybox \
+ ${PYTHON_PKGNAMEPREFIX}mixbox>=1.0.2:security/py-mixbox
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose \
${PYTHON_PKGNAMEPREFIX}maec>=4.1.0.13:security/py-maec
+USE_GITHUB= yes
+GH_ACCOUNT= STIXProject
+GH_PROJECT= python-${PORTNAME}
+
NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist