aboutsummaryrefslogtreecommitdiff
path: root/security/py-trezor/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-12-09 21:26:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-12-09 21:26:06 +0000
commit1e421c284262bb697a7a1e602af1611daac9e3a6 (patch)
treeabaac785ad7a059a97cc8030ce453b34c47bbd53 /security/py-trezor/Makefile
parenta0ef6f23f019f2c7b05f944c306a00a099c6b18e (diff)
downloadports-1e421c284262bb697a7a1e602af1611daac9e3a6.tar.gz
ports-1e421c284262bb697a7a1e602af1611daac9e3a6.zip
This version of the port also requires devel/py-construct, www/py-requests,
devel/py-click and security/py-pyblake2 to run trezorctl. While here sort RUN_DEPENDS. MFH is not needed since this port was only recently updated after 2018Q4 was branched.
Notes
Notes: svn path=/head/; revision=487089
Diffstat (limited to 'security/py-trezor/Makefile')
-rw-r--r--security/py-trezor/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/py-trezor/Makefile b/security/py-trezor/Makefile
index 553e275f6c9d..fcc52cfc0c2e 100644
--- a/security/py-trezor/Makefile
+++ b/security/py-trezor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= trezor
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,10 +16,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= protoc:devel/protobuf \
${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}construct>=0:devel/py-construct@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyblake2>=0:security/py-pyblake2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
USES= python:3.3+ shebangfix
USE_PYTHON= autoplist concurrent distutils