aboutsummaryrefslogtreecommitdiff
path: root/security/py-trezor
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-05-31 15:52:30 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-05-31 15:52:30 +0000
commit8ce887f37ed9842e3b724b6aa3a0cf203f21b296 (patch)
tree740bb801d49c0acdb587d916133f33f902541d7c /security/py-trezor
parente3e5543a6dc3364105a52ea6b86c3f060bd230e2 (diff)
downloadports-8ce887f37ed9842e3b724b6aa3a0cf203f21b296.tar.gz
ports-8ce887f37ed9842e3b724b6aa3a0cf203f21b296.zip
Update to 0.11.3
Notes
Notes: svn path=/head/; revision=503179
Diffstat (limited to 'security/py-trezor')
-rw-r--r--security/py-trezor/Makefile5
-rw-r--r--security/py-trezor/distinfo6
-rw-r--r--security/py-trezor/files/patch-vendor_trezor-common_tools_coin__info.py11
3 files changed, 6 insertions, 16 deletions
diff --git a/security/py-trezor/Makefile b/security/py-trezor/Makefile
index ef3f47d90873..0cbf0f51cbc6 100644
--- a/security/py-trezor/Makefile
+++ b/security/py-trezor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= trezor
-PORTVERSION= 0.11.2
+PORTVERSION= 0.11.3
CATEGORIES= security
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,6 +29,7 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-SHEBANG_FILES= trezorlib/tests/burn_tests/burntest.py
+SHEBANG_FILES= trezorlib/tests/burn_tests/burntest_t1.py \
+ trezorlib/tests/burn_tests/burntest_t2.py
.include <bsd.port.mk>
diff --git a/security/py-trezor/distinfo b/security/py-trezor/distinfo
index 0c858c421b54..8a2e1afc310d 100644
--- a/security/py-trezor/distinfo
+++ b/security/py-trezor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551380729
-SHA256 (trezor-0.11.2.tar.gz) = a6f4b47b37a21247535fc43411cb70a8c61ef0a5a2dfee668bd05611e2741fb8
-SIZE (trezor-0.11.2.tar.gz) = 1734569
+TIMESTAMP = 1559317549
+SHA256 (trezor-0.11.3.tar.gz) = c79a500e90d003073c8060d319dceb042caaba9472f13990c77ed37d04a82108
+SIZE (trezor-0.11.3.tar.gz) = 284074
diff --git a/security/py-trezor/files/patch-vendor_trezor-common_tools_coin__info.py b/security/py-trezor/files/patch-vendor_trezor-common_tools_coin__info.py
deleted file mode 100644
index 35a91c13bca6..000000000000
--- a/security/py-trezor/files/patch-vendor_trezor-common_tools_coin__info.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- vendor/trezor-common/tools/coin_info.py.orig 2018-11-08 13:20:31 UTC
-+++ vendor/trezor-common/tools/coin_info.py
-@@ -25,7 +25,7 @@ def load_json(*path):
- else:
- filename = os.path.join(DEFS_DIR, *path)
-
-- with open(filename) as f:
-+ with open(filename, encoding="utf-8") as f:
- return json.load(f, object_pairs_hook=OrderedDict)
-
-