aboutsummaryrefslogtreecommitdiff
path: root/security/py-yubikey-manager
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2018-03-13 13:13:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2018-03-13 13:13:27 +0000
commit3fbc9ca4dcf012c79a036d7807cd6e68f735eb50 (patch)
treeb57f96f44692221a614672c2eaca8a069f4e2da8 /security/py-yubikey-manager
parentd58b4763c34897a05612a8965fe58118a51668c5 (diff)
downloadports-3fbc9ca4dcf012c79a036d7807cd6e68f735eb50.tar.gz
ports-3fbc9ca4dcf012c79a036d7807cd6e68f735eb50.zip
Python library and command line tool for configuring any YubiKey over all USB
Notes
Notes: svn path=/head/; revision=464369
Diffstat (limited to 'security/py-yubikey-manager')
-rw-r--r--security/py-yubikey-manager/Makefile26
-rw-r--r--security/py-yubikey-manager/distinfo3
-rw-r--r--security/py-yubikey-manager/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/security/py-yubikey-manager/Makefile b/security/py-yubikey-manager/Makefile
new file mode 100644
index 000000000000..76079bdedc34
--- /dev/null
+++ b/security/py-yubikey-manager/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= yubikey-manager
+PORTVERSION= 0.6.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Python library and command line tool for configuring a YubiKey
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}usb>0:devel/py-usb@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${FLAVOR} \
+ pcsc-spy:devel/pcsc-lite \
+ ${LOCALBASE}/lib/pcsc/drivers/ifd-ccid.bundle/Contents/${OPSYS}/libccid.so:devel/libccid \
+ u2f-host:security/libu2f-host \
+ ykpers>0:security/ykpers
+
+USES= python:3.6
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-yubikey-manager/distinfo b/security/py-yubikey-manager/distinfo
new file mode 100644
index 000000000000..87eda08e8ddf
--- /dev/null
+++ b/security/py-yubikey-manager/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520944897
+SHA256 (yubikey-manager-0.6.0.tar.gz) = ab04a20832eed4312873fb25abaed7fe3040484e33a6a97ec33053ba37d1942c
+SIZE (yubikey-manager-0.6.0.tar.gz) = 77823
diff --git a/security/py-yubikey-manager/pkg-descr b/security/py-yubikey-manager/pkg-descr
new file mode 100644
index 000000000000..21c5db55a490
--- /dev/null
+++ b/security/py-yubikey-manager/pkg-descr
@@ -0,0 +1,4 @@
+Python library and command line tool for configuring any YubiKey over all USB
+transports.
+
+WWW: https://developers.yubico.com/yubikey-manager/