aboutsummaryrefslogtreecommitdiff
path: root/security/py-zope.app.security/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-22 14:38:23 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-22 14:38:23 +0000
commit8c626e09230941e99ed5d86611a334337c6de848 (patch)
tree9bb3a1aa1c9d1493f69ac975cd358035b46e53de /security/py-zope.app.security/Makefile
parentbe3d74a9526e83b5359571d061c07db0a384e324 (diff)
downloadports-8c626e09230941e99ed5d86611a334337c6de848.tar.gz
ports-8c626e09230941e99ed5d86611a334337c6de848.zip
Notes
Diffstat (limited to 'security/py-zope.app.security/Makefile')
-rw-r--r--security/py-zope.app.security/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/py-zope.app.security/Makefile b/security/py-zope.app.security/Makefile
new file mode 100644
index 000000000000..49f6fef9e1e8
--- /dev/null
+++ b/security/py-zope.app.security/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: py-zope.app.security
+# Date created: 22 December 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.app.security
+PORTVERSION= 3.7.5
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= ZMI Views For Zope3 Security Components
+
+LICENSE= ZPL21
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.app.localpermission>=0:${PORTSDIR}/security/py-zope.app.localpermission \
+ ${PYTHON_PKGNAMEPREFIX}zope.app.pagetemplate>=0:${PORTSDIR}/devel/py-zope.app.pagetemplate \
+ ${PYTHON_PKGNAMEPREFIX}zope.app.publisher>=0:${PORTSDIR}/devel/py-zope.app.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:${PORTSDIR}/security/py-zope.authentication \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18n>=0:${PORTSDIR}/devel/py-zope.i18n \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.principalregistry>=0:${PORTSDIR}/security/py-zope.principalregistry \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=3.12:${PORTSDIR}/devel/py-zope.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security \
+ ${PYTHON_PKGNAMEPREFIX}zope.securitypolicy>=0:${PORTSDIR}/security/py-zope.securitypolicy \
+ ${PYTHON_PKGNAMEPREFIX}zope.login>=0:${PORTSDIR}/security/py-zope.login
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>