aboutsummaryrefslogtreecommitdiff
path: root/security/qtkeychain
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-04-17 06:06:24 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-04-17 06:06:24 +0000
commit3b2488db112434b6dc7aa68d91678b636122e9d0 (patch)
treea0436715c3dbdf803c88539b16eb5fba495c53f7 /security/qtkeychain
parent3d560094c7a21ad0dc9969a024b70a8005f2b0b8 (diff)
downloadports-3b2488db112434b6dc7aa68d91678b636122e9d0.tar.gz
ports-3b2488db112434b6dc7aa68d91678b636122e9d0.zip
- add new port: security/qtkeychain
QtKeychain is a Qt API to store passwords and other secret data securely.How the data is stored depends on the platform. For Linux/Unix, KWallet (via D-Bus) is used. Support for the GNOME Keyring via freedesktop.org's Secret Storage D-Bus specification is planned but not yet implemented. WWW: https://github.com/frankosterfeld/qtkeychain PR: 177634 Submitted by: 6yearold@gmail.com Feature safe: yes
Notes
Notes: svn path=/head/; revision=315930
Diffstat (limited to 'security/qtkeychain')
-rw-r--r--security/qtkeychain/Makefile24
-rw-r--r--security/qtkeychain/distinfo2
-rw-r--r--security/qtkeychain/files/patch-auto_ptr.h11
-rw-r--r--security/qtkeychain/pkg-descr7
-rw-r--r--security/qtkeychain/pkg-plist12
5 files changed, 56 insertions, 0 deletions
diff --git a/security/qtkeychain/Makefile b/security/qtkeychain/Makefile
new file mode 100644
index 000000000000..41ba9b6b12ae
--- /dev/null
+++ b/security/qtkeychain/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= qtkeychain
+PORTVERSION= 0.1.0
+CATEGORIES= security
+
+MAINTAINER= 6yearold@gmail.com
+COMMENT= Platform independent Qt API for storing passwords
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= frankosterfeld
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= bb32e45
+
+USES= cmake
+USE_QT4= corelib dbus moc_build qmake_build rcc_build
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/security/qtkeychain/distinfo b/security/qtkeychain/distinfo
new file mode 100644
index 000000000000..29e5d4644469
--- /dev/null
+++ b/security/qtkeychain/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qtkeychain-0.1.0.tar.gz) = cf4fa0e9063d6df54c191e361566f5b6e5d3a5867fc0d9ab96954af393c939ef
+SIZE (qtkeychain-0.1.0.tar.gz) = 12834
diff --git a/security/qtkeychain/files/patch-auto_ptr.h b/security/qtkeychain/files/patch-auto_ptr.h
new file mode 100644
index 000000000000..7c74770b6262
--- /dev/null
+++ b/security/qtkeychain/files/patch-auto_ptr.h
@@ -0,0 +1,11 @@
+--- _keychain_dbus.cpp 2013-03-25 20:32:44.801564594 +0400
++++ keychain_dbus.cpp 2013-03-25 20:32:49.811561714 +0400
+@@ -10,7 +10,7 @@
+
+ #include <QSettings>
+
+-#include <auto_ptr.h>
++#include <memory>
+
+ using namespace QKeychain;
+
diff --git a/security/qtkeychain/pkg-descr b/security/qtkeychain/pkg-descr
new file mode 100644
index 000000000000..debb81eb4d9a
--- /dev/null
+++ b/security/qtkeychain/pkg-descr
@@ -0,0 +1,7 @@
+QtKeychain is a Qt API to store passwords and other secret data securely.How
+the data is stored depends on the platform.
+For Linux/Unix, KWallet (via D-Bus) is used. Support for the GNOME Keyring
+via freedesktop.org's Secret Storage D-Bus specification is planned
+but not yet implemented.
+
+WWW: https://github.com/frankosterfeld/qtkeychain
diff --git a/security/qtkeychain/pkg-plist b/security/qtkeychain/pkg-plist
new file mode 100644
index 000000000000..e5cdd64438de
--- /dev/null
+++ b/security/qtkeychain/pkg-plist
@@ -0,0 +1,12 @@
+include/qtkeychain/keychain.h
+include/qtkeychain/qkeychain_export.h
+lib/cmake/QtKeychain/QtKeychainConfig.cmake
+lib/cmake/QtKeychain/QtKeychainConfigVersion.cmake
+lib/cmake/QtKeychain/QtKeychainLibraryDepends-release.cmake
+lib/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
+lib/libqtkeychain.so
+lib/libqtkeychain.so.0
+lib/libqtkeychain.so.0.1.0
+@dirrm lib/cmake/QtKeychain
+@dirrmtry lib/cmake
+@dirrm include/qtkeychain