aboutsummaryrefslogtreecommitdiff
path: root/security/quantis-kmod
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-06-01 15:16:12 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-06-01 15:16:12 +0000
commit317438073539fc65b5eb77ceb0347d41ed87bc69 (patch)
tree51f71bf6747afc6a50d4307e3e890b6f5e6c5888 /security/quantis-kmod
parent193f33ad74a5b65349955e740b6388f124dfcd31 (diff)
downloadports-317438073539fc65b5eb77ceb0347d41ed87bc69.tar.gz
ports-317438073539fc65b5eb77ceb0347d41ed87bc69.zip
Quantis is a physical random number generator exploiting
an elementary quantum optics process. This port contains the kernel driver to access Quantis PCI and PCIe devices. WWW: http://www.idquantique.com/
Notes
Notes: svn path=/head/; revision=255456
Diffstat (limited to 'security/quantis-kmod')
-rw-r--r--security/quantis-kmod/Makefile52
-rw-r--r--security/quantis-kmod/distinfo3
-rw-r--r--security/quantis-kmod/pkg-descr10
-rw-r--r--security/quantis-kmod/pkg-message6
4 files changed, 71 insertions, 0 deletions
diff --git a/security/quantis-kmod/Makefile b/security/quantis-kmod/Makefile
new file mode 100644
index 000000000000..4eb55b95c315
--- /dev/null
+++ b/security/quantis-kmod/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: quantis-kmod
+# Date created: 10 May 2010
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quantis
+DISTVERSION= v10.06.01
+CATEGORIES= security kld
+MASTER_SITES= http://www.idquantique.com/files/products/quantis/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ale
+PKGNAMESUFFIX= -kmod
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Kernel driver for Quantis PCI/PCIe random number generator
+
+LICENSE_COMB= dual
+LICENSE= BSD GPLv2
+LICENSE_FILE= ${WRKDIR}/Quantis-${DISTVERSION}/License.txt
+
+USE_ZIP= yes
+EXTRACT_BEFORE_ARGS= -aqo
+
+WRKSRC= ${WRKDIR}/Quantis-${DISTVERSION}/Drivers/Unix/QuantisPci
+
+KMODDIR?= /boot/modules
+
+SRC_BASE?= /usr/src
+
+MAKE_ENV+= KMODDIR=${KMODDIR}
+
+PLIST_FILES= "@cwd ${KMODDIR}" \
+ "quantis.ko" \
+ "@unexec kldxref ${KMODDIR}" \
+ "@cwd ${PREFIX}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+IGNORE= requires FreeBSD >= 7
+.endif
+
+.if !exists(${SRC_BASE}/sys/Makefile)
+IGNORE= requires kernel source to be installed
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/quantis-kmod/distinfo b/security/quantis-kmod/distinfo
new file mode 100644
index 000000000000..d2fbc8709c0c
--- /dev/null
+++ b/security/quantis-kmod/distinfo
@@ -0,0 +1,3 @@
+MD5 (quantis-v10.06.01.zip) = 56b307d4f6930356adbe8d91d4c7a5a0
+SHA256 (quantis-v10.06.01.zip) = 7992d65990c3c174f5e579e6d6555dc6fc42dc53b2dd7110bd637d706d4f4953
+SIZE (quantis-v10.06.01.zip) = 1160026
diff --git a/security/quantis-kmod/pkg-descr b/security/quantis-kmod/pkg-descr
new file mode 100644
index 000000000000..27e3f69e65d7
--- /dev/null
+++ b/security/quantis-kmod/pkg-descr
@@ -0,0 +1,10 @@
+Quantis is a physical random number generator exploiting
+an elementary quantum optics process.
+
+This port contains the kernel driver to access Quantis
+PCI and PCIe devices.
+
+WWW: http://www.idquantique.com/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/security/quantis-kmod/pkg-message b/security/quantis-kmod/pkg-message
new file mode 100644
index 000000000000..fe487ef1871d
--- /dev/null
+++ b/security/quantis-kmod/pkg-message
@@ -0,0 +1,6 @@
+*******************************************************
+
+Add quantis_load="YES" to /boot/loader.conf to load the
+kernel module automatically.
+
+*******************************************************