aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2009-02-23 03:16:29 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2009-02-23 03:16:29 +0000
commit81e2940bccaed74f3a943e6ebcff6954e81c88ed (patch)
tree446942b02083cacb783e353c046012fd4149dd01 /security/racoon2
parentebe2efd71a7503e5e21e04d71c549ec8d8138d76 (diff)
downloadports-81e2940bccaed74f3a943e6ebcff6954e81c88ed.tar.gz
ports-81e2940bccaed74f3a943e6ebcff6954e81c88ed.zip
Notes
Diffstat (limited to 'security/racoon2')
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/racoon2/files/patch-lib-cfsetup.c27
2 files changed, 28 insertions, 1 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index f462262fd268..44661498e2dc 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= racoon2
PORTVERSION= 20071227e
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.racoon2.wide.ad.jp/pub/racoon2/
EXTRACT_SUFX= .tgz
diff --git a/security/racoon2/files/patch-lib-cfsetup.c b/security/racoon2/files/patch-lib-cfsetup.c
new file mode 100644
index 000000000000..e670f0c29d97
--- /dev/null
+++ b/security/racoon2/files/patch-lib-cfsetup.c
@@ -0,0 +1,27 @@
+--- lib/cfsetup.c.orig 2007-12-05 16:26:10.000000000 +0900
++++ lib/cfsetup.c 2009-02-23 12:10:53.000000000 +0900
+@@ -3636,15 +3636,15 @@
+ "invalid kmp type %s\n", rct2str(proto));
+ return -1;
+ }
+- if (!kmp || !kmp->peers_ipaddr)
+- return -1;
+- for (al = kmp->peers_ipaddr; al != 0; al = al->next) {
+- if (al->type != RCT_ADDR_INET)
+- continue;
+- if (rcs_cmpsa_wop(al->a.ipaddr, s) != 0)
+- continue;
+- src = n;
+- goto found;
++ if (kmp && kmp->peers_ipaddr) {
++ for (al = kmp->peers_ipaddr; al != 0; al = al->next) {
++ if (al->type != RCT_ADDR_INET)
++ continue;
++ if (rcs_cmpsa_wop(al->a.ipaddr, s) != 0)
++ continue;
++ src = n;
++ goto found;
++ }
+ }
+ }
+ found: