aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-10-23 06:39:00 +0000
committerCy Schubert <cy@FreeBSD.org>2014-10-23 06:39:00 +0000
commitf76e89f6f2a76274ebe3623474745d824cdfd612 (patch)
tree0afd9e01599e010a6ffd4e25665893e719619b71 /security/racoon2
parente3d9d9f4258788a0692e73df9b17535be1198daa (diff)
downloadports-f76e89f6f2a76274ebe3623474745d824cdfd612.tar.gz
ports-f76e89f6f2a76274ebe3623474745d824cdfd612.zip
Add hack to address wrong security index.
Submitted by: Denis Ahrens <denis@h3q.com> Obtained from: http://www.racoon2.wide.ad.jp/ml/racoon2-users/201008/msg804.html
Notes
Notes: svn path=/head/; revision=371377
Diffstat (limited to 'security/racoon2')
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/racoon2/files/patch-iked__ikev2_child.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 1ba3a1ba215b..dfd920540774 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= racoon2
PORTVERSION= 20100526a
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.racoon2.wide.ad.jp/pub/racoon2/
diff --git a/security/racoon2/files/patch-iked__ikev2_child.c b/security/racoon2/files/patch-iked__ikev2_child.c
new file mode 100644
index 000000000000..548f132e011a
--- /dev/null
+++ b/security/racoon2/files/patch-iked__ikev2_child.c
@@ -0,0 +1,11 @@
+--- iked/ikev2_child.c.orig 2008-09-10 01:30:58.000000000 -0700
++++ iked/ikev2_child.c 2014-10-22 23:33:18.140601874 -0700
+@@ -1171,7 +1171,7 @@
+ * used to do update or add.
+ */
+ param->flags = 0;
+- if (child_sa->is_initiator)
++ if (child_sa->is_initiator && child_sa->preceding_satype == 0)
+ param->flags |= PFK_FLAG_NOPORTS;
+
+ param->wsize = ikev2_ipsec_window_size;