aboutsummaryrefslogtreecommitdiff
path: root/security/ratproxy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-08 21:35:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-08 21:35:23 +0000
commit19fd4a8b23585fa4e0427c34fc20ce08e0e4a782 (patch)
tree84bbfadc4f2baf19eb7e129e604be15f0059e629 /security/ratproxy
parent191fca0e5b5434e0b9bd7326ea573f2f625bde22 (diff)
downloadports-19fd4a8b23585fa4e0427c34fc20ce08e0e4a782.tar.gz
ports-19fd4a8b23585fa4e0427c34fc20ce08e0e4a782.zip
Ratproxy is a semi-automated, largely passive web application security audit
tool. It is meant to complement active crawlers and manual proxies more commonly used for this task, and is optimized specifically for an accurate and sensitive detection, and automatic annotation, of potential problems and security-relevant design patterns based on the observation of existing, user-initiated traffic in complex web 2.0 environments. WWW: http://code.google.com/p/ratproxy/ PR: ports/125249 Submitted by: Steven Kreuzer <skreuzer@exit2shell.com>
Notes
Notes: svn path=/head/; revision=216561
Diffstat (limited to 'security/ratproxy')
-rw-r--r--security/ratproxy/Makefile28
-rw-r--r--security/ratproxy/distinfo3
-rw-r--r--security/ratproxy/files/patch-Makefile22
-rw-r--r--security/ratproxy/pkg-descr8
4 files changed, 61 insertions, 0 deletions
diff --git a/security/ratproxy/Makefile b/security/ratproxy/Makefile
new file mode 100644
index 000000000000..376cb54becb2
--- /dev/null
+++ b/security/ratproxy/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ratproxy
+# Date created: 3 July 2008
+# Whom: Steven Kreuzer <skreuzer@exit2shell.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ratproxy
+PORTVERSION= 1.51
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= skreuzer@exit2shell.com
+COMMENT= Semi-automated, largely passive web application security audit tool
+
+USE_OPENSSL= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/ratproxy \
+ bin/ratproxy-report.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#-Wno-pointer-sign##g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ratproxy ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ratproxy-report.sh ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/ratproxy/distinfo b/security/ratproxy/distinfo
new file mode 100644
index 000000000000..12a6054df249
--- /dev/null
+++ b/security/ratproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (ratproxy-1.51.tar.gz) = 40e47c86c8beaf01dabe4eae9458cf13
+SHA256 (ratproxy-1.51.tar.gz) = f58a40d021988874c1bac177413c7b07b985721ff1282cd6734623c08fed634b
+SIZE (ratproxy-1.51.tar.gz) = 168409
diff --git a/security/ratproxy/files/patch-Makefile b/security/ratproxy/files/patch-Makefile
new file mode 100644
index 000000000000..89f7a01ba9a2
--- /dev/null
+++ b/security/ratproxy/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig 2008-07-03 23:38:31.000000000 -0400
++++ Makefile 2008-07-03 23:38:53.000000000 -0400
+@@ -23,18 +23,10 @@
+ CFLAGS = -Wall -O3 -Wno-pointer-sign -D_GNU_SOURCE
+ LDFLAGS = -lcrypto -lssl
+
+-all: $(PROGNAME) flare-check
++all: $(PROGNAME)
+
+ $(PROGNAME): $(PROGNAME).c http.c mime.c ssl.c http.h mime.h ssl.h nlist.h config.h debug.h types.h string-inl.h
+ $(CC) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS) http.c mime.c ssl.c $(LDFLAGS)
+
+-flare-check:
+- @flare-dist/flare 2>&1 | grep -qF Igor || ( \
+- echo; \
+- echo '*** WARNING: 'flare-dist/flare' bianry is not operational.'; \
+- echo '*** Please see flare-dist/README and update it for your OS.'; \
+- echo )
+-
+ clean:
+ rm -f $(PROGNAME) *.exe *.o *~ a.out core core.[1-9][0-9]* *.stackdump
+-
diff --git a/security/ratproxy/pkg-descr b/security/ratproxy/pkg-descr
new file mode 100644
index 000000000000..b27b224bb762
--- /dev/null
+++ b/security/ratproxy/pkg-descr
@@ -0,0 +1,8 @@
+Ratproxy is a semi-automated, largely passive web application security audit
+tool. It is meant to complement active crawlers and manual proxies more
+commonly used for this task, and is optimized specifically for an accurate and
+sensitive detection, and automatic annotation, of potential problems and
+security-relevant design patterns based on the observation of existing,
+user-initiated traffic in complex web 2.0 environments.
+
+WWW: http://code.google.com/p/ratproxy/