aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-clamavNugget
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-20 17:32:02 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-20 17:32:02 +0000
commit2e1ad47c4891f43dc64d1a071adfa70088680544 (patch)
treea9f6a58c59f2bea8f61695460936cf1723b431f3 /security/razorback-clamavNugget
parentb5c22bf1e247d25c6a053a435ac32e93de2eaee8 (diff)
downloadports-2e1ad47c4891f43dc64d1a071adfa70088680544.tar.gz
ports-2e1ad47c4891f43dc64d1a071adfa70088680544.zip
security/razorback-clamavNugget: Chase json-c update (Unbreak)
Notes
Notes: svn path=/head/; revision=365490
Diffstat (limited to 'security/razorback-clamavNugget')
-rw-r--r--security/razorback-clamavNugget/Makefile5
-rw-r--r--security/razorback-clamavNugget/files/patch-common__m4_api__deps.m411
-rw-r--r--security/razorback-clamavNugget/files/patch-common__m4_compiler__options.m411
3 files changed, 25 insertions, 2 deletions
diff --git a/security/razorback-clamavNugget/Makefile b/security/razorback-clamavNugget/Makefile
index 2849dabd3f13..ad3b62e77616 100644
--- a/security/razorback-clamavNugget/Makefile
+++ b/security/razorback-clamavNugget/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clamavNugget
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
@@ -16,14 +16,15 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api \
+ libjson-c.so:${PORTSDIR}/devel/json-c \
libclamav.so:${PORTSDIR}/security/clamav
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
-
USES= libtool pkgconfig
RB_LIBDIR?= ${PREFIX}/lib/razorback
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf
USE_LDCONFIG= ${RB_LIBDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/security/razorback-clamavNugget/files/patch-common__m4_api__deps.m4 b/security/razorback-clamavNugget/files/patch-common__m4_api__deps.m4
new file mode 100644
index 000000000000..b424f894f261
--- /dev/null
+++ b/security/razorback-clamavNugget/files/patch-common__m4_api__deps.m4
@@ -0,0 +1,11 @@
+--- common_m4/api_deps.m4.orig 2012-04-16 18:59:44 UTC
++++ common_m4/api_deps.m4
+@@ -55,7 +55,7 @@ LIBS="$LIBCONFIG_LIBS $LIBS"
+ # [AC_MSG_ERROR("curl header file not found")]
+ # )
+
+-PKG_CHECK_MODULES([JSON], [json >= 0.9])
++PKG_CHECK_MODULES([JSON], [json-c >= 0.9])
+
+ CFLAGS="$JSON_CFLAGS $CFLAGS"
+ LIBS="$JSON_LIBS $LIBS"
diff --git a/security/razorback-clamavNugget/files/patch-common__m4_compiler__options.m4 b/security/razorback-clamavNugget/files/patch-common__m4_compiler__options.m4
new file mode 100644
index 000000000000..8e2572727b90
--- /dev/null
+++ b/security/razorback-clamavNugget/files/patch-common__m4_compiler__options.m4
@@ -0,0 +1,11 @@
+--- common_m4/compiler_options.m4.orig 2012-01-04 18:17:09 UTC
++++ common_m4/compiler_options.m4
+@@ -28,7 +28,7 @@ if test "$GCC" = yes ; then
+
+ CFLAGS="$CFLAGS -std=c99 -fno-strict-aliasing"
+ CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"
+- CWARNINGS="$CWARNINGS -Wall -Werror -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
++ CWARNINGS="$CWARNINGS -Wall -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
+ if test "x$NOT_PEDANTIC" = "x"; then
+ CWARNINGS="$CWARNINGS -pedantic"
+ fi