aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-pdfFox
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-11 13:15:40 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-11 13:15:40 +0000
commit99e468206f5a6555a51ea9cfcbceca08f33a67ef (patch)
treeca77c17674d37b8685a9a36ea99899d2dd284911 /security/razorback-pdfFox
parent63a1f846274279aefe957d38dd16b442c53ed3f6 (diff)
downloadports-99e468206f5a6555a51ea9cfcbceca08f33a67ef.tar.gz
ports-99e468206f5a6555a51ea9cfcbceca08f33a67ef.zip
Notes
Diffstat (limited to 'security/razorback-pdfFox')
-rw-r--r--security/razorback-pdfFox/Makefile51
-rw-r--r--security/razorback-pdfFox/distinfo2
-rw-r--r--security/razorback-pdfFox/pkg-descr8
-rw-r--r--security/razorback-pdfFox/pkg-plist11
4 files changed, 72 insertions, 0 deletions
diff --git a/security/razorback-pdfFox/Makefile b/security/razorback-pdfFox/Makefile
new file mode 100644
index 000000000000..a5ffc8d0043d
--- /dev/null
+++ b/security/razorback-pdfFox/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: razorback-archiveInflate
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfFox
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - PDF Fox
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+
+OPTIONS_DEFINE= DEBUG ASSERT
+ASSERT_DESC= Enable Asserts
+
+.include <bsd.port.options.mk>
+
+RB_LIBDIR?= ${PREFIX}/lib/razorback
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= ${RB_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ ${LN} -sf ${RB_LIBDIR}/pdfFox.so.2 ${RB_LIBDIR}/pdfFox.so.2.0.0
+ @if [ ! -f ${PREFIX}/etc/razorback/pdffox.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/pdffox.conf.sample ${PREFIX}/etc/razorback/pdffox.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-pdfFox/distinfo b/security/razorback-pdfFox/distinfo
new file mode 100644
index 000000000000..7dce9ae28e2b
--- /dev/null
+++ b/security/razorback-pdfFox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/pdfFox-0.5.0.tar.gz) = 41dedc45791534d3b62b2915ffa1bea7d9bc6a79f6f4d42100846bb49c525358
+SIZE (razorback/pdfFox-0.5.0.tar.gz) = 340417
diff --git a/security/razorback-pdfFox/pkg-descr b/security/razorback-pdfFox/pkg-descr
new file mode 100644
index 000000000000..36931779eb82
--- /dev/null
+++ b/security/razorback-pdfFox/pkg-descr
@@ -0,0 +1,8 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+This nugget is an open-source PDF analyzer that does not require an
+external commercial application to function.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-pdfFox/pkg-plist b/security/razorback-pdfFox/pkg-plist
new file mode 100644
index 000000000000..fddb706d0cda
--- /dev/null
+++ b/security/razorback-pdfFox/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+@unexec if cmp -s %D/etc/razorback/pdffox.conf %D/etc/razorback/pdffox.conf.sample; then rm -f %D/etc/razorback/pdffox.conf; fi
+etc/razorback/pdffox.conf.sample
+@exec if [ ! -f %D/etc/razorback/pdffox.conf ]; then cp -p %D/%F %B/pdffox.conf; fi
+@dirrmtry etc/razorback
+lib/razorback/pdfFox.so.2.0.0
+lib/razorback/pdfFox.so.2
+lib/razorback/pdfFox.so
+lib/razorback/pdfFox.la
+lib/razorback/pdfFox.a
+@dirrmtry lib/razorback