aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-scriptNugget
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-11 16:52:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-11 16:52:30 +0000
commit64f3670d91c2aabad7a652600b8c18e2bf839507 (patch)
tree05090bf3e94de069c68820d2fb5772aefe1257fb /security/razorback-scriptNugget
parent740037b316fa91650985048cd0239d813da5d70f (diff)
downloadports-64f3670d91c2aabad7a652600b8c18e2bf839507.tar.gz
ports-64f3670d91c2aabad7a652600b8c18e2bf839507.zip
- Add staging support
- COnvert to new LIB_DEPENDS format, options helpers, USES=libtool - Use @sample for config file
Notes
Notes: svn path=/head/; revision=361566
Diffstat (limited to 'security/razorback-scriptNugget')
-rw-r--r--security/razorback-scriptNugget/Makefile31
-rw-r--r--security/razorback-scriptNugget/pkg-plist6
2 files changed, 11 insertions, 26 deletions
diff --git a/security/razorback-scriptNugget/Makefile b/security/razorback-scriptNugget/Makefile
index 3d58a4ecc5a4..c55623db13a9 100644
--- a/security/razorback-scriptNugget/Makefile
+++ b/security/razorback-scriptNugget/Makefile
@@ -3,51 +3,40 @@
PORTNAME= scriptNugget
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
DIST_SUBDIR= razorback
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for an intelligence driven security - Scripting Interface
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
rubygem-razorback-scriptNugget>=0.5.0:${PORTSDIR}/security/rubygem-razorback-scriptNugget
-OPTIONS_DEFINE= DEBUG ASSERT
-ASSERT_DESC= Enable Asserts
-
RB_LIBDIR?= ${PREFIX}/lib/razorback
-USES= pkgconfig
+USES= libtool pkgconfig
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ruby
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= ${RB_LIBDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-debug
-.endif
+OPTIONS_DEFINE= DEBUG ASSERT
-.if ${PORT_OPTIONS:MASSERT}
-CONFIGURE_ARGS+=--enable-assert
-.endif
+ASSERT_DESC= Enable Asserts
+ASSERT_CONFIGURE_ENABLE= assert
+DEBUG_CONFIGURE_ENABLE= debug
post-install:
- ${LN} -sf ${RB_LIBDIR}/scriptNugget.so.2 ${RB_LIBDIR}/scriptNugget.so.2.0.0
- @if [ ! -f ${PREFIX}/etc/razorback/scriptNugget.conf ]; then \
- ${CP} -p ${PREFIX}/etc/razorback/scriptNugget.conf.sample ${PREFIX}/etc/razorback/scriptNugget.conf ; \
- fi
+ ${LN} -sf ${RB_LIBDIR}/scriptNugget.so.2 \
+ ${STAGEDIR}${RB_LIBDIR}/scriptNugget.so.2.0.0
.include <bsd.port.mk>
diff --git a/security/razorback-scriptNugget/pkg-plist b/security/razorback-scriptNugget/pkg-plist
index 0b55ef87d65d..918a2a0c01a4 100644
--- a/security/razorback-scriptNugget/pkg-plist
+++ b/security/razorback-scriptNugget/pkg-plist
@@ -1,11 +1,7 @@
-@unexec if cmp -s %D/etc/razorback/scriptNugget.conf %D/etc/razorback/scriptNugget.conf.sample; then rm -f %D/etc/razorback/scriptNugget.conf; fi
-etc/razorback/scriptNugget.conf.sample
-@exec if [ ! -f %D/etc/razorback/scriptNugget.conf ] ; then cp -p %D/%F %B/scriptNugget.conf; fi
-@dirrmtry etc/razorback
+@sample etc/razorback/scriptNugget.conf.sample
lib/razorback/scriptNugget.so.2.0.0
lib/razorback/scriptNugget.so.2
lib/razorback/scriptNugget.so
-lib/razorback/scriptNugget.la
lib/razorback/scriptNugget.a
@dirrmtry lib/razorback
libexec/razorback/scriptNugget/test.rb