aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-swfScanner
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-11 03:04:32 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-11 03:04:32 +0000
commita37ec24405518060bc65e3f8605782aee113a95a (patch)
treecf0e5b1f95fc605ca9f4448906315ca2918357bf /security/razorback-swfScanner
parentadb7cdd26fb3be08580f3bd0c189264f4040505f (diff)
downloadports-a37ec24405518060bc65e3f8605782aee113a95a.tar.gz
ports-a37ec24405518060bc65e3f8605782aee113a95a.zip
New port: security/razorback-swfScanner:
Razorback is a framework for an intelligence driven security solution. It consists of a Dispatcher at the core of the system, surrounded by Nuggets of varying types. SWF Nugget is a Razorback Detection Nugget that scans Flash files collected by Razorback Collector Nuggets. SWF Nugget decompresses (as necessary) and parses Flash files to detect attacks exploiting known vulnerabilities. The scan results are sent back to Razorback Dispatcher to correlate with other Razorback Nuggets. WWW: http://razorbacktm.sourceforge.net/ PR: ports/167753 Submitted by: Tom Judge <tom@tomjudge.com>
Notes
Notes: svn path=/head/; revision=299003
Diffstat (limited to 'security/razorback-swfScanner')
-rw-r--r--security/razorback-swfScanner/Makefile51
-rw-r--r--security/razorback-swfScanner/distinfo2
-rw-r--r--security/razorback-swfScanner/pkg-descr13
-rw-r--r--security/razorback-swfScanner/pkg-plist11
4 files changed, 77 insertions, 0 deletions
diff --git a/security/razorback-swfScanner/Makefile b/security/razorback-swfScanner/Makefile
new file mode 100644
index 000000000000..e39a6d1f1bb9
--- /dev/null
+++ b/security/razorback-swfScanner/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: razorback-swfScanner
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swfScanner
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - SWF Detection
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+
+OPTIONS_DEFINE= DEBUG ASSERT
+ASSERT_DESC= Enable Asserts
+
+.include <bsd.port.options.mk>
+
+RB_LIBDIR?= ${PREFIX}/lib/razorback
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= ${RB_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ ${LN} -sf ${RB_LIBDIR}/swfScanner.so.2 ${RB_LIBDIR}/swfScanner.so.2.0.0
+ @if [ ! -f ${PREFIX}/etc/razorback/swf_scanner.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/swf_scanner.conf.sample ${PREFIX}/etc/razorback/swf_scanner.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-swfScanner/distinfo b/security/razorback-swfScanner/distinfo
new file mode 100644
index 000000000000..11d3efa6113c
--- /dev/null
+++ b/security/razorback-swfScanner/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/swfScanner-0.5.0.tar.gz) = 4e8baacc0f5e467b9703f5156aebb2e2cbfc2d6dc33f827e5bd75af8b0c3f414
+SIZE (razorback/swfScanner-0.5.0.tar.gz) = 324949
diff --git a/security/razorback-swfScanner/pkg-descr b/security/razorback-swfScanner/pkg-descr
new file mode 100644
index 000000000000..27ad72ad832f
--- /dev/null
+++ b/security/razorback-swfScanner/pkg-descr
@@ -0,0 +1,13 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+SWF Nugget is a Razorback Detection Nugget that scans Flash files
+collected by Razorback Collector Nuggets. SWF Nugget decompresses
+(as necessary) and parses Flash files to detect attacks exploiting
+known vulnerabilities.
+
+The scan results are sent back to Razorback Dispatcher to correlate
+with other Razorback Nuggets.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-swfScanner/pkg-plist b/security/razorback-swfScanner/pkg-plist
new file mode 100644
index 000000000000..1df2919664c3
--- /dev/null
+++ b/security/razorback-swfScanner/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+@unexec if cmp -s %D/etc/razorback/swf_scanner.conf %D/etc/razorback/swf_scanner.conf.sample; then rm -f %D/etc/razorback/swf_scanner.conf; fi
+etc/razorback/swf_scanner.conf.sample
+@exec if [ ! -f %D/etc/razorback/swf_scanner.conf ] ; then cp -p %D/%F %B/swf_scanner.conf; fi
+@dirrmtry etc/razorback
+lib/razorback/swfScanner.so.2.0.0
+lib/razorback/swfScanner.so.2
+lib/razorback/swfScanner.so
+lib/razorback/swfScanner.la
+lib/razorback/swfScanner.a
+@dirrmtry lib/razorback