aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-virusTotal
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-11 13:36:35 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-11 13:36:35 +0000
commitc2816b1cdb88109d677a284af5f76c412a9a3392 (patch)
treeb0c28b9fe2ca6319639bb0be209a4ead8a5badd3 /security/razorback-virusTotal
parent16c8d52e523f3aa2473a54fe7cb999df5fff6398 (diff)
Notes
Diffstat (limited to 'security/razorback-virusTotal')
-rw-r--r--security/razorback-virusTotal/Makefile52
-rw-r--r--security/razorback-virusTotal/distinfo2
-rw-r--r--security/razorback-virusTotal/pkg-descr9
-rw-r--r--security/razorback-virusTotal/pkg-plist11
4 files changed, 74 insertions, 0 deletions
diff --git a/security/razorback-virusTotal/Makefile b/security/razorback-virusTotal/Makefile
new file mode 100644
index 000000000000..3603a5ae9499
--- /dev/null
+++ b/security/razorback-virusTotal/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: razorback-virusTotal
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= virusTotal
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - Virus Total Detection
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api \
+ json:${PORTSDIR}/devel/json-c
+BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
+
+OPTIONS_DEFINE= DEBUG ASSERT
+ASSERT_DESC= Enable Asserts
+
+.include <bsd.port.options.mk>
+
+RB_LIBDIR?= ${PREFIX}/lib/razorback
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= ${RB_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MASSERT}
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ ${LN} -sf ${RB_LIBDIR}/virusTotal.so.2 ${RB_LIBDIR}/virusTotal.so.2.0.0
+ @if [ ! -f ${PREFIX}/etc/razorback/virustotal.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/virustotal.conf.sample ${PREFIX}/etc/razorback/virustotal.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-virusTotal/distinfo b/security/razorback-virusTotal/distinfo
new file mode 100644
index 000000000000..78e24f80ec60
--- /dev/null
+++ b/security/razorback-virusTotal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/virusTotal-0.5.0.tar.gz) = ecc89bea58b8314ba28642d07a5d923d8e796f5eee8e912e6c3bdd3f87db8255
+SIZE (razorback/virusTotal-0.5.0.tar.gz) = 318982
diff --git a/security/razorback-virusTotal/pkg-descr b/security/razorback-virusTotal/pkg-descr
new file mode 100644
index 000000000000..2516f0a0640e
--- /dev/null
+++ b/security/razorback-virusTotal/pkg-descr
@@ -0,0 +1,9 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+This nugget checks the VirusTotal API for the MD5 of the submitted file.
+If the file is found, the short data of the alert will contain the results
+from the JSON response from VirusTotal.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-virusTotal/pkg-plist b/security/razorback-virusTotal/pkg-plist
new file mode 100644
index 000000000000..5996799a31ec
--- /dev/null
+++ b/security/razorback-virusTotal/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+@unexec if cmp -s %D/etc/razorback/virustotal.conf %D/etc/razorback/virustotal.conf.sample; then rm -f %D/etc/razorback/virustotal.conf; fi
+etc/razorback/virustotal.conf.sample
+@exec if [ ! -f %D/etc/razorback/virustotal.conf ] ; then cp -p %D/%F %B/virustotal.conf; fi
+@dirrmtry etc/razorback
+lib/razorback/virusTotal.so.2.0.0
+lib/razorback/virusTotal.so.2
+lib/razorback/virusTotal.so
+lib/razorback/virusTotal.la
+lib/razorback/virusTotal.a
+@dirrmtry lib/razorback