aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-bcrypt-ruby
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-30 12:08:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-30 12:08:25 +0000
commitac1cb23d593bc6d57ea00c06e0b86d556dd6550d (patch)
treea16bab43989157d651fb34a9830a0aaa8dadcd9b /security/rubygem-bcrypt-ruby
parent344c7ae7b62b56df01f3047984bcf9120c1e3d47 (diff)
downloadports-ac1cb23d593bc6d57ea00c06e0b86d556dd6550d.tar.gz
ports-ac1cb23d593bc6d57ea00c06e0b86d556dd6550d.zip
bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD
project for hashing passwords. bcrypt-ruby provides a simple, humane wrapper for safely handling passwords. WWW: http://rubygems.org/gems/bcrypt-ruby PR: ports/153965 Submitted by: Jason Helfman <jhelfman at experts-exchange.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=268439
Diffstat (limited to 'security/rubygem-bcrypt-ruby')
-rw-r--r--security/rubygem-bcrypt-ruby/Makefile21
-rw-r--r--security/rubygem-bcrypt-ruby/distinfo2
-rw-r--r--security/rubygem-bcrypt-ruby/pkg-descr5
3 files changed, 28 insertions, 0 deletions
diff --git a/security/rubygem-bcrypt-ruby/Makefile b/security/rubygem-bcrypt-ruby/Makefile
new file mode 100644
index 000000000000..1121cf56d163
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-bcrypt-ruby
+# Date created: 13 January 2011
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+
+PORTNAME= bcrypt-ruby
+PORTVERSION= 2.1.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= Sophisticated and secure hash algorithm for passwords
+
+RUN_DEPENDS+= bcrypt:${PORTSDIR}/security/bcrypt
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-bcrypt-ruby/distinfo b/security/rubygem-bcrypt-ruby/distinfo
new file mode 100644
index 000000000000..b54f93374d80
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bcrypt-ruby-2.1.4.gem) = 6198fa6c0c1a2c2fc437e03f956866fa82e2178f4d4006ce5a77823e4643d853
+SIZE (rubygem/bcrypt-ruby-2.1.4.gem) = 39424
diff --git a/security/rubygem-bcrypt-ruby/pkg-descr b/security/rubygem-bcrypt-ruby/pkg-descr
new file mode 100644
index 000000000000..0b6168daf640
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/pkg-descr
@@ -0,0 +1,5 @@
+bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD
+project for hashing passwords. bcrypt-ruby provides a simple, humane wrapper
+for safely handling passwords.
+
+WWW: http://rubygems.org/gems/bcrypt-ruby