aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-net-ssh5
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2020-06-16 07:53:28 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2020-06-16 07:53:28 +0000
commit94f5eb0492ac8e4ab98fe567262ff20c73b0b22a (patch)
tree730efb669a15ed8ec271436ca9e29f452c7db5e9 /security/rubygem-net-ssh5
parente6aea60464090702d6e802f747856c5b11d5644c (diff)
Notes
Diffstat (limited to 'security/rubygem-net-ssh5')
-rw-r--r--security/rubygem-net-ssh5/Makefile31
-rw-r--r--security/rubygem-net-ssh5/distinfo3
-rw-r--r--security/rubygem-net-ssh5/pkg-descr11
3 files changed, 45 insertions, 0 deletions
diff --git a/security/rubygem-net-ssh5/Makefile b/security/rubygem-net-ssh5/Makefile
new file mode 100644
index 000000000000..14bbb442dcbe
--- /dev/null
+++ b/security/rubygem-net-ssh5/Makefile
@@ -0,0 +1,31 @@
+# Created by: Roderick van Domburg <r.s.a.vandomburg@student.utwente.nl>
+# $FreeBSD$
+
+PORTNAME= net-ssh
+PORTVERSION= 5.2.0
+PORTEPOCH= 2
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 5
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Non-interactive SSH processing
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem shebangfix
+USE_RUBY= yes
+
+OPTIONS_DEFINE= PROMPT_PASSPHRASES
+OPTIONS_DEFAULT=PROMPT_PASSPHRASES
+PROMPT_PASSPHRASES_DESC= Prompt for passphrases on keys
+
+SHEBANG_FILES= support/ssh_tunnel_bug.rb
+NO_ARCH= yes
+
+PROMPT_PASSPHRASES_RUN_DEPENDS= rubygem-ruby-termios>=0:comms/rubygem-ruby-termios
+
+PORTSCOUT= limit:^5\.
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh5/distinfo b/security/rubygem-net-ssh5/distinfo
new file mode 100644
index 000000000000..b2f779ec87b1
--- /dev/null
+++ b/security/rubygem-net-ssh5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1564249766
+SHA256 (rubygem/net-ssh-5.2.0.gem) = 80a8a71d39e9f917ed265f66c0c5985f1849fc5e7156ac48f14dd1d4af683c80
+SIZE (rubygem/net-ssh-5.2.0.gem) = 132608
diff --git a/security/rubygem-net-ssh5/pkg-descr b/security/rubygem-net-ssh5/pkg-descr
new file mode 100644
index 000000000000..04aedca23f31
--- /dev/null
+++ b/security/rubygem-net-ssh5/pkg-descr
@@ -0,0 +1,11 @@
+Net::SSH is a pure-Ruby implementation of the SSH2 client protocol. It
+supports the following features:
+
+ - User authentication via explicit username/password, or using a
+ public-key/private-key pair.
+ - Port forwarding, both from the local host to a remote computer via
+ the remote host, and from the remote host to the local host.
+ - Execute processes on the remote machine, both interactively and
+ non-interactively ("batch").
+
+WWW: https://github.com/net-ssh/net-ssh