aboutsummaryrefslogtreecommitdiff
path: root/security/s2n
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
commit5b55a8a53e383d5e641472b56a6d631e59da3967 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /security/s2n
parent769a9f1570ce818b49b6170bf5745363ffbe79e0 (diff)
downloadports-5b55a8a53e383d5e641472b56a6d631e59da3967.tar.gz
ports-5b55a8a53e383d5e641472b56a6d631e59da3967.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Notes
Notes: svn path=/head/; revision=416966
Diffstat (limited to 'security/s2n')
-rw-r--r--security/s2n/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/s2n/Makefile b/security/s2n/Makefile
index 4906c583b948..2a09e79fc592 100644
--- a/security/s2n/Makefile
+++ b/security/s2n/Makefile
@@ -17,17 +17,17 @@ GH_TAGNAME= c6da8bb
OPTIONS_DEFINE= DOCS EXAMPLES
USES= gmake
+USE_OPENSSL=yes
USE_LDCONFIG= yes
NO_CONFIGURE= yes
SUB_FILES= pkg-message Makefile
ALL_TARGET= bin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.endif
@@ -50,4 +50,4 @@ do-install:
tests: build
${GMAKE} PLATFORM=FreeBSD CRYPTO_LDFLAGS=-L${LOCALBASE}/lib -C ${WRKSRC}/tests
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>