aboutsummaryrefslogtreecommitdiff
path: root/security/samhain
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2012-11-21 20:36:28 +0000
committerDavid Thiel <lx@FreeBSD.org>2012-11-21 20:36:28 +0000
commit0a7059d58566111ba0bb6767f6ddb5645369aaf5 (patch)
tree01219ea34e7e658ab2c26bd90fe918ab7e6654b9 /security/samhain
parentb4be86ec54a9f75d1257e8f130d92e4e7776c6e0 (diff)
downloadports-0a7059d58566111ba0bb6767f6ddb5645369aaf5.tar.gz
ports-0a7059d58566111ba0bb6767f6ddb5645369aaf5.zip
Update to 3.0.8, unbreak with utmpx.
Feature safe: Yes
Notes
Notes: svn path=/head/; revision=307624
Diffstat (limited to 'security/samhain')
-rw-r--r--security/samhain/Makefile4
-rw-r--r--security/samhain/distinfo4
-rw-r--r--security/samhain/files/extra-patch-config-h-in15
3 files changed, 19 insertions, 4 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index 29180925c4c7..6274f081fb98 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= samhain
-PORTVERSION= 3.0.3
+PORTVERSION= 3.0.8
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/ \
http://redundancy.redundancy.org/mirror/
@@ -41,7 +41,7 @@ MANUAL_PACKAGE_BUILD= fails to link on pointyhat
.endif
.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-config-h-in
.endif
.if defined(WITH_GPG)
diff --git a/security/samhain/distinfo b/security/samhain/distinfo
index 4f6dc0d1b125..db88715cb307 100644
--- a/security/samhain/distinfo
+++ b/security/samhain/distinfo
@@ -1,2 +1,2 @@
-SHA256 (samhain_signed-3.0.3.tar.gz) = e8e4bd1142aae5b5bfa8bb887043282bbe87d775255ed58fd3be15bfb55998cf
-SIZE (samhain_signed-3.0.3.tar.gz) = 2100233
+SHA256 (samhain_signed-3.0.8.tar.gz) = ca4e95ab1eedcbd0f18915d986cef15e0457547537a4a7877cf01e6fa154efbd
+SIZE (samhain_signed-3.0.8.tar.gz) = 2163928
diff --git a/security/samhain/files/extra-patch-config-h-in b/security/samhain/files/extra-patch-config-h-in
new file mode 100644
index 000000000000..5b2aef73ca67
--- /dev/null
+++ b/security/samhain/files/extra-patch-config-h-in
@@ -0,0 +1,15 @@
+--- /tmp/config.h.in 2012-11-09 14:19:51.587478847 -0800
++++ config.h.in 2012-11-09 14:21:07.068488479 -0800
+@@ -349,7 +349,11 @@
+ #undef HAVE_UINT64_T
+
+ /* Define if you have utmpx.h. */
+-#undef HAVE_UTMPX_H
++#define HAVE_UTMPX_H
++
++#define UTMPX_FILE "/var/log/utx.active"
++
++#define WTMPX_FILE "/var/log/utx.log"
+
+ /* Define if your struct utmpx has ut_xtime. */
+ #undef HAVE_UTXTIME