aboutsummaryrefslogtreecommitdiff
path: root/security/sancp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-17 18:13:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-17 18:13:11 +0000
commita17d44ae2087b45e3dfd9b3c135bcb42cf27fd7a (patch)
tree384982dad712f644219d41f7c1a37e8470511cca /security/sancp
parent93350b17573a67eae43c4d7714aa6f025bc964d1 (diff)
downloadports-a17d44ae2087b45e3dfd9b3c135bcb42cf27fd7a.tar.gz
ports-a17d44ae2087b45e3dfd9b3c135bcb42cf27fd7a.zip
- Update MASTER_SITES
- Add two vendor patches - Fix config file handling - Use SUB_FILES for pkg-message and better of USE_RC_SUBR PR: ports/89178 Submitted by: Paul Schmehl <pauls@utdallas.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=148641
Diffstat (limited to 'security/sancp')
-rw-r--r--security/sancp/Makefile25
-rw-r--r--security/sancp/distinfo7
-rw-r--r--security/sancp/files/pkg-message.in (renamed from security/sancp/pkg-message)26
-rw-r--r--security/sancp/files/sancp.sh.in (renamed from security/sancp/files/sancp.sh)0
-rw-r--r--security/sancp/pkg-deinstall1
-rw-r--r--security/sancp/pkg-plist9
6 files changed, 36 insertions, 32 deletions
diff --git a/security/sancp/Makefile b/security/sancp/Makefile
index 65ce225d724d..a841f7ae6d56 100644
--- a/security/sancp/Makefile
+++ b/security/sancp/Makefile
@@ -7,39 +7,40 @@
PORTNAME= sancp
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://www.metre.net/files/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sancp
+
+PATCH_SITES= http://sancp.sourceforge.net/
+PATCHFILES= sancp-1.6.1.fix200511.a.patch \
+ sancp-1.6.1.fix200511.b.patch
+PATCH_DIST_STRIP=-p1
MAINTAINER= pauls@utdallas.edu
COMMENT= A network connection profiler
ALL_TARGET= final
-USE_REINPLACE= yes
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+USE_RC_SUBR= sancp.sh
+SUB_FILES= pkg-message
PORTDOCS= CHANGES INSTALL ISSUES README SETUP fields.LIST
.include <bsd.port.pre.mk>
-post-patch:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/sancp.sh > ${WRKDIR}/sancp.sh
-
post-install:
${SH} ${PKGINSTALL}
${INSTALL_PROGRAM} ${WRKSRC}/sancp ${PREFIX}/bin
- ${INSTALL_SCRIPT} -m 755 ${WRKDIR}/sancp.sh ${PREFIX}/etc/rc.d/sancp.sh
.for f in sancp.conf
- ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}-sample
+ ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}-dist
[ -f ${PREFIX}/etc/${f} ] || \
- ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}
+ ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} LICENSE ${DOCSDIR}
cd ${WRKSRC}/docs/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
- @${SED} 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/security/sancp/distinfo b/security/sancp/distinfo
index 76947b4d4191..8c3cba4db408 100644
--- a/security/sancp/distinfo
+++ b/security/sancp/distinfo
@@ -1,2 +1,9 @@
MD5 (sancp-1.6.1.tar.gz) = b83e2f4abb2bf7b10fd874aa58f6324c
+SHA256 (sancp-1.6.1.tar.gz) = 58e487a4bd83716e90ff19d0d7fab352e28bbe143be60f4ee61c34d5fa6380a3
SIZE (sancp-1.6.1.tar.gz) = 69986
+MD5 (sancp-1.6.1.fix200511.a.patch) = 7b357ec3371fc399c7589261f0d8d11b
+SHA256 (sancp-1.6.1.fix200511.a.patch) = f80ea77873f03de40399c2c9247590829f02421d68758425cd139c48151eb13c
+SIZE (sancp-1.6.1.fix200511.a.patch) = 662
+MD5 (sancp-1.6.1.fix200511.b.patch) = 747aa31c477d726ce6a9b233e3e5f4ee
+SHA256 (sancp-1.6.1.fix200511.b.patch) = 0bbcf2797d689f9eaa46933262edc3badd644636fb8821832264bab454a870c0
+SIZE (sancp-1.6.1.fix200511.b.patch) = 870
diff --git a/security/sancp/pkg-message b/security/sancp/files/pkg-message.in
index fa346b069aa3..b9cc18b8a51a 100644
--- a/security/sancp/pkg-message
+++ b/security/sancp/files/pkg-message.in
@@ -1,26 +1,24 @@
- ***********************************
- * !!!!!!!!!!! WARNING !!!!!!!!!!! *
- ***********************************
+ ***********************************
+ * !!!!!!!!!!! WARNING !!!!!!!!!!! *
+ ***********************************
-A startup script, named sancp.sh-sample was installed in
-%%PREFIX%%/etc/rc.d/. Create a copy named sancp.sh in the
-same directory and enable the script in /etc/rc.conf using
-the usual rc.subr syntax. See rc.conf(5) or go to
+A startup script was installed in %%PREFIX%%/etc/rc.d/. Enable the script
+in /etc/rc.conf using the usual rc.subr syntax. See rc.conf(5) or go to
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/configtuning-rcng.html
-Configuration files named sancp.conf-sample and sancp.conf
+Configuration files named sancp.conf-dist and sancp.conf
were installed in %%PREFIX%%/etc. See the INSTALL doc, located in
-%%PREFIX%%/share/doc/sancp/ for details on configuration
+%%PREFIX%%/share/doc/sancp/ for details on configuration
options or type "sancp -h" on the commandline.
-Note that if you are installing sancp for use with sguil, the
+Note that if you are installing sancp for use with sguil, the
sancp.conf file will not be altered unless it is identical to
-the sancp.conf-sample file. In that case, during the
+the sancp.conf-dist file. In that case, during the
sguil-sensor install, the sancp.conf file will be overwritten with
the one that comes with squil. That file needs no editing. If the
-sancp.conf has been altered (you used sancp for something else) a
-new conf file, named sguil-sancp.conf-sample will be installed in the
-%%PREFIX%%/etc/rc.d/directory. You should use that one for sguil.
+sancp.conf has been altered (you used sancp for something else) a
+new conf file, named sguil-sancp.conf-sample will be installed in the
+%%PREFIX%%/etc directory. You should use that one for sguil.
Some of the configuration options for sancp are:
diff --git a/security/sancp/files/sancp.sh b/security/sancp/files/sancp.sh.in
index f8be90c0e112..f8be90c0e112 100644
--- a/security/sancp/files/sancp.sh
+++ b/security/sancp/files/sancp.sh.in
diff --git a/security/sancp/pkg-deinstall b/security/sancp/pkg-deinstall
index 143ec1bc244c..185e78234c89 100644
--- a/security/sancp/pkg-deinstall
+++ b/security/sancp/pkg-deinstall
@@ -25,4 +25,3 @@ if pw group show "${GROUP}" >/dev/null 2>&1; then
echo "Unable to remove group: ${GROUP}, remove it manually"
fi
fi
-
diff --git a/security/sancp/pkg-plist b/security/sancp/pkg-plist
index 71bb3ff88a5c..53689f4b4544 100644
--- a/security/sancp/pkg-plist
+++ b/security/sancp/pkg-plist
@@ -1,7 +1,6 @@
bin/sancp
-etc/sancp.conf-sample
-etc/rc.d/sancp.sh
-%%DOCSDIR%%/LICENSE
-@unexec if [ -f %D/etc/sancp.conf ] && ! cmp -s %D/etc/sancp.conf %D/etc/sancp.conf-sample; then rm -f %D/etc/sancp.conf; fi
-@unexec if [ -d /var/log/sancp/ ] && ! rmdir /var/log/sancp/ >/dev/null 2>&1; then echo "WARNING: Unable to remove log dir '/var/log/sancp/', its probably not empty" ; fi
+@unexec if [ -f %D/etc/sancp.conf ] && cmp -s %D/etc/sancp.conf %D/etc/sancp.conf-dist; then rm -f %D/etc/sancp.conf; fi
@unexec if [ -f %D/etc/sancp.conf ]; then echo "WARNING: The %D/etc/sancp.conf file was not removed!"; fi
+etc/sancp.conf-dist
+@exec if [ ! -f %D/etc/sancp.conf-dist ] ; then cp -p %D/%F %B/sancp.conf; fi
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE