aboutsummaryrefslogtreecommitdiff
path: root/security/sasp
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2014-07-11 07:32:45 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2014-07-11 07:32:45 +0000
commit32b7c92c6a47d6fc0b75c72efa5b06b82365ec50 (patch)
tree55481cbd0e3651ea9b63e91824ec6bdac610507c /security/sasp
parentdf4a2efa1aac368ce183650c3b075d0a5866bd3d (diff)
downloadports-32b7c92c6a47d6fc0b75c72efa5b06b82365ec50.tar.gz
ports-32b7c92c6a47d6fc0b75c72efa5b06b82365ec50.zip
Notes
Diffstat (limited to 'security/sasp')
-rw-r--r--security/sasp/Makefile5
-rw-r--r--security/sasp/files/patch-Makefile2
2 files changed, 3 insertions, 4 deletions
diff --git a/security/sasp/Makefile b/security/sasp/Makefile
index 5ea734239067..f2d01cfc1d2d 100644
--- a/security/sasp/Makefile
+++ b/security/sasp/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~ahze/distfiles/
MASTER_SITE_SUBDIR= ahze
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A tool that permits to use a gateway whatever IP we have
-LIB_DEPENDS= net:${PORTSDIR}/net/libnet
+LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
NO_WRKSUBDIR= yes
MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
@@ -20,5 +20,4 @@ PLIST_FILES= sbin/sasp
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/sasp/files/patch-Makefile b/security/sasp/files/patch-Makefile
index 7ec25d4b7c98..a15e41f4fe7e 100644
--- a/security/sasp/files/patch-Makefile
+++ b/security/sasp/files/patch-Makefile
@@ -6,6 +6,6 @@
+ ${CC} `${LIBNET_CONFIG} --cflags` -o sasp sasp.c -lpcap `${LIBNET_CONFIG} --libs`
install:
- install -o root -m 555 sasp /usr/local/sbin
-+ ${BSD_INSTALL_PROGRAM} sasp ${PREFIX}/sbin
++ ${BSD_INSTALL_PROGRAM} sasp ${DESTDIR}${PREFIX}/sbin
clean:
rm -rf *.o