aboutsummaryrefslogtreecommitdiff
path: root/security/scrypt
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2016-06-18 23:41:41 +0000
committerColin Percival <cperciva@FreeBSD.org>2016-06-18 23:41:41 +0000
commit76b4a4f5b802f6ed062c3fdc1d14286000e96b0d (patch)
treeeb7c2ca3424bb0d84a19e06fbe4b63e9a53f07ce /security/scrypt
parent710fd7cbf9d3d211ca20774c67c62fa4c78c8a09 (diff)
downloadports-76b4a4f5b802f6ed062c3fdc1d14286000e96b0d.tar.gz
ports-76b4a4f5b802f6ed062c3fdc1d14286000e96b0d.zip
Teach security/scrypt about libcrypto versions:
* Add USE_OPENSSL * Pass the appropriate CFLAGS and LDFLAGS to configure
Notes
Notes: svn path=/head/; revision=417096
Diffstat (limited to 'security/scrypt')
-rw-r--r--security/scrypt/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/scrypt/Makefile b/security/scrypt/Makefile
index 7cd0cd8bb2a2..9b6797d48461 100644
--- a/security/scrypt/Makefile
+++ b/security/scrypt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scrypt
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.tarsnap.com/scrypt/
@@ -10,7 +11,11 @@ MAINTAINER= cperciva@tarsnap.com
COMMENT= Key Derivation Function
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="-I${OPENSSLINC} ${CFLAGS}" \
+ LDFLAGS="-L${OPENSSLLIB} ${LDFLAGS}"
+
USES= gmake tar:tgz
+USE_OPENSSL= YES
PLIST_FILES= bin/scrypt \
man/man1/scrypt.1.gz