aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /security/seahorse
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Notes
Notes: svn path=/head/; revision=280300
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile10
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-notification.c11
2 files changed, 17 insertions, 4 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index d7a2d00aa0f0..6a9dd20e316f 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,12 +3,12 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.99 2010/09/28 09:01:33 kwm Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.104 2011/07/03 11:57:45 kwm Exp $
#
PORTNAME= seahorse
PORTVERSION= 2.32.0
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,10 +20,12 @@ BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
LIB_DEPENDS= gpgme.19:${PORTSDIR}/security/gpgme \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gnome-keyring:${PORTSDIR}/security/gnome-keyring \
+ gcr.0:${PORTSDIR}/security/gnome-keyring \
gcrypt.18:${PORTSDIR}/security/libgcrypt \
soup-2.4.1:${PORTSDIR}/devel/libsoup
+CONFLICTS= seahorse-3.[0-9]*
+
USE_XORG= sm
USE_LDCONFIG= yes
USE_BZIP2= yes
@@ -53,7 +55,7 @@ CONFIGURE_ARGS+=--disable-ldap
.endif
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
.endif
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-notification.c b/security/seahorse/files/patch-libseahorse_seahorse-notification.c
new file mode 100644
index 000000000000..7cf855253009
--- /dev/null
+++ b/security/seahorse/files/patch-libseahorse_seahorse-notification.c
@@ -0,0 +1,11 @@
+--- libseahorse/seahorse-notification.c.orig 2011-03-06 21:03:39.000000000 +0100
++++ libseahorse/seahorse-notification.c 2011-03-06 21:03:58.000000000 +0100
+@@ -231,7 +231,7 @@ setup_libnotify_notification (SeahorseNo
+ heading = format_key_text (snotif->heading);
+ message = format_key_text (snotif->message);
+
+- notif = notify_notification_new (heading, message, snotif->icon, attachto);
++ notif = notify_notification_new (heading, message, snotif->icon);
+
+ g_free (heading);
+ g_free (message);