aboutsummaryrefslogtreecommitdiff
path: root/security/seccure
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-05-27 01:10:53 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-05-27 01:10:53 +0000
commitf6209504849db4a4f55c3757d4bda05e4e2e0b4f (patch)
tree0a8ee0a9562b1272cd6ae594b33fa3fe8bb217b3 /security/seccure
parent90d4e33e75da38d73e4cd87fdaab04e990f0cc12 (diff)
downloadports-f6209504849db4a4f55c3757d4bda05e4e2e0b4f.tar.gz
ports-f6209504849db4a4f55c3757d4bda05e4e2e0b4f.zip
- Update to 0.4.
- Pass maintainer to submitter. Previous maintainer address bounced, even after removing the anti-spam measure. - Cleanup COMMENT and pkg-descr. - Also, respect PREFIX. PR: ports/157361 Submitted by: Ryan Steinmetz <rpsfa@rit.edu>
Notes
Notes: svn path=/head/; revision=274718
Diffstat (limited to 'security/seccure')
-rw-r--r--security/seccure/Makefile10
-rw-r--r--security/seccure/distinfo5
-rw-r--r--security/seccure/files/patch-Makefile33
-rw-r--r--security/seccure/pkg-descr14
4 files changed, 35 insertions, 27 deletions
diff --git a/security/seccure/Makefile b/security/seccure/Makefile
index 458d52c537cd..a334a0e8f93c 100644
--- a/security/seccure/Makefile
+++ b/security/seccure/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= seccure
-PORTVERSION= 0.3
-PORTREVISION= 3
+PORTVERSION= 0.4
CATEGORIES= security
-MASTER_SITES= http://point-at-infinity.org/seccure/
+MASTER_SITES= http://point-at-infinity.org/seccure/ \
+ ${MASTER_SITE_NETBSD}
-MAINTAINER= luke@REMOVE_IT.novum.am.lublin.pl
-COMMENT= SECCURE Elliptic Curve Crypto Utility for Reliable Encryption
+MAINTAINER= rpsfsa@rit.edu
+COMMENT= Elliptic Curve Crypto Utility for Reliable Encryption
LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt
diff --git a/security/seccure/distinfo b/security/seccure/distinfo
index 005d5a119176..e266381e9797 100644
--- a/security/seccure/distinfo
+++ b/security/seccure/distinfo
@@ -1,3 +1,2 @@
-MD5 (seccure-0.3.tar.gz) = 01f2a24ef84743795b6be007e4ca4e5c
-SHA256 (seccure-0.3.tar.gz) = 8d9cadca8319b253ae24644c22958898babb67abafd2d90caadd97714d824a47
-SIZE (seccure-0.3.tar.gz) = 30376
+SHA256 (seccure-0.4.tar.gz) = 33d690a7034ee349bce4911a8b7c73e6e3cd13a140f429e9e628d5cd5a3bb955
+SIZE (seccure-0.4.tar.gz) = 31881
diff --git a/security/seccure/files/patch-Makefile b/security/seccure/files/patch-Makefile
index 12594ab5bf28..b36a28284d78 100644
--- a/security/seccure/files/patch-Makefile
+++ b/security/seccure/files/patch-Makefile
@@ -1,15 +1,14 @@
---- Makefile.orig Wed Aug 16 22:13:57 2006
-+++ Makefile Thu Aug 30 13:33:58 2007
-@@ -1,4 +1,7 @@
--CFLAGS = -O2 # -D NOBEEP # -D NOMEMLOCK
-+CFLAGS = -L/usr/local/lib -I/usr/local/include -O2 -DNOBEEP -DNOMEMLOCK
-+DESTDIR = /usr/local
+--- Makefile 2009-04-09 08:42:50.000000000 -0400
++++ /tmp/Makefile 2011-05-26 19:30:35.000000000 -0400
+@@ -1,4 +1,6 @@
+-CFLAGS = -O2 -Wall # -D NOBEEP
++CFLAGS = -L$(LOCALBASE)/lib -I$(LOCALBASE)/include -O2 -DNOBEEP -DNOMEMLOCK
+
+all: default
default: binaries # doc
-@@ -8,15 +11,15 @@
+@@ -8,15 +10,15 @@
doc: seccure.1 seccure.1.html
install: default
@@ -22,15 +21,15 @@
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-veridec
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-dh
- install -m0644 seccure.1 $(DESTDIR)/usr/share/man/man1
-+ install -m0755 seccure-key $(DESTDIR)/bin
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-encrypt
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-decrypt
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-sign
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-verify
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-signcrypt
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-veridec
-+ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-dh
-+ install -m0644 seccure.1 $(DESTDIR)/man/man1
++ install -m0755 seccure-key $(PREFIX)/bin
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-encrypt
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-decrypt
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-sign
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-verify
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-signcrypt
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-veridec
++ ln -f $(PREFIX)/bin/seccure-key $(PREFIX)/bin/seccure-dh
++ install -m0644 seccure.1 $(PREFIX)/man/man1
clean:
- rm -f *.o seccure-key seccure-encrypt seccure-decrypt seccure-sign \
+ rm -f *.o *~ seccure-key seccure-encrypt seccure-decrypt seccure-sign \
diff --git a/security/seccure/pkg-descr b/security/seccure/pkg-descr
index 51a9a6bce6fa..e43e1c5e703b 100644
--- a/security/seccure/pkg-descr
+++ b/security/seccure/pkg-descr
@@ -1,6 +1,16 @@
-The seccure toolset implements a selection of asymmetric algorithms based on elliptic curve cryptography (ECC). In particular it offers public key encryption / decryption, signature generation / verification and key establishment.
+The seccure toolset implements a selection of asymmetric algorithms
+based on elliptic curve cryptography (ECC). In particular it offers
+public key encryption / decryption, signature generation /
+verification and key establishment.
-ECC schemes offer a much better key size to security ratio than classical systems (RSA, DSA). Keys are short enough to make direct specification of keys on the command line possible (sometimes this is more convenient than the management of PGP-like key rings). seccure builds on this feature and therefore is the tool of choice whenever lightweight asymmetric cryptography -- independent of key servers, revocation certificates, the Web of Trust or even configuration files -- is required.
+ECC schemes offer a much better key size to security ratio than
+classical systems (RSA, DSA). Keys are short enough to make direct
+specification of keys on the command line possible (sometimes this
+is more convenient than the management of PGP-like key rings).
+seccure builds on this feature and therefore is the tool of choice
+whenever lightweight asymmetric cryptography -- independent of key
+servers, revocation certificates, the Web of Trust or even
+configuration files -- is required.
WWW: http://point-at-infinity.org/seccure/
Author: B. Poettering