aboutsummaryrefslogtreecommitdiff
path: root/security/sectok
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-25 13:20:09 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-25 13:20:09 +0000
commit708626061d29b08b9c20d3ea1b9997bfb66820a2 (patch)
tree5f9b05a7cb98b80409eba4d52a440f4258ab5626 /security/sectok
parentae7854c5594f07c1615619f90bfa9c6f4df23521 (diff)
downloadports-708626061d29b08b9c20d3ea1b9997bfb66820a2.tar.gz
ports-708626061d29b08b9c20d3ea1b9997bfb66820a2.zip
- Respect CC/CFLAGS
- Support staging PR: ports/184845 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337414
Diffstat (limited to 'security/sectok')
-rw-r--r--security/sectok/Makefile25
-rw-r--r--security/sectok/files/patch-Makefile41
2 files changed, 18 insertions, 48 deletions
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
index 00802866e093..2354d3165c77 100644
--- a/security/sectok/Makefile
+++ b/security/sectok/Makefile
@@ -5,21 +5,32 @@ PORTNAME= sectok
PORTVERSION= 20030825
CATEGORIES= security
MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
-DISTNAME= sectok-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= ISO 7816 Smartcard Utility
-LIB_DEPENDS= sectok.3:${PORTSDIR}/security/libsectok
+LIB_DEPENDS= libsectok.so:${PORTSDIR}/security/libsectok
USE_OPENSSL= yes
-
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN1= sectok.1
-PLIST_FILES= bin/sectok
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^INCLUDES=/s|$$| $${CPPFLAGS}| ; \
+ /^LIBS=/s|$$| $${LDFLAGS}| ; \
+ s|^CC=|CC?=| ; \
+ s|^CFLAGS=|CFLAGS?=|' ${WRKSRC}/Makefile
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/sectok/files/patch-Makefile b/security/sectok/files/patch-Makefile
deleted file mode 100644
index b1867f2e4a06..000000000000
--- a/security/sectok/files/patch-Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
---- Makefile.orig Thu Jan 3 21:16:01 2002
-+++ Makefile Mon Sep 29 01:00:21 2003
-@@ -1,13 +1,19 @@
- # Standard installation:
--INCLUDES=
--LIBS= -lsectok -lcrypto
-+#INCLUDES=
-+#LIBS= -lsectok -lcrypto
-+
-+# FreeBSD
-+#PREFIX?= ${PREFIX}
-+#LOCALBASE?= ${LOCALBASE}
-+INCLUDES= -I$(LOCALBASE)/include
-+LIBS= -L$(LOCALBASE)/lib -lsectok -lcrypto
-
- # For building locally (libsectok not installed)
- #INCLUDES= -I../libsectok
- #LIBS= ../libsectok/libsectok.a -lcrypto
-
- # If crypto is included with openssl you might need this
--#INCLUDES= -I/usr/include/openssl
-+INCLUDES+= -I${OPENSSLINC}
-
- # You shouldn't have to change anything below this line
-
-@@ -17,7 +23,6 @@
- CC= gcc
- CFLAGS= -g -Wall
- INSTALL= install
--PREFIX= /usr/local
- RELEASE= sectok-`date "+%Y%m%d"`
-
- all : $(TARGETS)
-@@ -30,6 +35,7 @@
-
- install :
- $(INSTALL) $(TARGETS) $(PREFIX)/bin
-+ $(INSTALL) sectok.1 $(PREFIX)/man/man1
-
- release :
- rm -rf $(RELEASE)