aboutsummaryrefslogtreecommitdiff
path: root/security/setaudit
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2018-03-27 23:20:33 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2018-03-27 23:20:33 +0000
commit9c8f68ff1686373dc83564d8fcec2143cda2ec2a (patch)
tree56e13a8972ed7657c21edfe7d9147e1677fe7bf4 /security/setaudit
parenta122c9f9d6865339bbfa08d7fd177726f20d579f (diff)
downloadports-9c8f68ff1686373dc83564d8fcec2143cda2ec2a.tar.gz
ports-9c8f68ff1686373dc83564d8fcec2143cda2ec2a.zip
Add security/setaudit: Tool to specify audit configurations on a process
With setaudit it is possible to specify audit configurations on a process directly at the runtime. All audit events are redirected to the auditd(8), an audit log management daemon. Example of enabling all exe related audit events performed by a command and its child processes: # setaudit -m ex command WWW: https://github.com/csjayp/setaudit PR: 226627 Submitted by: Mateusz Piotrowski <0mp@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=465770
Diffstat (limited to 'security/setaudit')
-rw-r--r--security/setaudit/Makefile29
-rw-r--r--security/setaudit/distinfo3
-rw-r--r--security/setaudit/pkg-descr12
3 files changed, 44 insertions, 0 deletions
diff --git a/security/setaudit/Makefile b/security/setaudit/Makefile
new file mode 100644
index 000000000000..745730af35b6
--- /dev/null
+++ b/security/setaudit/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= setaudit
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.3
+CATEGORIES= security
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Tool to specify audit configurations on a process
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= csjayp
+
+PLIST_FILES= bin/setaudit \
+ man/man8/setaudit.8.gz
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/setaudit
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/setaudit/distinfo b/security/setaudit/distinfo
new file mode 100644
index 000000000000..ee915c5f065c
--- /dev/null
+++ b/security/setaudit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521772004
+SHA256 (csjayp-setaudit-v1.0.3_GH0.tar.gz) = e94787dca51b8b3986a391e3ea402f84946f151bf419611aac5bf6568ae32c0a
+SIZE (csjayp-setaudit-v1.0.3_GH0.tar.gz) = 2901
diff --git a/security/setaudit/pkg-descr b/security/setaudit/pkg-descr
new file mode 100644
index 000000000000..c5c44fadceb2
--- /dev/null
+++ b/security/setaudit/pkg-descr
@@ -0,0 +1,12 @@
+With setaudit it is possible to specify audit configurations on a process
+directly at the runtime.
+
+All audit events are redirected to the auditd(8), an audit log management
+daemon.
+
+Example of enabling all exe related audit events performed by a command and its
+child processes:
+
+ # setaudit -m ex command
+
+WWW: https://github.com/csjayp/setaudit