aboutsummaryrefslogtreecommitdiff
path: root/security/sha2wordlist
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2017-07-19 17:20:36 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2017-07-19 17:20:36 +0000
commit1209267e703976f2a8a6176274a69a2bf604faf2 (patch)
tree6fa328eb1673c523c39d8ddc9440f14623f50749 /security/sha2wordlist
parent905a742f705690440885a0f0c851c5a1f5aac420 (diff)
downloadports-1209267e703976f2a8a6176274a69a2bf604faf2.tar.gz
ports-1209267e703976f2a8a6176274a69a2bf604faf2.zip
Add sha2wordlist.
sha2wordlist makes a sha256 digest and outputs it in PGP Words, to be used when verifying hashes verbally. Submitted by: Peter Ankerstål
Notes
Notes: svn path=/head/; revision=446209
Diffstat (limited to 'security/sha2wordlist')
-rw-r--r--security/sha2wordlist/Makefile26
-rw-r--r--security/sha2wordlist/distinfo3
-rw-r--r--security/sha2wordlist/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/security/sha2wordlist/Makefile b/security/sha2wordlist/Makefile
new file mode 100644
index 000000000000..b200a754574a
--- /dev/null
+++ b/security/sha2wordlist/Makefile
@@ -0,0 +1,26 @@
+# Created by: Peter Ankerstal <peter@pean.org>
+# $FreeBSD$
+
+PORTNAME= sha2wordlist
+PORTVERSION= 1.0.20140124
+CATEGORIES= security
+
+MAINTAINER= peter@pean.org
+COMMENT= create SHA256 digests as PGP words
+
+LICENSE= BSD2CLAUSE BSD3CLAUSE
+LICENSE_COMB= multi
+
+USE_GITHUB= yes
+GH_ACCOUNT= kirei
+GH_TAGNAME= 3615281
+
+PLIST_FILES= sbin/sha2wordlist
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|cc|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${LOCALBASE}/sbin/
+
+.include <bsd.port.mk>
diff --git a/security/sha2wordlist/distinfo b/security/sha2wordlist/distinfo
new file mode 100644
index 000000000000..b8a8401b9ee4
--- /dev/null
+++ b/security/sha2wordlist/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500115682
+SHA256 (kirei-sha2wordlist-1.0.20140124-3615281_GH0.tar.gz) = 9fc3227ada752823250d2892961b7fed34f2d8a736c47421cf8dd6e4b1d26cee
+SIZE (kirei-sha2wordlist-1.0.20140124-3615281_GH0.tar.gz) = 14272
diff --git a/security/sha2wordlist/pkg-descr b/security/sha2wordlist/pkg-descr
new file mode 100644
index 000000000000..156c2e1641a8
--- /dev/null
+++ b/security/sha2wordlist/pkg-descr
@@ -0,0 +1,5 @@
+This program takes data on stdin and outputs the SHA256 checksum of that
+data together with the PGP Wordlist representation of the checksum.
+This could be very useful when verifying checksums verbally.
+
+WWW: https://github.com/kirei/sha2wordlist