aboutsummaryrefslogtreecommitdiff
path: root/security/sinfp
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-30 15:36:00 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-30 15:36:00 +0000
commit13656ce7679181f0b1b776ed95b711d9370fe971 (patch)
treeaba3625b969faf5c3d2b6bd501ca2207adbb3456 /security/sinfp
parente34dada69d0bfe8ee356ea9bff09dd06291b8a28 (diff)
downloadports-13656ce7679181f0b1b776ed95b711d9370fe971.tar.gz
ports-13656ce7679181f0b1b776ed95b711d9370fe971.zip
Notes
Diffstat (limited to 'security/sinfp')
-rw-r--r--security/sinfp/Makefile51
-rw-r--r--security/sinfp/distinfo3
-rw-r--r--security/sinfp/pkg-descr16
-rw-r--r--security/sinfp/pkg-plist28
4 files changed, 21 insertions, 77 deletions
diff --git a/security/sinfp/Makefile b/security/sinfp/Makefile
index 494b1e2a264f..8dabac56871d 100644
--- a/security/sinfp/Makefile
+++ b/security/sinfp/Makefile
@@ -1,42 +1,33 @@
-# New ports collection makefile for: SinFP
+# New ports collection makefile for: sinfp
# Date created: 26 May 2006
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= Net-SinFP
+PORTNAME= sinfp
PORTVERSION= 2.02.1
-DISTVERSION= 2.02
-PORTREVISION= 1
-CATEGORIES= security ipv6 perl5
-MASTER_SITES= CPAN
-MAINTAINER= infofarmer@FreeBSD.org
-COMMENT= Full operating system stack fingerprinting suite
-
-BUILD_DEPENDS= p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor \
- p5-DBIx-SQLite-Simple>=0.33:${PORTSDIR}/databases/p5-DBIx-SQLite-Simple \
- p5-Net-Packet>=3.00:${PORTSDIR}/net/p5-Net-Packet \
- p5-Net-Packet-Target>=1.00:${PORTSDIR}/net/p5-Net-Packet-Target
+BUILD_DEPENDS= p5-Net-SinFP>=2.02:${PORTSDIR}/security/p5-Net-SinFP
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
-MAN3= Net::SinFP.3 Net::SinFP::Consts.3 Net::SinFP::DB.3 Net::SinFP::DB::IpVersion.3 \
- Net::SinFP::DB::Os.3 Net::SinFP::DB::OsVersion.3 Net::SinFP::DB::OsVersionChildren.3 \
- Net::SinFP::DB::OsVersionFamily.3 Net::SinFP::DB::PatternBinary.3 \
- Net::SinFP::DB::PatternTcpFlags.3 Net::SinFP::DB::PatternTcpMss.3 \
- Net::SinFP::DB::PatternTcpOptions.3 Net::SinFP::DB::PatternTcpWindow.3 \
- Net::SinFP::DB::Signature.3 Net::SinFP::DB::SystemClass.3 Net::SinFP::DB::Vendor.3 \
- Net::SinFP::Result.3 Net::SinFP::Search.3 Net::SinFP::SinFP4.3 Net::SinFP::SinFP6.3
-
-ONLY_FOR_ARCHS= i386 amd64 alpha
-ONLY_FOR_ARCHS_REASON= Big endian architectures not supported yet
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= perl 5.6.1 or newer required. Install lang/perl5 or lang/perl5.8 and try again
+PLIST= ""
+PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/${PORTNAME}.db
+PLIST_DIRS= %%DATADIR%%
+NO_BUILD= yes
+MASTERDIR= ${.CURDIR}/../p5-Net-SinFP
+DBDATE= 20060923
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!$$Bin/../db/!${DATADIR}/!' ${WRKSRC}/bin/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL} -d ${DATADIR}/
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+.ifdef DBDATE
+ @${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}-${DBDATE}.db ${DATADIR}/${PORTNAME}.db
+.else
+ @${INSTALL_DATA} ${WRKSRC}/bin/${PORTNAME}.db ${DATADIR}/
.endif
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/security/sinfp/distinfo b/security/sinfp/distinfo
deleted file mode 100644
index 3f9cc4d1f0b9..000000000000
--- a/security/sinfp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (Net-SinFP-2.02.tar.gz) = 9200a258e3f1e2cde3a57fe483e0c172
-SHA256 (Net-SinFP-2.02.tar.gz) = a986a7f548f49a91ba64780e70746c2da5296a13a21282656fae49c50fb461e9
-SIZE (Net-SinFP-2.02.tar.gz) = 25218
diff --git a/security/sinfp/pkg-descr b/security/sinfp/pkg-descr
deleted file mode 100644
index 3568b7ed5828..000000000000
--- a/security/sinfp/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-SinFP is a new approach to OS fingerprinting, which bypasses
-limitations that nmap has.
-
-Nmap approaches to fingerprinting as shown to be efficient for years.
-Nowadays, with the omni-presence of stateful filtering devices,
-PAT/NAT configurations and emerging packet normalization technologies,
-its approach to OS fingerprinting is becoming to be obsolete.
-
-SinFP uses the aforementioned limitations as a basis for tests to be
-obsolutely avoided in used frames to identify accurately the remote
-operating system. That is, it only requires one open TCP port, sends
-only fully standard TCP packets, and limits the number of tests to 2
-or 3 (with only 1 test giving the OS reliably in most cases).
-
-WWW: http://www.gomor.org/sinfp
-Author: GomoR <netpkt@gomor.org>
diff --git a/security/sinfp/pkg-plist b/security/sinfp/pkg-plist
deleted file mode 100644
index b781d3c2ab9b..000000000000
--- a/security/sinfp/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-bin/sinfp.db
-bin/sinfp.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SinFP/.packlist
-%%SITE_PERL%%/Net/SinFP.pm
-%%SITE_PERL%%/Net/SinFP/Consts.pm
-%%SITE_PERL%%/Net/SinFP/DB.pm
-%%SITE_PERL%%/Net/SinFP/DB/IpVersion.pm
-%%SITE_PERL%%/Net/SinFP/DB/Os.pm
-%%SITE_PERL%%/Net/SinFP/DB/OsVersion.pm
-%%SITE_PERL%%/Net/SinFP/DB/OsVersionChildren.pm
-%%SITE_PERL%%/Net/SinFP/DB/OsVersionFamily.pm
-%%SITE_PERL%%/Net/SinFP/DB/PatternBinary.pm
-%%SITE_PERL%%/Net/SinFP/DB/PatternTcpFlags.pm
-%%SITE_PERL%%/Net/SinFP/DB/PatternTcpMss.pm
-%%SITE_PERL%%/Net/SinFP/DB/PatternTcpOptions.pm
-%%SITE_PERL%%/Net/SinFP/DB/PatternTcpWindow.pm
-%%SITE_PERL%%/Net/SinFP/DB/Signature.pm
-%%SITE_PERL%%/Net/SinFP/DB/SystemClass.pm
-%%SITE_PERL%%/Net/SinFP/DB/Vendor.pm
-%%SITE_PERL%%/Net/SinFP/Result.pm
-%%SITE_PERL%%/Net/SinFP/Search.pm
-%%SITE_PERL%%/Net/SinFP/SinFP4.pm
-%%SITE_PERL%%/Net/SinFP/SinFP6.pm
-@dirrmtry %%SITE_PERL%%/Net/SinFP/DB
-@dirrmtry %%SITE_PERL%%/Net/SinFP
-@dirrmtry %%SITE_PERL%%/Net
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SinFP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net