aboutsummaryrefslogtreecommitdiff
path: root/security/skip/Makefile
diff options
context:
space:
mode:
authorArchie Cobbs <archie@FreeBSD.org>2000-01-26 01:55:28 +0000
committerArchie Cobbs <archie@FreeBSD.org>2000-01-26 01:55:28 +0000
commita3dd62941f5a3293aace76538667e68ba52e12c4 (patch)
tree9a66dfd2813b90bae64681c94871563c1efd38c6 /security/skip/Makefile
parente122a8ab58fc4b674694806ed7932f4886014aac (diff)
Notes
Diffstat (limited to 'security/skip/Makefile')
-rw-r--r--security/skip/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/security/skip/Makefile b/security/skip/Makefile
index ba7f8995922f..966f9004790a 100644
--- a/security/skip/Makefile
+++ b/security/skip/Makefile
@@ -18,7 +18,7 @@ MASTER_SITES= ftp://ftp.replaytv.com/pub/replay/crypto/APPS/skip/ \
DISTFILES= skipsrc-1.0.tar.Z
EXTRACT_SUFX= tar.Z
-MAINTAINER= archie@whistle.com
+MAINTAINER= archie@freebsd.org
BUILD_DEPENDS= ${X11BASE}/lib/libxview.a:${PORTSDIR}/x11-toolkits/xview \
${X11BASE}/lib/X11/config/XView.cf:${PORTSDIR}/x11-toolkits/xview
@@ -47,6 +47,8 @@ MAN4= skipd.conf.4 raw_keys.4
# SKIP has a lot of hard coded paths in it. Our patches replace
# them with @@PREFIX@@, which we then replace with ${PREFIX}.
+# Also, we remove all the "#pragma ident" lines that generate
+# a bazillion warnings from the compiler.
post-patch:
@find ${WRKSRC} -name '*.orig' -print | xargs rm
@cd ${WRKSRC}; \
@@ -54,12 +56,12 @@ post-patch:
for FILE in $$FILES; do \
${SED} 's!@@PREFIX@@!${PREFIX}!g' < $$FILE > $$FILE.new ; \
${MV} $$FILE.new $$FILE; \
+ done; \
+ FILES=`find . -type f -name '*.[cCh]' -print \
+ | xargs ${GREP} -l '^#pragma ident'`; \
+ for FILE in $$FILES; do \
+ ${SED} '/^#pragma ident/d' < $$FILE > $$FILE.new ; \
+ ${MV} $$FILE.new $$FILE; \
done
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400006
-BROKEN= New character device registration issues and _KERNEL
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>