aboutsummaryrefslogtreecommitdiff
path: root/security/slush
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-27 14:11:12 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-27 14:11:12 +0000
commitf8720f3a34cb42fc4fa2b584f875e60355f83894 (patch)
tree1a71e282e7b9301b35d552492c9786f21b658144 /security/slush
parent83e4b4d656fe46d51321ce83ad5912d175de1657 (diff)
downloadports-f8720f3a34cb42fc4fa2b584f875e60355f83894.tar.gz
ports-f8720f3a34cb42fc4fa2b584f875e60355f83894.zip
- Fix build on -current
- Fixes for portlint (DOCSDIR) PR: 58582 Submitted by: elvis@sslab.cs.ccu.edu.tw
Notes
Notes: svn path=/head/; revision=92322
Diffstat (limited to 'security/slush')
-rw-r--r--security/slush/Makefile17
-rw-r--r--security/slush/files/patch-ab32
-rw-r--r--security/slush/files/patch-ac23
-rw-r--r--security/slush/pkg-plist9
4 files changed, 31 insertions, 50 deletions
diff --git a/security/slush/Makefile b/security/slush/Makefile
index 7433404aa138..96f01d1d2f6d 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slush
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/kris/ \
http://violet.ibs.com.au/slush/files/ \
@@ -16,26 +17,18 @@ MAINTAINER= shipley@dis.org
COMMENT= A telnet-like application which uses a secure SSL channel
GNU_CONFIGURE= yes
-
-USE_OPENSSL= YES
+USE_OPENSSL= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 300000
BROKEN= does not build
.endif
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
do-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/slush
- ${INSTALL_MAN} ${WRKSRC}/control.txt ${PREFIX}/share/doc/slush
- ${INSTALL_MAN} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/slush
- ${INSTALL_MAN} ${WRKSRC}/HISTORY ${PREFIX}/share/doc/slush
- ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/slush
- ${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/slush
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/control.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
${INSTALL_PROGRAM} ${WRKSRC}/slush ${PREFIX}/bin/slush
${INSTALL_PROGRAM} ${WRKSRC}/slushd ${PREFIX}/sbin/slushd
diff --git a/security/slush/files/patch-ab b/security/slush/files/patch-ab
index 2a72fc630570..35bdb47ece44 100644
--- a/security/slush/files/patch-ab
+++ b/security/slush/files/patch-ab
@@ -1,19 +1,13 @@
-*** slush.c- Fri May 7 03:31:04 1999
---- slush.c Fri May 7 03:31:14 1999
-***************
-*** 34,40 ****
- #include <signal.h>
- #include <string.h>
- #include <stdlib.h>
-! #include <getopt.h>
- #include <termios.h>
- #include <pwd.h>
- #include <sys/ioctl.h>
---- 34,40 ----
- #include <signal.h>
- #include <string.h>
- #include <stdlib.h>
-! /* #include <getopt.h> */
- #include <termios.h>
- #include <pwd.h>
- #include <sys/ioctl.h>
+--- slush.c- Mon Oct 27 06:19:50 2003
++++ slush.c Mon Oct 27 06:21:46 2003
+@@ -34,7 +34,10 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <sys/param.h>
++#if __FreeBSD_version >= 500000
+ #include <getopt.h>
++#endif
+ #include <termios.h>
+ #include <pwd.h>
+ #include <sys/ioctl.h>
diff --git a/security/slush/files/patch-ac b/security/slush/files/patch-ac
index 8ee3c7fe9268..9ebcb844f771 100644
--- a/security/slush/files/patch-ac
+++ b/security/slush/files/patch-ac
@@ -1,25 +1,22 @@
-*** slushd.c.orig Tue Apr 6 05:14:04 1999
---- slushd.c Sat May 8 23:53:40 1999
+*** slushd.c- Mon Oct 27 06:19:54 2003
+--- slushd.c Mon Oct 27 06:22:02 2003
***************
*** 40,46 ****
+--- 40,50 ----
#include <ctype.h>
#include <stdlib.h>
#include <netdb.h>
-! #include <getopt.h>
- #include <pwd.h>
- #include <grp.h>
- #include <fcntl.h>
---- 40,46 ----
- #include <ctype.h>
- #include <stdlib.h>
- #include <netdb.h>
-! #include <libutil.h>
++ #include <sys/param.h>
++ #if __FreeBSD_version >= 500000
+ #include <getopt.h>
++ #endif
++ #include <libutil.h>
#include <pwd.h>
#include <grp.h>
#include <fcntl.h>
***************
*** 51,56 ****
---- 51,57 ----
+--- 55,61 ----
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/file.h>
@@ -87,7 +84,7 @@
}
/* Retrieve client X509 certificate and test authentication */
---- 655,684 ----
+--- 659,688 ----
void log_uwtmp(struct passwd *pw, struct in_addr *i, char *tty, int is_logout)
{
struct utmp ut;
diff --git a/security/slush/pkg-plist b/security/slush/pkg-plist
index de12fbb39af9..2ebbb97b64a7 100644
--- a/security/slush/pkg-plist
+++ b/security/slush/pkg-plist
@@ -1,8 +1,5 @@
bin/slush
sbin/slushd
-share/doc/slush/COPYING
-share/doc/slush/HISTORY
-share/doc/slush/INSTALL
-share/doc/slush/README
-share/doc/slush/control.txt
-@dirrm share/doc/slush
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/control.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%