aboutsummaryrefslogtreecommitdiff
path: root/security/sniff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:31:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:31:11 +0000
commitcfde8ed62505d54020e38d93f2dd2a6a1b133971 (patch)
tree7cdaa51c08adb9c3c13cf01b53139f6cef7c69f7 /security/sniff
parente3e9508087a5531a3fb56d31c3351404dac4e046 (diff)
downloadports-cfde8ed62505d54020e38d93f2dd2a6a1b133971.tar.gz
ports-cfde8ed62505d54020e38d93f2dd2a6a1b133971.zip
- Respect CC/CFLAGS
- Add LICENSE - Support staging PR: ports/184882 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337082
Diffstat (limited to 'security/sniff')
-rw-r--r--security/sniff/Makefile31
1 files changed, 19 insertions, 12 deletions
diff --git a/security/sniff/Makefile b/security/sniff/Makefile
index 7922f3a9adc7..41b2cebe3760 100644
--- a/security/sniff/Makefile
+++ b/security/sniff/Makefile
@@ -1,23 +1,30 @@
# Created by: Rick & Samu
# $FreeBSD$
-PORTNAME= sniff
-PORTVERSION= 1.0
-CATEGORIES= security
-MASTER_SITES= LOCAL/fenner
+PORTNAME= sniff
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= LOCAL/fenner
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Program to sniff logins and passwords
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Program to sniff logins and passwords
-MAN1= sniff.1
+LICENSE= GPLv2
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= configure
+GNU_CONFIGURE= yes
-PLIST_FILES= sbin/sniff
+PLIST_FILES= sbin/sniff man/man1/sniff.1.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|^CC.*|CC=@CC@| ; \
+ s|^CFLAGS.*|CFLAGS=@CFLAGS@| ; \
+ s|^PREFIX.*|PREFIX=@PREFIX@|' ${WRKSRC}/Makefile.in
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} sniff \
+ ${STAGEDIR}${PREFIX}/sbin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} sniff.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1)
.include <bsd.port.mk>