aboutsummaryrefslogtreecommitdiff
path: root/security/snort-rep
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-05-01 09:02:50 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-05-01 09:02:50 +0000
commit0429f9a4a485435873bc5ac81b8ab30511820996 (patch)
treeafe042158f492485e51592d69d49934bc9d6161d /security/snort-rep
parent572fcf274bfb97ddb3ea9c754e322e7ea573136a (diff)
downloadports-0429f9a4a485435873bc5ac81b8ab30511820996.tar.gz
ports-0429f9a4a485435873bc5ac81b8ab30511820996.zip
- Fix a call of Perl's timelocal() for timestamps with seconds out of [0..59].
[1] - Convert Makefile header to new style. PR: 168926 [1] Submitted by: Filip Valder <filip@valder.cz> [1]
Notes
Notes: svn path=/head/; revision=317005
Diffstat (limited to 'security/snort-rep')
-rw-r--r--security/snort-rep/Makefile7
-rw-r--r--security/snort-rep/files/patch-snort-rep11
2 files changed, 13 insertions, 5 deletions
diff --git a/security/snort-rep/Makefile b/security/snort-rep/Makefile
index 04c6c5c759b4..69946f4f2c64 100644
--- a/security/snort-rep/Makefile
+++ b/security/snort-rep/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: snort-rep
-# Date created: Jul 19, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-#
PORTNAME= snort-rep
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://david.schweikert.ch/software/snort-rep/pub/
diff --git a/security/snort-rep/files/patch-snort-rep b/security/snort-rep/files/patch-snort-rep
new file mode 100644
index 000000000000..f83be0cb0795
--- /dev/null
+++ b/security/snort-rep/files/patch-snort-rep
@@ -0,0 +1,11 @@
+--- snort-rep.orig 2013-05-01 10:38:51.000000000 +0200
++++ snort-rep 2013-05-01 10:39:27.000000000 +0200
+@@ -1081,7 +1081,7 @@
+ my $year = defined $3 ? $3 : (localtime(time))[5]+1900;
+
+ # convert to unix time
+- $a{timestamp} = timelocal($6, $5, $4, $2, $1 - 1, $year);
++ $a{timestamp} = timelocal(int($6), $5, $4, $2, $1 - 1, $year);
+ $start_time = $a{timestamp}
+ if not defined $start_time or $a{timestamp} < $start_time;
+ $end_time = $a{timestamp} if not defined $end_time or $a{timestamp} > $end_time;