aboutsummaryrefslogtreecommitdiff
path: root/security/snort3
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2018-03-20 15:33:09 +0000
committerDan Langille <dvl@FreeBSD.org>2018-03-20 15:33:09 +0000
commit27aa66d0761a888e4ae1274946febcbf7afef84c (patch)
treeab7c56289241c0024ca633087876147be46b0602 /security/snort3
parent3261026f5e9203e8f0ce1ddf1dd08c07d1134814 (diff)
downloadports-27aa66d0761a888e4ae1274946febcbf7afef84c.tar.gz
ports-27aa66d0761a888e4ae1274946febcbf7afef84c.zip
Unbreak and update to 3.0.0-a4.243
Submitted by: Daniel Engberg Differential Revision: https://reviews.freebsd.org/D14582
Notes
Notes: svn path=/head/; revision=465089
Diffstat (limited to 'security/snort3')
-rw-r--r--security/snort3/Makefile58
-rw-r--r--security/snort3/distinfo6
-rw-r--r--security/snort3/pkg-plist3
3 files changed, 39 insertions, 28 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index cbb103e62db0..3ae531f5b2be 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= snort
-DISTVERSION= 3.0.0-a4.242
+DISTVERSION= 3.0.0-a4.243
PORTREVISION= 1
CATEGORIES= security
PKGNAMESUFFIX= 3
@@ -13,8 +13,6 @@ COMMENT= Lightweight network intrusion detection system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to package
-
BUILD_DEPENDS= daq>=2.2.2:net/daq \
bash>0:shells/bash
LIB_DEPENDS= libpcre.so:devel/pcre \
@@ -22,25 +20,44 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libpcap.so:net/libpcap \
libluajit-5.1.so:lang/luajit \
libhwloc.so:devel/hwloc
+
RUN_DEPENDS= daq>=2.2.2:net/daq
-USES= cmake compiler:c++11-lang cpe libtool pathfix pkgconfig ssl
+USES= cmake compiler:c++11-lang cpe libtool pathfix pkgconfig ssl iconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
USE_GITHUB= yes
GH_ACCOUNT= snortadmin
GH_PROJECT= snort3
-GH_TAGNAME= BUILD_242
-
-OPTIONS_DEFINE= DEBUG DOCS LRGPCAP
-
-OPTIONS_SUB= yes
-
-LRGPCAP_DESC= Pcaps larger than 2GB
-DEBUG_DESC= Enable debugging symbols+core dumps
-
-DEBUG_CONFIGURE_ENABLE= debug debug-msgs
-DEBUG_CONFIGURE_DISABLE= corefiles
-DEBUG_MAKE_ENV= DONTSTRIP="yes"
-LRGPCAP_CONFIGURE_ENABLE= large-pcap
+GH_TAGNAME= BUILD_243
+
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= ADDRESSSANITIZER DEBUG DOCS LARGEPCAP PIE THREADSANITIZER STATICDAQ
+OPTIONS_DEFINE_amd64= HYPERSCAN TSC
+OPTIONS_DEFAULT= DOCS STATICDAQ
+
+ADDRESSSANITIZER_DESC= Enable address sanitizer
+DEBUG_DESC= Enable debug
+DOCS_DESC= Enable documentation
+# FLATBUFFERS_DESC= Enable flatbuffers support // Doesn't get detected
+HYPERSCAN_DESC= Enable high-performance regular expression lib
+LARGEPCAP_DESC= Enable support for pcaps larger than 2 GB
+PIE_DESC= Enable PIE (Broken)
+STATICDAQ_DESC= Link static DAQ modules
+THREADSANITIZER_DESC= Enable thread sanitizer
+TSC_DESC= Use timestamp counter register clock (x86 only)
+
+ADDRESSSANITIZER_CMAKE_BOOL= ENABLE_ADDRESS_SANITIZER
+DEBUG_CMAKE_BOOL= ENABLE_COREFILES ENABLE_GDB
+DOCS_CMAKE_BOOL= MAKE_HTML_DOC MAKE_PDF_DOC MAKE_TEXT_DOC
+LARGEPCAP_CMAKE_BOOL= ENABLE_LARGE_PCAP
+PIE_CMAKE_BOOL= ENABLE_PIE
+STATICDAQ_CMAKE_BOOL= ENABLE_STATIC_DAQ
+THREADSANITIZER_CMAKE_BOOL= ENABLE_THREAD_SANITIZER
+TSC_CMAKE_BOOL= ENABLE_TSC_CLOCK
+
+# FLATBUFFERS_LIB_DEPENDS= libflatbuffers.so:devel/flatbuffers
+HYPERSCAN_LIB_DEPENDS= libhs.so:devel/hyperscan
.include <bsd.port.pre.mk>
@@ -48,13 +65,6 @@ LRGPCAP_CONFIGURE_ENABLE= large-pcap
EXTRA_PATCHES= ${PATCHDIR}/freebsd103_patch-src_memory_memory__allocator.h
.endif
-.include <bsd.port.options.mk>
-
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-CFLAGS+= -I${LOCALBASE}/include
-
CONFLICTS= snort-2*
.include <bsd.port.post.mk>
diff --git a/security/snort3/distinfo b/security/snort3/distinfo
index c51988b07497..f15c8d9ae1d0 100644
--- a/security/snort3/distinfo
+++ b/security/snort3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517327070
-SHA256 (snortadmin-snort3-3.0.0-a4.242-BUILD_242_GH0.tar.gz) = e3bbc0a2d36f533bb26bd53b0db9db35776c23f754514f7b03cbd9bd4863eee5
-SIZE (snortadmin-snort3-3.0.0-a4.242-BUILD_242_GH0.tar.gz) = 6340850
+TIMESTAMP = 1520170188
+SHA256 (snortadmin-snort3-3.0.0-a4.243-BUILD_243_GH0.tar.gz) = 5d4699e12fddff0605050f69d5e64be66dcd809cacca72aa96d59638fd41a343
+SIZE (snortadmin-snort3-3.0.0-a4.243-BUILD_243_GH0.tar.gz) = 6343357
diff --git a/security/snort3/pkg-plist b/security/snort3/pkg-plist
index e7b5c4e0d2e8..25bbfdae1728 100644
--- a/security/snort3/pkg-plist
+++ b/security/snort3/pkg-plist
@@ -69,9 +69,10 @@ include/snort/log/u2_packet.h
include/snort/log/unified2.h
include/snort/lua/snort_config.lua
include/snort/lua/snort_plugin.lua
+include/snort/main/analyzer_command.h
include/snort/main/policy.h
include/snort/main/snort_config.h
-include/snort/main/snort_%%CMAKE_BUILD_TYPE%%.h
+include/snort/main/snort_debug.h
include/snort/main/snort_types.h
include/snort/main/thread.h
include/snort/managers/codec_manager.h