aboutsummaryrefslogtreecommitdiff
path: root/security/snort3
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-02-01 22:52:29 +0000
committerMark Felder <feld@FreeBSD.org>2018-02-01 22:52:29 +0000
commit2a2d3706cf58f6b40b37c703367308bd6960f47a (patch)
tree726ce8a6f3e4a538da29fb21ad942e7b35a966c1 /security/snort3
parent99282e907252371b34f1189e57866b9da745c4da (diff)
downloadports-2a2d3706cf58f6b40b37c703367308bd6960f47a.tar.gz
ports-2a2d3706cf58f6b40b37c703367308bd6960f47a.zip
security/snort3: Fix build with FreeBSD 10.3
Notes
Notes: svn path=/head/; revision=460648
Diffstat (limited to 'security/snort3')
-rw-r--r--security/snort3/Makefile8
-rw-r--r--security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h14
2 files changed, 21 insertions, 1 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index b02413d27c18..d1471cf83e79 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -40,6 +40,12 @@ DEBUG_CONFIGURE_DISABLE= corefiles
DEBUG_MAKE_ENV= DONTSTRIP="yes"
LRGPCAP_CONFIGURE_ENABLE= large-pcap
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1004000
+EXTRA_PATCHES= ${PATCHDIR}/freebsd103_patch-src_memory_memory__allocator.h
+.endif
+
.include <bsd.port.options.mk>
GNU_CONFIGURE= yes
@@ -49,4 +55,4 @@ CFLAGS+= -I${LOCALBASE}/include
CONFLICTS= snort-2*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h b/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h
new file mode 100644
index 000000000000..82aa51523552
--- /dev/null
+++ b/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h
@@ -0,0 +1,14 @@
+--- src/memory/memory_allocator.h.orig 2018-02-01 22:21:37 UTC
++++ src/memory/memory_allocator.h
+@@ -34,4 +34,11 @@ struct MemoryAllocator
+
+ } // namespace memory
+
++// Fix for FreeBSD 10.3's broken toolchain
++typedef struct {
++ long long __max_align1 __aligned(_Alignof(long long));
++ long double __max_align2 __aligned(_Alignof(long double));
++} max_align_t;
++
++
+ #endif