aboutsummaryrefslogtreecommitdiff
path: root/security/snort3
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-29 20:18:00 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-29 20:18:00 +0000
commit549c2d86e5d0afc2692ab50f87dcf93e157f4f22 (patch)
tree11a1d530051644629881a785a3e8c8e439716f45 /security/snort3
parent19d8ef124140977fd3393e77fa9e5727fd003a35 (diff)
downloadports-549c2d86e5d0afc2692ab50f87dcf93e157f4f22.tar.gz
ports-549c2d86e5d0afc2692ab50f87dcf93e157f4f22.zip
security/snort3: Update version 3.0.0-270=>3.0.1-2
Notes
Notes: svn path=/head/; revision=533394
Diffstat (limited to 'security/snort3')
-rw-r--r--security/snort3/Makefile2
-rw-r--r--security/snort3/distinfo6
-rw-r--r--security/snort3/files/patch-src_host__tracker_host__cache__allocator.cc26
-rw-r--r--security/snort3/files/patch-src_host__tracker_host__cache__allocator.h25
-rw-r--r--security/snort3/files/patch-src_main_analyzer.cc6
-rw-r--r--security/snort3/files/patch-src_network__inspectors_appid_appid__config.h13
-rw-r--r--security/snort3/pkg-plist5
7 files changed, 23 insertions, 60 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index e7d089bc7e78..0eab9f8fc8f8 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= snort
-DISTVERSION= 3.0.0-270
+DISTVERSION= 3.0.1-2
PORTEPOCH= 1
CATEGORIES= security
PKGNAMESUFFIX= 3
diff --git a/security/snort3/distinfo b/security/snort3/distinfo
index c92e8e1c2762..1b7859dcb6bb 100644
--- a/security/snort3/distinfo
+++ b/security/snort3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1585861636
-SHA256 (snort3-snort3-3.0.0-270_GH0.tar.gz) = 06e127240c9c234b17f9ff22469dd21651374fac0fec8fceea9849a108bb3499
-SIZE (snort3-snort3-3.0.0-270_GH0.tar.gz) = 6537334
+TIMESTAMP = 1587732085
+SHA256 (snort3-snort3-3.0.1-2_GH0.tar.gz) = 651a5dfe98d27d76fba10e217a53bf184a36ce3a22a970b32c0bc9292dc13e17
+SIZE (snort3-snort3-3.0.1-2_GH0.tar.gz) = 6546507
diff --git a/security/snort3/files/patch-src_host__tracker_host__cache__allocator.cc b/security/snort3/files/patch-src_host__tracker_host__cache__allocator.cc
deleted file mode 100644
index ab0f2903c0fc..000000000000
--- a/security/snort3/files/patch-src_host__tracker_host__cache__allocator.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/host_tracker/host_cache_allocator.cc.orig 2020-04-04 01:57:20 UTC
-+++ src/host_tracker/host_cache_allocator.cc
-@@ -24,23 +24,6 @@
- #include "host_cache.h"
-
- template <class T>
--T* HostCacheAlloc<T>::allocate(std::size_t n)
--{
-- size_t sz=n*sizeof(T);
-- T* out=std::allocator<T>::allocate(n);
-- lru->update(sz);
-- return out;
--}
--
--template <class T>
--void HostCacheAlloc<T>::deallocate(T* p, std::size_t n) noexcept
--{
-- size_t sz = n*sizeof(T);
-- std::allocator<T>::deallocate(p, n);
-- lru->update( -(int) sz);
--}
--
--template <class T>
- HostCacheAllocIp<T>::HostCacheAllocIp()
- {
- lru = &host_cache;
diff --git a/security/snort3/files/patch-src_host__tracker_host__cache__allocator.h b/security/snort3/files/patch-src_host__tracker_host__cache__allocator.h
deleted file mode 100644
index ce74bf9038a9..000000000000
--- a/security/snort3/files/patch-src_host__tracker_host__cache__allocator.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/host_tracker/host_cache_allocator.h.orig 2020-04-04 02:00:30 UTC
-+++ src/host_tracker/host_cache_allocator.h
-@@ -44,6 +44,22 @@ class HostCacheAlloc : public std::allocator<T> (prote
- HostCacheInterface* lru = 0;
- };
-
-+template <class T>
-+T* HostCacheAlloc<T>::allocate(std::size_t n)
-+{
-+ size_t sz = n * sizeof(T);
-+ T* out = std::allocator<T>::allocate(n);
-+ lru->update(sz);
-+ return out;
-+}
-+
-+template <class T>
-+void HostCacheAlloc<T>::deallocate(T* p, std::size_t n) noexcept
-+{
-+ size_t sz = n * sizeof(T);
-+ std::allocator<T>::deallocate(p, n);
-+ lru->update(-(int) sz);
-+}
-
- // Trivial derived allocator, pointing to their own host cache.
- // HostCacheAllocIp has a HostCacheInterface* pointing to an lru cache
diff --git a/security/snort3/files/patch-src_main_analyzer.cc b/security/snort3/files/patch-src_main_analyzer.cc
index ba139dda1e7d..3f6793577093 100644
--- a/security/snort3/files/patch-src_main_analyzer.cc
+++ b/security/snort3/files/patch-src_main_analyzer.cc
@@ -1,6 +1,6 @@
---- src/main/analyzer.cc.orig 2020-03-25 14:13:20 UTC
+--- src/main/analyzer.cc.orig 2020-04-23 16:12:51 UTC
+++ src/main/analyzer.cc
-@@ -95,7 +95,7 @@ class RetryQueue (public)
+@@ -96,7 +96,7 @@ class RetryQueue (public)
RetryQueue(unsigned interval_ms)
{
assert(interval_ms > 0);
@@ -9,7 +9,7 @@
}
~RetryQueue()
-@@ -546,7 +546,7 @@ void Analyzer::idle()
+@@ -552,7 +552,7 @@ void Analyzer::idle()
struct timeval now, increment;
unsigned int timeout = SnortConfig::get_conf()->daq_config->timeout;
packet_gettimeofday(&now);
diff --git a/security/snort3/files/patch-src_network__inspectors_appid_appid__config.h b/security/snort3/files/patch-src_network__inspectors_appid_appid__config.h
new file mode 100644
index 000000000000..61ef3e25f178
--- /dev/null
+++ b/security/snort3/files/patch-src_network__inspectors_appid_appid__config.h
@@ -0,0 +1,13 @@
+--- src/network_inspectors/appid/appid_config.h.orig 2020-04-28 22:50:18 UTC
++++ src/network_inspectors/appid/appid_config.h
+@@ -65,8 +65,8 @@ class AppIdConfig (public)
+ uint32_t first_decrypted_packet_debug = 0;
+ #endif
+ bool log_stats = false;
+- unsigned long app_stats_period = 300;
+- unsigned long app_stats_rollover_size = 0;
++ uint32_t app_stats_period = 300;
++ uint32_t app_stats_rollover_size = 0;
+ const char* app_detector_dir = nullptr;
+ std::string tp_appid_path = "";
+ std::string tp_appid_config = "";
diff --git a/security/snort3/pkg-plist b/security/snort3/pkg-plist
index 9c585a1813ba..546fde95dec1 100644
--- a/security/snort3/pkg-plist
+++ b/security/snort3/pkg-plist
@@ -43,6 +43,7 @@ include/snort/file_api/file_segment.h
include/snort/file_api/file_service.h
include/snort/flow/expect_cache.h
include/snort/flow/flow.h
+include/snort/flow/flow_data.h
include/snort/flow/flow_key.h
include/snort/flow/flow_stash.h
include/snort/flow/ha.h
@@ -100,6 +101,7 @@ include/snort/main/snort_config.h
include/snort/main/snort_debug.h
include/snort/main/snort_types.h
include/snort/main/thread.h
+include/snort/main/trace.h
include/snort/managers/codec_manager.h
include/snort/managers/inspector_manager.h
include/snort/mime/decode_b64.h
@@ -111,12 +113,12 @@ include/snort/mime/file_mime_log.h
include/snort/mime/file_mime_paf.h
include/snort/mime/file_mime_process.h
include/snort/network_inspectors/appid/appid_api.h
+include/snort/network_inspectors/appid/appid_app_descriptor.h
include/snort/network_inspectors/appid/appid_dns_session.h
include/snort/network_inspectors/appid/appid_http_session.h
include/snort/network_inspectors/appid/appid_session_api.h
include/snort/network_inspectors/appid/appid_types.h
include/snort/network_inspectors/appid/application_ids.h
-include/snort/network_inspectors/appid/http_xff_fields.h
include/snort/network_inspectors/appid/tp_appid_module_api.h
include/snort/network_inspectors/appid/tp_appid_session_api.h
include/snort/network_inspectors/appid/tp_appid_types.h
@@ -178,7 +180,6 @@ include/snort/target_based/snort_protocols.h
include/snort/time/clock_defs.h
include/snort/time/packet_time.h
include/snort/time/stopwatch.h
-include/snort/utils/bitop.h
include/snort/utils/boyer_moore.h
include/snort/utils/cpp_macros.h
include/snort/utils/endian.h