aboutsummaryrefslogtreecommitdiff
path: root/security/snort3
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-02-21 00:07:29 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-02-21 00:07:29 +0000
commit64a1d25a870e222ba0d840a5f44bc3cd4be9837b (patch)
tree350df6204665b0e79bdaebe5e83ad4636e54ecb0 /security/snort3
parentf79cc4f3ecc1338df59017ae7fc7292d79ecbb94 (diff)
downloadports-64a1d25a870e222ba0d840a5f44bc3cd4be9837b.tar.gz
ports-64a1d25a870e222ba0d840a5f44bc3cd4be9837b.zip
security/snort3: Update version 3.0.0-a4.243=>3.0.0-250
- Take MAINTAINERSHIP
Notes
Notes: svn path=/head/; revision=493478
Diffstat (limited to 'security/snort3')
-rw-r--r--security/snort3/Makefile25
-rw-r--r--security/snort3/distinfo6
-rw-r--r--security/snort3/pkg-plist21
3 files changed, 34 insertions, 18 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index 558b1ce85cc5..298d5138d09f 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= snort
-DISTVERSION= 3.0.0-a4.243
-PORTREVISION= 3
+DISTVERSION= 3.0.0-250
+PORTEPOCH= 1
CATEGORIES= security
PKGNAMESUFFIX= 3
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Lightweight network intrusion detection system
LICENSE= GPLv2
@@ -20,20 +20,21 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libpcap.so:net/libpcap \
libluajit-5.1.so:lang/luajit \
libhwloc.so:devel/hwloc
-
RUN_DEPENDS= daq>=2.2.2:net/daq
-USES= cmake compiler:c++11-lang cpe libtool pathfix pkgconfig ssl iconv
-LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+USES= cmake compiler:c++11-lang cpe libtool pathfix pkgconfig shebangfix ssl iconv
+
USE_GITHUB= yes
-GH_ACCOUNT= snortadmin
+GH_ACCOUNT= snort3
GH_PROJECT= snort3
-GH_TAGNAME= BUILD_243
-USE_LDCONFIG= yes
+SHEBANG_FILES= tools/appid_detector_builder.sh
+
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+USE_LDCONFIG= yes
OPTIONS_DEFINE= ADDRESSSANITIZER DEBUG DOCS LARGEPCAP PIE THREADSANITIZER STATICDAQ
-OPTIONS_DEFINE_amd64= HYPERSCAN TSC
+OPTIONS_DEFINE_amd64= HYPERSCAN TSC
OPTIONS_DEFAULT= STATICDAQ
ADDRESSSANITIZER_DESC= Enable address sanitizer
@@ -47,13 +48,13 @@ STATICDAQ_DESC= Link static DAQ modules
THREADSANITIZER_DESC= Enable thread sanitizer
TSC_DESC= Use timestamp counter register clock (x86 only)
-ADDRESSSANITIZER_CMAKE_BOOL= ENABLE_ADDRESS_SANITIZER
+ADDRESSSANITIZER_CMAKE_BOOL= ENABLE_ADDRESS_SANITIZER
DEBUG_CMAKE_BOOL= ENABLE_COREFILES ENABLE_GDB
DOCS_CMAKE_BOOL= MAKE_HTML_DOC MAKE_PDF_DOC MAKE_TEXT_DOC
LARGEPCAP_CMAKE_BOOL= ENABLE_LARGE_PCAP
PIE_CMAKE_BOOL= ENABLE_PIE
STATICDAQ_CMAKE_BOOL= ENABLE_STATIC_DAQ
-THREADSANITIZER_CMAKE_BOOL= ENABLE_THREAD_SANITIZER
+THREADSANITIZER_CMAKE_BOOL= ENABLE_THREAD_SANITIZER
TSC_CMAKE_BOOL= ENABLE_TSC_CLOCK
# FLATBUFFERS_LIB_DEPENDS= libflatbuffers.so:devel/flatbuffers
diff --git a/security/snort3/distinfo b/security/snort3/distinfo
index f15c8d9ae1d0..cdd711428360 100644
--- a/security/snort3/distinfo
+++ b/security/snort3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520170188
-SHA256 (snortadmin-snort3-3.0.0-a4.243-BUILD_243_GH0.tar.gz) = 5d4699e12fddff0605050f69d5e64be66dcd809cacca72aa96d59638fd41a343
-SIZE (snortadmin-snort3-3.0.0-a4.243-BUILD_243_GH0.tar.gz) = 6343357
+TIMESTAMP = 1550701372
+SHA256 (snort3-snort3-3.0.0-250_GH0.tar.gz) = 7853c3f9a6490d2c02ce132617545a0e94858db6788ece403636b0a3a2fa0ab1
+SIZE (snort3-snort3-3.0.0-250_GH0.tar.gz) = 6306832
diff --git a/security/snort3/pkg-plist b/security/snort3/pkg-plist
index 25bbfdae1728..c07239a681ec 100644
--- a/security/snort3/pkg-plist
+++ b/security/snort3/pkg-plist
@@ -1,10 +1,13 @@
+bin/appid_detector_builder.sh
bin/snort
bin/snort2lua
bin/u2boat
bin/u2spewfoo
%%ETCDIR%%/file_magic.lua
+%%ETCDIR%%/inline.lua
%%ETCDIR%%/snort.lua
%%ETCDIR%%/snort_defaults.lua
+%%ETCDIR%%/talos.lua
include/snort/actions/actions.h
include/snort/codecs/codec_module.h
include/snort/daqs/daq_user.h
@@ -15,6 +18,7 @@ include/snort/detection/detection_engine.h
include/snort/detection/detection_options.h
include/snort/detection/detection_util.h
include/snort/detection/ips_context.h
+include/snort/detection/ips_context_data.h
include/snort/detection/regex_offload.h
include/snort/detection/rule_option_types.h
include/snort/detection/rules.h
@@ -80,12 +84,19 @@ include/snort/managers/inspector_manager.h
include/snort/mime/decode_b64.h
include/snort/mime/decode_base.h
include/snort/mime/file_mime_config.h
+include/snort/mime/file_mime_context_data.h
include/snort/mime/file_mime_decode.h
include/snort/mime/file_mime_log.h
include/snort/mime/file_mime_paf.h
include/snort/mime/file_mime_process.h
include/snort/network_inspectors/appid/appid_api.h
+include/snort/network_inspectors/appid/appid_dns_session.h
+include/snort/network_inspectors/appid/appid_http_session.h
+include/snort/network_inspectors/appid/appid_session_api.h
+include/snort/network_inspectors/appid/appid_types.h
include/snort/network_inspectors/appid/application_ids.h
+include/snort/network_inspectors/appid/http_xff_fields.h
+include/snort/network_inspectors/packet_tracer/packet_tracer.h
include/snort/packet_io/active.h
include/snort/packet_io/sfdaq.h
include/snort/profiler/memory_context.h
@@ -119,6 +130,7 @@ include/snort/protocols/token_ring.h
include/snort/protocols/udp.h
include/snort/protocols/vlan.h
include/snort/protocols/wlan.h
+include/snort/pub_sub/appid_events.h
include/snort/pub_sub/expect_events.h
include/snort/pub_sub/http_events.h
include/snort/pub_sub/sip_events.h
@@ -151,14 +163,12 @@ include/snort/utils/util_unfold.h
include/snort/utils/util_utf.h
lib/snort/daqs/daq_file.so
lib/snort/daqs/daq_hext.so
-lib/snort/snort-%%CMAKE_BUILD_TYPE%%.cmake
-lib/snort/snort.cmake
libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/README.u2boat
+%%PORTDOCS%%%%DOCSDIR%%/active.txt
%%PORTDOCS%%%%DOCSDIR%%/appid.txt
%%PORTDOCS%%%%DOCSDIR%%/basic.txt
%%PORTDOCS%%%%DOCSDIR%%/binder.txt
-%%PORTDOCS%%%%DOCSDIR%%/bugs.txt
%%PORTDOCS%%%%DOCSDIR%%/building.txt
%%PORTDOCS%%%%DOCSDIR%%/builtin.txt
%%PORTDOCS%%%%DOCSDIR%%/byte_extract.txt
@@ -169,6 +179,7 @@ libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/commands.txt
%%PORTDOCS%%%%DOCSDIR%%/concepts.txt
%%PORTDOCS%%%%DOCSDIR%%/config.txt
+%%PORTDOCS%%%%DOCSDIR%%/config_changes.txt
%%PORTDOCS%%%%DOCSDIR%%/connector.txt
%%PORTDOCS%%%%DOCSDIR%%/connectors.txt
%%PORTDOCS%%%%DOCSDIR%%/counts.txt
@@ -182,14 +193,17 @@ libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/extending.txt
%%PORTDOCS%%%%DOCSDIR%%/features.txt
%%PORTDOCS%%%%DOCSDIR%%/file_processing.txt
+%%PORTDOCS%%%%DOCSDIR%%/ftp.txt
%%PORTDOCS%%%%DOCSDIR%%/gids.txt
%%PORTDOCS%%%%DOCSDIR%%/help.txt
%%PORTDOCS%%%%DOCSDIR%%/high_availability.txt
%%PORTDOCS%%%%DOCSDIR%%/http_inspect.txt
+%%PORTDOCS%%%%DOCSDIR%%/http2_inspect.txt
%%PORTDOCS%%%%DOCSDIR%%/inspector.txt
%%PORTDOCS%%%%DOCSDIR%%/ips_action.txt
%%PORTDOCS%%%%DOCSDIR%%/ips_option.txt
%%PORTDOCS%%%%DOCSDIR%%/logger.txt
+%%PORTDOCS%%%%DOCSDIR%%/module_trace.txt
%%PORTDOCS%%%%DOCSDIR%%/modules.txt
%%PORTDOCS%%%%DOCSDIR%%/options.txt
%%PORTDOCS%%%%DOCSDIR%%/overview.txt
@@ -213,6 +227,7 @@ libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/snort_manual.txt
%%PORTDOCS%%%%DOCSDIR%%/snorty.png
%%PORTDOCS%%%%DOCSDIR%%/style.txt
+%%PORTDOCS%%%%DOCSDIR%%/telnet.txt
%%PORTDOCS%%%%DOCSDIR%%/terms.txt
%%PORTDOCS%%%%DOCSDIR%%/testing_numerical_values.txt
%%PORTDOCS%%%%DOCSDIR%%/tutorial.txt