aboutsummaryrefslogtreecommitdiff
path: root/security/snort3
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-02-01 21:53:19 +0000
committerMark Felder <feld@FreeBSD.org>2018-02-01 21:53:19 +0000
commitdac6918bb970c87bc1592c13fa0131e26da23c9e (patch)
treeaf0903fe3a2d5f081aafd634e90b7375c7797bc6 /security/snort3
parentc85d622a7d6ef4fb3c95df99c6700d814d263acf (diff)
downloadports-dac6918bb970c87bc1592c13fa0131e26da23c9e.tar.gz
ports-dac6918bb970c87bc1592c13fa0131e26da23c9e.zip
security/snort3: Update to Alpha BUILD_242
- Use cmake now as autotools will be going away - Fix segfaulting which was actually caused by devel/hwloc
Notes
Notes: svn path=/head/; revision=460638
Diffstat (limited to 'security/snort3')
-rw-r--r--security/snort3/Makefile10
-rw-r--r--security/snort3/pkg-plist53
2 files changed, 52 insertions, 11 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index 2990b53fd582..fbbaa93548d1 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -12,10 +12,8 @@ COMMENT= Lightweight network intrusion detection system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_11= Segmentation Fault
-BROKEN_FreeBSD_12= Segmentation Fault
-
-BUILD_DEPENDS= daq>=2.2.2:net/daq
+BUILD_DEPENDS= daq>=2.2.2:net/daq \
+ bash>0:shells/bash
LIB_DEPENDS= libpcre.so:devel/pcre \
libdnet.so:net/libdnet \
libpcap.so:net/libpcap \
@@ -23,7 +21,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libhwloc.so:devel/hwloc
RUN_DEPENDS= daq>=2.2.2:net/daq
-USES= autoreconf cpe libtool pathfix pkgconfig ssl
+USES= cmake compiler:c++11-lang cpe libtool pathfix pkgconfig ssl
USE_GITHUB= yes
GH_ACCOUNT= snortadmin
GH_PROJECT= snort3
@@ -41,6 +39,8 @@ DEBUG_CONFIGURE_DISABLE= corefiles
DEBUG_MAKE_ENV= DONTSTRIP="yes"
LRGPCAP_CONFIGURE_ENABLE= large-pcap
+.include <bsd.port.options.mk>
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/snort3/pkg-plist b/security/snort3/pkg-plist
index 850df7b702fc..e7b5c4e0d2e8 100644
--- a/security/snort3/pkg-plist
+++ b/security/snort3/pkg-plist
@@ -11,7 +11,6 @@ include/snort/daqs/daq_user.h
include/snort/decompress/file_decomp.h
include/snort/detection/detect.h
include/snort/detection/detect_trace.h
-include/snort/detection/detection_defines.h
include/snort/detection/detection_engine.h
include/snort/detection/detection_options.h
include/snort/detection/detection_util.h
@@ -32,6 +31,7 @@ include/snort/file_api/file_module.h
include/snort/file_api/file_policy.h
include/snort/file_api/file_segment.h
include/snort/file_api/file_service.h
+include/snort/flow/expect_cache.h
include/snort/flow/flow.h
include/snort/flow/flow_key.h
include/snort/framework/api_options.h
@@ -55,18 +55,23 @@ include/snort/framework/parameter.h
include/snort/framework/range.h
include/snort/framework/so_rule.h
include/snort/framework/value.h
+include/snort/hash/ghash.h
include/snort/hash/hashes.h
-include/snort/hash/sfghash.h
-include/snort/hash/sfhashfcn.h
-include/snort/hash/sfxhash.h
+include/snort/hash/hashfcn.h
+include/snort/hash/xhash.h
+include/snort/helpers/base64_encoder.h
+include/snort/log/log.h
+include/snort/log/log_text.h
include/snort/log/messages.h
+include/snort/log/obfuscator.h
include/snort/log/text_log.h
+include/snort/log/u2_packet.h
include/snort/log/unified2.h
include/snort/lua/snort_config.lua
include/snort/lua/snort_plugin.lua
include/snort/main/policy.h
include/snort/main/snort_config.h
-include/snort/main/snort_debug.h
+include/snort/main/snort_%%CMAKE_BUILD_TYPE%%.h
include/snort/main/snort_types.h
include/snort/main/thread.h
include/snort/managers/codec_manager.h
@@ -78,7 +83,10 @@ include/snort/mime/file_mime_decode.h
include/snort/mime/file_mime_log.h
include/snort/mime/file_mime_paf.h
include/snort/mime/file_mime_process.h
+include/snort/network_inspectors/appid/appid_api.h
+include/snort/network_inspectors/appid/application_ids.h
include/snort/packet_io/active.h
+include/snort/packet_io/sfdaq.h
include/snort/profiler/memory_context.h
include/snort/profiler/memory_defs.h
include/snort/profiler/memory_profiler_defs.h
@@ -110,6 +118,9 @@ include/snort/protocols/token_ring.h
include/snort/protocols/udp.h
include/snort/protocols/vlan.h
include/snort/protocols/wlan.h
+include/snort/pub_sub/expect_events.h
+include/snort/pub_sub/http_events.h
+include/snort/pub_sub/sip_events.h
include/snort/search_engines/search_common.h
include/snort/search_engines/search_tool.h
include/snort/sfip/sf_cidr.h
@@ -118,11 +129,14 @@ include/snort/sfip/sf_returns.h
include/snort/stream/paf.h
include/snort/stream/stream.h
include/snort/stream/stream_splitter.h
+include/snort/target_based/snort_protocols.h
include/snort/time/clock_defs.h
+include/snort/time/packet_time.h
include/snort/time/stopwatch.h
include/snort/time/tsc_clock.h
include/snort/utils/bitop.h
include/snort/utils/cpp_macros.h
+include/snort/utils/endian.h
include/snort/utils/kmap.h
include/snort/utils/safec.h
include/snort/utils/segment_mem.h
@@ -136,21 +150,30 @@ include/snort/utils/util_unfold.h
include/snort/utils/util_utf.h
lib/snort/daqs/daq_file.so
lib/snort/daqs/daq_hext.so
+lib/snort/snort-%%CMAKE_BUILD_TYPE%%.cmake
+lib/snort/snort.cmake
libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/README.u2boat
%%PORTDOCS%%%%DOCSDIR%%/appid.txt
+%%PORTDOCS%%%%DOCSDIR%%/basic.txt
%%PORTDOCS%%%%DOCSDIR%%/binder.txt
%%PORTDOCS%%%%DOCSDIR%%/bugs.txt
%%PORTDOCS%%%%DOCSDIR%%/building.txt
+%%PORTDOCS%%%%DOCSDIR%%/builtin.txt
%%PORTDOCS%%%%DOCSDIR%%/byte_extract.txt
%%PORTDOCS%%%%DOCSDIR%%/byte_jump.txt
%%PORTDOCS%%%%DOCSDIR%%/byte_math.txt
%%PORTDOCS%%%%DOCSDIR%%/byte_test.txt
+%%PORTDOCS%%%%DOCSDIR%%/codec.txt
+%%PORTDOCS%%%%DOCSDIR%%/commands.txt
%%PORTDOCS%%%%DOCSDIR%%/concepts.txt
-%%PORTDOCS%%%%DOCSDIR%%/config_changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/config.txt
+%%PORTDOCS%%%%DOCSDIR%%/connector.txt
%%PORTDOCS%%%%DOCSDIR%%/connectors.txt
+%%PORTDOCS%%%%DOCSDIR%%/counts.txt
%%PORTDOCS%%%%DOCSDIR%%/daq.txt
%%PORTDOCS%%%%DOCSDIR%%/daq_readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/data.txt
%%PORTDOCS%%%%DOCSDIR%%/dcerpc.txt
%%PORTDOCS%%%%DOCSDIR%%/differences.txt
%%PORTDOCS%%%%DOCSDIR%%/enviro.txt
@@ -158,17 +181,34 @@ libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/extending.txt
%%PORTDOCS%%%%DOCSDIR%%/features.txt
%%PORTDOCS%%%%DOCSDIR%%/file_processing.txt
+%%PORTDOCS%%%%DOCSDIR%%/gids.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.txt
%%PORTDOCS%%%%DOCSDIR%%/high_availability.txt
%%PORTDOCS%%%%DOCSDIR%%/http_inspect.txt
+%%PORTDOCS%%%%DOCSDIR%%/inspector.txt
+%%PORTDOCS%%%%DOCSDIR%%/ips_action.txt
+%%PORTDOCS%%%%DOCSDIR%%/ips_option.txt
+%%PORTDOCS%%%%DOCSDIR%%/logger.txt
+%%PORTDOCS%%%%DOCSDIR%%/modules.txt
+%%PORTDOCS%%%%DOCSDIR%%/options.txt
%%PORTDOCS%%%%DOCSDIR%%/overview.txt
%%PORTDOCS%%%%DOCSDIR%%/params.txt
%%PORTDOCS%%%%DOCSDIR%%/perf_monitor.txt
+%%PORTDOCS%%%%DOCSDIR%%/plugins.txt
+%%PORTDOCS%%%%DOCSDIR%%/pop_imap.txt
+%%PORTDOCS%%%%DOCSDIR%%/port_scan.txt
%%PORTDOCS%%%%DOCSDIR%%/reference.txt
%%PORTDOCS%%%%DOCSDIR%%/sensitive_data.txt
%%PORTDOCS%%%%DOCSDIR%%/side_channel.txt
+%%PORTDOCS%%%%DOCSDIR%%/signals.txt
+%%PORTDOCS%%%%DOCSDIR%%/smtp.txt
%%PORTDOCS%%%%DOCSDIR%%/snort2lua.txt
+%%PORTDOCS%%%%DOCSDIR%%/snort2lua_cmds.txt
%%PORTDOCS%%%%DOCSDIR%%/snort2x.png
%%PORTDOCS%%%%DOCSDIR%%/snort3x.png
+%%PORTDOCS%%%%DOCSDIR%%/snort_manual.html
+%%PORTDOCS%%%%DOCSDIR%%/snort_manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/snort_manual.text
%%PORTDOCS%%%%DOCSDIR%%/snort_manual.txt
%%PORTDOCS%%%%DOCSDIR%%/snorty.png
%%PORTDOCS%%%%DOCSDIR%%/style.txt
@@ -176,4 +216,5 @@ libdata/pkgconfig/snort.pc
%%PORTDOCS%%%%DOCSDIR%%/testing_numerical_values.txt
%%PORTDOCS%%%%DOCSDIR%%/tutorial.txt
%%PORTDOCS%%%%DOCSDIR%%/usage.txt
+%%PORTDOCS%%%%DOCSDIR%%/version.txt
%%PORTDOCS%%%%DOCSDIR%%/wizard.txt