aboutsummaryrefslogtreecommitdiff
path: root/security/snortsnarf
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 13:12:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 13:12:04 +0000
commit15770e14f7238e0c468a4909780dbcea4e693831 (patch)
tree38759858d936eeccf41e7d46ec345f7af70fb7b8 /security/snortsnarf
parent0e884413bcd63aa2712f6b8dc2f0bbee8348254b (diff)
downloadports-15770e14f7238e0c468a4909780dbcea4e693831.tar.gz
ports-15770e14f7238e0c468a4909780dbcea4e693831.zip
Notes
Diffstat (limited to 'security/snortsnarf')
-rw-r--r--security/snortsnarf/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/security/snortsnarf/Makefile b/security/snortsnarf/Makefile
index b65c9bc0a207..7bbaca41661d 100644
--- a/security/snortsnarf/Makefile
+++ b/security/snortsnarf/Makefile
@@ -17,21 +17,20 @@ USES= perl5
NO_BUILD= yes
USE_PERL5= run
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${SED} -e 's|\./include|${PREFIX}/libdata/${PORTNAME}|' \
< ${WRKSRC}/snortsnarf.pl > ${WRKSRC}/snortsnarf
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/snortsnarf ${LOCALBASE}/bin
- @${MKDIR} ${PREFIX}/libdata/snortsnarf
- @(cd ${WRKSRC}/include \
- && ${COPYTREE_SHARE} . ${PREFIX}/libdata/${PORTNAME})
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/snortsnarf ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libdata/snortsnarf
+ (cd ${WRKSRC}/include \
+ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/libdata/${PORTNAME})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in README Usage
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>