aboutsummaryrefslogtreecommitdiff
path: root/security/softether-devel
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-02-27 06:34:44 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-02-27 06:34:44 +0000
commit09a66268dfddb630f0f9076aea3eba79f62b2ec2 (patch)
treeca0984b3f5b40ecd97d554a2c1838b1971e52172 /security/softether-devel
parentdc73dfedce5a43bd0c502c641c32fa30d0ff2f07 (diff)
downloadports-09a66268dfddb630f0f9076aea3eba79f62b2ec2.tar.gz
ports-09a66268dfddb630f0f9076aea3eba79f62b2ec2.zip
Notes
Diffstat (limited to 'security/softether-devel')
-rw-r--r--security/softether-devel/Makefile59
-rw-r--r--security/softether-devel/files/patch-chain-certs-dir31
-rw-r--r--security/softether-devel/files/patch-piddir29
-rw-r--r--security/softether-devel/files/patch-src__Cedar__Cedar.h75
-rw-r--r--security/softether-devel/files/patch-src__Cedar__Client.h20
-rw-r--r--security/softether-devel/files/patch-src__Cedar__Nat.h11
-rw-r--r--security/softether-devel/files/patch-src__Cedar__Server.c30
-rw-r--r--security/softether-devel/files/patch-src__Mayaqua__Cfg.c11
-rw-r--r--security/softether-devel/files/patch-src__Mayaqua__Cfg.h11
-rw-r--r--security/softether-devel/files/patch-src__Mayaqua__Kernel.c11
-rw-r--r--security/softether-devel/files/patch-src__Mayaqua__Table.h11
-rw-r--r--security/softether-devel/files/patch-src__Mayaqua__Unix.c29
-rw-r--r--security/softether-devel/files/pkg-message.in (renamed from security/softether-devel/pkg-message)4
-rw-r--r--security/softether-devel/pkg-plist3
14 files changed, 119 insertions, 216 deletions
diff --git a/security/softether-devel/Makefile b/security/softether-devel/Makefile
index 6013e42fe441..5973b84f3396 100644
--- a/security/softether-devel/Makefile
+++ b/security/softether-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= softether
DISTVERSION= 4.28-9669-beta
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://www.softether-download.com/files/softether/v${DISTVERSION}-2018.09.11-tree/Source_Code/
PKGNAMESUFFIX= -devel
@@ -22,7 +23,6 @@ USE_RC_SUBR= softether_bridge softether_client softether_server
DOS2UNIX_FILES= ChangeLog LICENSE README *.TXT \
src/Cedar/*.* src/Mayaqua/*.*
-SUB_FILES= vpncmd
OPTIONS_DEFINE= DOCS UNLOCK
@@ -39,9 +39,11 @@ UNLOCK_EXTRA_PATCHES= ${FILESDIR}/extra-patch-unrestrict-enterprise-functions
CONFLICTS_INSTALL= softether-4.* softether5
PORTDOCS= AUTHORS.TXT ChangeLog LICENSE README THIRD_PARTY.TXT WARNING.TXT
-LOGDIR?= /var/log/softether
-PLIST_SUB= LOGDIR="${LOGDIR}"
-SUB_LIST= LOGDIR="${LOGDIR}"
+SE_DBDIR?= /var/db/${PORTNAME}
+SE_LOGDIR?= /var/log/${PORTNAME}
+PLIST_SUB= SE_DBDIR="${SE_DBDIR}" SE_LOGDIR="${SE_LOGDIR}"
+SUB_LIST= SE_DBDIR="${SE_DBDIR}" SE_LOGDIR="${SE_LOGDIR}"
+SUB_FILES= pkg-message vpncmd
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -54,6 +56,52 @@ ALL_TARGET= build
.include <bsd.port.options.mk>
post-patch:
+ # SoftEther scatters logs, config files and PID files in PREFIX/libexec
+ # directory. To write them in the right place, replace it.
+ ${REINPLACE_CMD} \
+ -e "s|@vpn_server_template|${SE_DBDIR}/vpn_server_template|" \
+ -e "s|@vpn_server|${SE_DBDIR}/vpn_server|" \
+ -e "s|@vpn_bridge|${SE_DBDIR}/vpn_bridge|" \
+ -e "s|@vpn_gate_svc|${SE_DBDIR}/vpn_gate_svc|" \
+ -e "s|@vpn_gate_relay|${SE_DBDIR}/vpn_gate_relay|" \
+ ${WRKSRC}/src/Cedar/Server.c
+
+ ${REINPLACE_CMD} \
+ -e "s|@adminip|${SE_DBDIR}/adminip|" \
+ -e "s|@etherlogger|${SE_DBDIR}/etherlogger|" \
+ -e "s|@vpn_client|${SE_DBDIR}/vpn_client|" \
+ -e "s|@vpn_router|${SE_DBDIR}/vpn_router|" \
+ -e "s|@custom|${SE_DBDIR}/custom|" \
+ -e "s|@backup|${SE_DBDIR}/backup|" \
+ -e "s|@save_binary|${SE_DBDIR}/save_binary|" \
+ -e "s|@lang|${SE_DBDIR}/lang|" \
+ -e "s|@azureserver|${SE_DBDIR}/azureserver|" \
+ -e "s|@server_log|${SE_LOGDIR}/server|" \
+ -e "s|@security_log|${SE_LOGDIR}/security|" \
+ -e "s|@packet_log|${SE_LOGDIR}/packet|" \
+ -e "s|@secure_nat_log|${SE_LOGDIR}/secure_nat|" \
+ -e "s|@client_log|${SE_LOGDIR}/client|" \
+ -e "s|@tiny_log|${SE_LOGDIR}/tiny|" \
+ -e "s|@carrier_log|${SE_LOGDIR}/carrier|" \
+ -e "s|@etherlogger_log|${SE_LOGDIR}/etherlogger|" \
+ ${WRKSRC}/src/Cedar/Cedar.h \
+ ${WRKSRC}/src/Cedar/Client.h \
+ ${WRKSRC}/src/Cedar/Nat.h \
+ ${WRKSRC}/src/Cedar/Server.c \
+ ${WRKSRC}/src/Mayaqua/Cfg.c \
+ ${WRKSRC}/src/Mayaqua/Cfg.h \
+ ${WRKSRC}/src/Mayaqua/Table.h
+
+ ${REINPLACE_CMD} \
+ -e "s|abort_error_log\.txt|${SE_LOGDIR}/abort_error_log.txt|" \
+ ${WRKSRC}/src/Mayaqua/Kernel.c
+
+ ${REINPLACE_CMD} \
+ -e "s|%%SE_DBDIR%%|${SE_DBDIR}|g" \
+ ${WRKSRC}/src/Cedar/Protocol.c \
+ ${WRKSRC}/src/Mayaqua/Unix.c \
+ ${WRKSRC}/src/Mayaqua/Network.c
+
# skip configure at all and copy the corresponding Makefile in place
.if ${ARCH} != "amd64"
@${CP} ${WRKSRC}/src/makefiles/freebsd_32bit.mak ${WRKSRC}/Makefile
@@ -78,7 +126,8 @@ do-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/${i}
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${LOGDIR}
+ @${MKDIR} ${STAGEDIR}${SE_DBDIR}
+ @${MKDIR} ${STAGEDIR}${SE_LOGDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/security/softether-devel/files/patch-chain-certs-dir b/security/softether-devel/files/patch-chain-certs-dir
new file mode 100644
index 000000000000..7a962c115e04
--- /dev/null
+++ b/security/softether-devel/files/patch-chain-certs-dir
@@ -0,0 +1,31 @@
+--- src/Cedar/Protocol.c.orig 2019-02-03 19:43:50 UTC
++++ src/Cedar/Protocol.c
+@@ -58,7 +58,7 @@ bool TryGetRootCertChain(LIST *o, X *x, bool auto_save
+ wchar_t exedir[MAX_SIZE];
+
+ GetExeDirW(exedir, sizeof(exedir));
+- CombinePathW(dirname, sizeof(dirname), exedir, L"chain_certs");
++ CombinePathW(dirname, sizeof(dirname), L"%%SE_DBDIR%%", L"chain_certs");
+ MakeDirExW(dirname);
+
+ if (auto_save)
+@@ -365,7 +365,7 @@ void AddAllChainCertsToCertList(LIST *o)
+
+ GetExeDirW(exedir, sizeof(exedir));
+
+- CombinePathW(dirname, sizeof(dirname), exedir, L"chain_certs");
++ CombinePathW(dirname, sizeof(dirname), L"%%SE_DBDIR%%", L"chain_certs");
+
+ MakeDirExW(dirname);
+
+--- src/Mayaqua/Network.c.orig 2019-02-03 19:43:50 UTC
++++ src/Mayaqua/Network.c
+@@ -11520,7 +11520,7 @@ void AddChainSslCertOnDirectory(struct ssl_ctx_st *ctx
+
+ GetExeDirW(exedir, sizeof(exedir));
+
+- CombinePathW(dirname, sizeof(dirname), exedir, L"chain_certs");
++ CombinePathW(dirname, sizeof(dirname), L"%%SE_DBDIR%%", L"chain_certs");
+
+ MakeDirExW(dirname);
+
diff --git a/security/softether-devel/files/patch-piddir b/security/softether-devel/files/patch-piddir
new file mode 100644
index 000000000000..c8375df27fcc
--- /dev/null
+++ b/security/softether-devel/files/patch-piddir
@@ -0,0 +1,29 @@
+--- src/Mayaqua/Unix.c.orig 2019-02-03 19:43:50 UTC
++++ src/Mayaqua/Unix.c
+@@ -774,7 +774,7 @@ void *UnixNewSingleInstance(char *instance_name)
+ GetExeDir(dir, sizeof(dir));
+
+ // File name generation
+- Format(name, sizeof(name), "%s/.%s", dir, tmp);
++ Format(name, sizeof(name), "%%SE_DBDIR%%/.%s", tmp);
+
+ fd = open(name, O_WRONLY);
+ if (fd == -1)
+@@ -2194,7 +2194,7 @@ void UnixGenPidFileName(char *name, UINT size)
+ Md5(hash, exe_name, StrLen(exe_name));
+ BinToStr(tmp1, sizeof(tmp1), hash, sizeof(hash));
+
+- Format(name, size, "%s/.pid_%s", dir, tmp1);
++ Format(name, size, "%%SE_DBDIR%%/.pid_%s", tmp1);
+ }
+
+ // Delete the PID file
+@@ -2239,7 +2239,7 @@ void UnixGenCtlFileName(char *name, UINT size)
+ Md5(hash, exe_name, StrLen(exe_name));
+ BinToStr(tmp1, sizeof(tmp1), hash, sizeof(hash));
+
+- Format(name, size, "%s/.ctl_%s", dir, tmp1);
++ Format(name, size, "%%SE_DBDIR%%/.ctl_%s", tmp1);
+ }
+
+ // Write the CTL file
diff --git a/security/softether-devel/files/patch-src__Cedar__Cedar.h b/security/softether-devel/files/patch-src__Cedar__Cedar.h
deleted file mode 100644
index c4888df0a44b..000000000000
--- a/security/softether-devel/files/patch-src__Cedar__Cedar.h
+++ /dev/null
@@ -1,75 +0,0 @@
---- src/Cedar/Cedar.h.orig 2016-05-03 06:16:53 UTC
-+++ src/Cedar/Cedar.h
-@@ -510,22 +510,22 @@
- #define LOG_ENGINE_BUFFER_CACHE_SIZE_MAX (10 * 1024 * 1024) // Write cache size
-
- // Constant such as a file name
--#define SERVER_LOG_DIR_NAME "@server_log"
-+#define SERVER_LOG_DIR_NAME "/var/log/softether/server"
- #define BRIDGE_LOG_DIR_NAME SERVER_LOG_DIR_NAME
- #define SERVER_LOG_PERFIX "vpn"
-
--#define HUB_SECURITY_LOG_DIR_NAME "@security_log"
--#define HUB_SECURITY_LOG_FILE_NAME "@security_log/%s"
-+#define HUB_SECURITY_LOG_DIR_NAME "/var/log/softether/security"
-+#define HUB_SECURITY_LOG_FILE_NAME "/var/log/softether/security/%s"
- #define HUB_SECURITY_LOG_PREFIX "sec"
--#define HUB_PACKET_LOG_DIR_NAME "@packet_log"
--#define HUB_PACKET_LOG_FILE_NAME "@packet_log/%s"
-+#define HUB_PACKET_LOG_DIR_NAME "/var/log/softether/packet"
-+#define HUB_PACKET_LOG_FILE_NAME "/var/log/softether/packet/%s"
- #define HUB_PACKET_LOG_PREFIX "pkt"
-
--#define NAT_LOG_DIR_NAME "@secure_nat_log"
--#define NAT_LOG_FILE_NAME "@secure_nat_log/%s"
-+#define NAT_LOG_DIR_NAME "/var/log/softether/secure_nat"
-+#define NAT_LOG_FILE_NAME "/var/log/softether/secure_nat/%s"
- #define NAT_LOG_PREFIX "snat"
-
--#define CLIENT_LOG_DIR_NAME "@client_log"
-+#define CLIENT_LOG_DIR_NAME "/var/log/softether/client"
- #define CLIENT_LOG_PREFIX "client"
-
- // Packet log settings
-@@ -560,8 +560,8 @@
- #define DISK_FREE_CHECK_INTERVAL_DEFAULT (5 * 60 * 1000)
-
- // Simple log
--#define TINY_LOG_DIRNAME "@tiny_log"
--#define TINY_LOG_FILENAME "@tiny_log/%04u%02u%02u_%02u%02u%02u.log"
-+#define TINY_LOG_DIRNAME "/var/log/softether/tiny"
-+#define TINY_LOG_FILENAME "/var/log/softether/tiny/%04u%02u%02u_%02u%02u%02u.log"
-
-
- //////////////////////////////////////////////////////////////////////
-@@ -574,7 +574,7 @@
- //#define CE_SNAPSHOT_INTERVAL ((UINT64)(3000))
- #define CE_SNAPSHOT_POLLING_INTERVAL (1 * 1000)
- #define CE_SNAPSHOT_POLLING_INTERVAL_LICENSE (30 * 1000)
--#define CE_SNAPSHOT_DIR_NAME "@carrier_log"
-+#define CE_SNAPSHOT_DIR_NAME "/var/log/softether/carrier"
- #define CE_SNAPSHOT_PREFIX "carrier"
-
-
-@@ -591,7 +591,7 @@
- // Expiration date of random size cache
- #define RAND_SIZE_CACHE_EXPIRE (24 * 60 * 60 * 1000)
- // Management allowed IP address list file name
--#define ADMINIP_TXT "@adminip.txt"
-+#define ADMINIP_TXT "/var/db/softether/adminip.txt"
-
- #define NON_SSL_MIN_COUNT 60
- #define NON_SSL_ENTRY_EXPIRES (10 * 60 * 1000)
-@@ -642,9 +642,9 @@
- //////////////////////////////////////////////////////////////////////
-
- #define EL_ADMIN_PORT 22888
--#define EL_CONFIG_FILENAME "@etherlogger.config"
--#define EL_PACKET_LOG_DIR_NAME "@etherlogger_log"
--#define EL_PACKET_LOG_FILE_NAME "@etherlogger_log/%s"
-+#define EL_CONFIG_FILENAME "/var/db/softether/etherlogger.config"
-+#define EL_PACKET_LOG_DIR_NAME "/var/log/softether/etherlogger"
-+#define EL_PACKET_LOG_FILE_NAME "/var/log/softether/etherlogger/%s"
- #define EL_PACKET_LOG_PREFIX "pkt"
- #define EL_LICENSE_CHECK_SPAN (10 * 1000)
-
diff --git a/security/softether-devel/files/patch-src__Cedar__Client.h b/security/softether-devel/files/patch-src__Cedar__Client.h
deleted file mode 100644
index 8515a6b79ec4..000000000000
--- a/security/softether-devel/files/patch-src__Cedar__Client.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Cedar/Client.h.orig 2016-05-03 06:16:53 UTC
-+++ src/Cedar/Client.h
-@@ -125,7 +125,7 @@
-
-
- // Constants
--#define CLIENT_CONFIG_FILE_NAME "@vpn_client.config"
-+#define CLIENT_CONFIG_FILE_NAME "/var/db/softether/vpn_client.config"
- #define CLIENT_DEFAULT_KEEPALIVE_HOST "keepalive.softether.org"
- #define CLIENT_DEFAULT_KEEPALIVE_PORT 80
- #define CLIENT_DEFAULT_KEEPALIVE_INTERVAL KEEP_INTERVAL_DEFAULT
-@@ -145,7 +145,7 @@
- #define CLIENT_WIN32_EXE_FILENAME_X64 "vpnclient_x64.exe"
- #define CLIENT_WIN32_EXE_FILENAME_IA64 "vpnclient_ia64.exe"
-
--#define CLIENT_CUSTOM_INI_FILENAME "@custom.ini"
-+#define CLIENT_CUSTOM_INI_FILENAME "/var/db/softether/custom.ini"
-
- #define CLIENT_GLOBAL_PULSE_NAME "clientglobalpulse"
-
diff --git a/security/softether-devel/files/patch-src__Cedar__Nat.h b/security/softether-devel/files/patch-src__Cedar__Nat.h
deleted file mode 100644
index 38da377ada63..000000000000
--- a/security/softether-devel/files/patch-src__Cedar__Nat.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Cedar/Nat.h.orig 2016-05-03 06:16:53 UTC
-+++ src/Cedar/Nat.h
-@@ -115,7 +115,7 @@
- #define NAT_H
-
- // Constants
--#define NAT_CONFIG_FILE_NAME "@vpn_router.config" // NAT configuration file
-+#define NAT_CONFIG_FILE_NAME "/var/db/softether/vpn_router.config" // NAT configuration file
- #define DEFAULT_NAT_ADMIN_PORT 2828 // Default port number for management
- #define NAT_ADMIN_PORT_LISTEN_INTERVAL 1000 // Interval for trying to open a port for management
- #define NAT_FILE_SAVE_INTERVAL (30 * 1000) // Interval to save
diff --git a/security/softether-devel/files/patch-src__Cedar__Server.c b/security/softether-devel/files/patch-src__Cedar__Server.c
deleted file mode 100644
index 1de2f960cf5b..000000000000
--- a/security/softether-devel/files/patch-src__Cedar__Server.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/Cedar/Server.c.orig 2016-05-03 06:16:53 UTC
-+++ src/Cedar/Server.c
-@@ -115,12 +115,12 @@
-
- static SERVER *server = NULL;
- static LOCK *server_lock = NULL;
--char *SERVER_CONFIG_FILE_NAME = "@vpn_server.config";
--char *SERVER_CONFIG_FILE_NAME_IN_CLIENT = "@vpn_gate_svc.config";
--char *SERVER_CONFIG_FILE_NAME_IN_CLIENT_RELAY = "@vpn_gate_relay.config";
--char *BRIDGE_CONFIG_FILE_NAME = "@vpn_bridge.config";
--char *SERVER_CONFIG_TEMPLATE_NAME = "@vpn_server_template.config";
--char *BRIDGE_CONFIG_TEMPLATE_NAME = "@vpn_server_template.config";
-+char *SERVER_CONFIG_FILE_NAME = "/var/db/softether/vpn_server.config";
-+char *SERVER_CONFIG_FILE_NAME_IN_CLIENT = "/var/db/softether/vpn_gate_svc.config";
-+char *SERVER_CONFIG_FILE_NAME_IN_CLIENT_RELAY = "/var/db/softether/vpn_gate_relay.config";
-+char *BRIDGE_CONFIG_FILE_NAME = "/var/db/softether/vpn_bridge.config";
-+char *SERVER_CONFIG_TEMPLATE_NAME = "/var/db/softether/vpn_server_template.config";
-+char *BRIDGE_CONFIG_TEMPLATE_NAME = "/var/db/softether/vpn_server_template.config";
-
- static bool server_reset_setting = false;
-
-@@ -10916,7 +10916,7 @@ SERVER *SiNewServerEx(bool bridge, bool
- #endif // OS_WIN32
-
- #ifdef ENABLE_AZURE_SERVER
-- if (IsFileExists("@azureserver.config"))
-+ if (IsFileExists("/var/db/softether/azureserver.config"))
- {
- DisableRDUPServerGlobally();
- s->AzureServer = NewAzureServer(s->Cedar);
diff --git a/security/softether-devel/files/patch-src__Mayaqua__Cfg.c b/security/softether-devel/files/patch-src__Mayaqua__Cfg.c
deleted file mode 100644
index 6c55d843ec77..000000000000
--- a/security/softether-devel/files/patch-src__Mayaqua__Cfg.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Mayaqua/Cfg.c.orig 2016-05-03 06:16:53 UTC
-+++ src/Mayaqua/Cfg.c
-@@ -139,7 +139,7 @@ void BackupCfgWEx(CFG_RW *rw, FOLDER *f,
- }
-
- // Determine the directory name
-- UniFormat(dirname, sizeof(dirname), L"@backup.%s", original[0] == L'@' ? original + 1 : original);
-+ UniFormat(dirname, sizeof(dirname), L"/var/db/softether/backup.%s", original[0] == L'@' ? original + 1 : original);
-
- // Determine the file name
- LocalTime(&st);
diff --git a/security/softether-devel/files/patch-src__Mayaqua__Cfg.h b/security/softether-devel/files/patch-src__Mayaqua__Cfg.h
deleted file mode 100644
index 41460bf3f5e2..000000000000
--- a/security/softether-devel/files/patch-src__Mayaqua__Cfg.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Mayaqua/Cfg.h.orig 2016-05-03 06:16:53 UTC
-+++ src/Mayaqua/Cfg.h
-@@ -117,7 +117,7 @@
- // Macro
- //#define CHECK_CFG_NAME_EXISTS // Check duplication of the existing name
-
--#define SAVE_BINARY_FILE_NAME_SWITCH L"@save_binary"
-+#define SAVE_BINARY_FILE_NAME_SWITCH L"/var/db/softether/save_binary"
-
- // Constants
- #define TAG_DECLARE "declare"
diff --git a/security/softether-devel/files/patch-src__Mayaqua__Kernel.c b/security/softether-devel/files/patch-src__Mayaqua__Kernel.c
deleted file mode 100644
index eb10840d9765..000000000000
--- a/security/softether-devel/files/patch-src__Mayaqua__Kernel.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Mayaqua/Kernel.c.orig 2016-05-03 06:16:53 UTC
-+++ src/Mayaqua/Kernel.c
-@@ -2213,7 +2213,7 @@ void AbortExitEx(char *msg)
- msg = "Unknown Error";
- }
-
-- f = fopen("abort_error_log.txt", "w");
-+ f = fopen("/var/db/softether/abort_error_log.txt", "w");
- if (f != NULL)
- {
- fwrite(msg, 1, strlen(msg), f);
diff --git a/security/softether-devel/files/patch-src__Mayaqua__Table.h b/security/softether-devel/files/patch-src__Mayaqua__Table.h
deleted file mode 100644
index beb87352dd9e..000000000000
--- a/security/softether-devel/files/patch-src__Mayaqua__Table.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Mayaqua/Table.h.orig 2016-05-03 06:16:53 UTC
-+++ src/Mayaqua/Table.h
-@@ -119,7 +119,7 @@
- #define LANGLIST_FILENAME "|languages.txt"
- #define LANGLIST_FILENAME_WINE "|languages_wine.txt"
-
--#define LANG_CONFIG_FILENAME L"@lang.config"
-+#define LANG_CONFIG_FILENAME L"/var/db/softether/lang.config"
- #define LANG_CONFIG_TEMPLETE "|lang.config"
-
- // Language constant
diff --git a/security/softether-devel/files/patch-src__Mayaqua__Unix.c b/security/softether-devel/files/patch-src__Mayaqua__Unix.c
deleted file mode 100644
index 832f4bd69bf8..000000000000
--- a/security/softether-devel/files/patch-src__Mayaqua__Unix.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/Mayaqua/Unix.c.orig 2016-05-03 06:16:53 UTC
-+++ src/Mayaqua/Unix.c
-@@ -931,7 +931,7 @@ void *UnixNewSingleInstance(char *instan
- GetExeDir(dir, sizeof(dir));
-
- // File name generation
-- Format(name, sizeof(name), "%s/.%s", dir, tmp);
-+ Format(name, sizeof(name), "/var/db/softether/.%s", tmp);
-
- fd = open(name, O_WRONLY);
- if (fd == -1)
-@@ -2320,7 +2320,7 @@ void UnixGenPidFileName(char *name, UINT
- Hash(hash, exe_name, StrLen(exe_name), false);
- BinToStr(tmp1, sizeof(tmp1), hash, sizeof(hash));
-
-- Format(name, size, "%s/.pid_%s", dir, tmp1);
-+ Format(name, size, "/var/db/softether/%s.pid", tmp1);
- }
-
- // Delete the PID file
-@@ -2365,7 +2365,7 @@ void UnixGenCtlFileName(char *name, UINT
- Hash(hash, exe_name, StrLen(exe_name), false);
- BinToStr(tmp1, sizeof(tmp1), hash, sizeof(hash));
-
-- Format(name, size, "%s/.ctl_%s", dir, tmp1);
-+ Format(name, size, "/var/db/softether/.ctl_%s", tmp1);
- }
-
- // Write the CTL file
diff --git a/security/softether-devel/pkg-message b/security/softether-devel/files/pkg-message.in
index 23e7360a69ac..29299ccca65f 100644
--- a/security/softether-devel/pkg-message
+++ b/security/softether-devel/files/pkg-message.in
@@ -17,6 +17,8 @@ Please note client and bridge functionality is not fully
supported on FreeBSD right now.
When removing SoftEther VPN without the desire to reinstall, please
-ensure to remove the directory /var/db/softether as well.
+ensure to remove the following dirctories as well:
+- %%SE_DBDIR%%
+- %%SE_LOGDIR%%
**************************************************************************
diff --git a/security/softether-devel/pkg-plist b/security/softether-devel/pkg-plist
index d0b6f42c71b3..26279b02899c 100644
--- a/security/softether-devel/pkg-plist
+++ b/security/softether-devel/pkg-plist
@@ -5,4 +5,5 @@ libexec/softether/vpncmd
libexec/softether/vpnserver
sbin/vpncmd
@dir libexec/softether
-@dir %%LOGDIR%%
+@dir %%SE_DBDIR%%
+@dir %%SE_LOGDIR%%