aboutsummaryrefslogtreecommitdiff
path: root/security/softether5
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-03-18 05:19:32 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-03-18 05:19:32 +0000
commit732ed1024f762fb91f0d26e58790676b542199fd (patch)
treed3db6f519a6549e9cd7ca36b855cc9d81c3a99a3 /security/softether5
parent6cd717cf69e0a5a2b08b6859d05c1e547f57d8ae (diff)
downloadports-732ed1024f762fb91f0d26e58790676b542199fd.tar.gz
ports-732ed1024f762fb91f0d26e58790676b542199fd.zip
security/softether5: conditionalize dependence on devel/cpu_features
devel/cpu_features is not available on some architectures after r496118. Furturemore, upstream doesn't require cpu_features on some architectures such as armv7l, aarch64, s390x. Add CFLAGS=-DSKIP_CPU_FEATURES on architectures devel/cpu_features is not available. Tested no-harm on amd64.
Notes
Notes: svn path=/head/; revision=496122
Diffstat (limited to 'security/softether5')
-rw-r--r--security/softether5/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/security/softether5/Makefile b/security/softether5/Makefile
index 4c84d76e99f2..3b133092ed3b 100644
--- a/security/softether5/Makefile
+++ b/security/softether5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= softether
DISTVERSION= 5.01.9669
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
PKGNAMESUFFIX= 5
@@ -12,8 +12,6 @@ COMMENT= SoftEther VPN 5 (Developer Edition)
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/include/cpu_features_macros.h:devel/cpu_features
-
USES+= cmake:noninja dos2unix iconv:wchar_t localbase:ldflags ncurses readline ssl
USE_RC_SUBR= softether_bridge softether_client softether_server
USE_LDCONFIG= yes
@@ -45,7 +43,15 @@ PLIST_SUB= SE_DBDIR="${SE_DBDIR}" SE_LOGDIR="${SE_LOGDIR}"
SUB_LIST= SE_DBDIR="${SE_DBDIR}" SE_LOGDIR="${SE_LOGDIR}"
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+# devel/cpu_features not available on these archs, see devel/cpu_features/Makefile
+.if (${ARCH} == aarch64 || ${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == mips || ${ARCH} == mips64)
+# skip cpu_features when devel/cpu_features is not available
+CFLAGS+= -DSKIP_CPU_FEATURES
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/cpu_features_macros.h:devel/cpu_features
+.endif
pre-configure:
# not a GNU configure
@@ -107,4 +113,4 @@ post-install-DOCS-on:
${FIND} ${WRKSRC} -name ${doc} -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR} \;
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>