aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm2
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-08-18 16:09:58 +0000
committerSteve Wills <swills@FreeBSD.org>2017-08-18 16:09:58 +0000
commit34d0c11b9be5cf4380c32eb7ba7b3f2a638145f7 (patch)
treef9d1d2b4fb2fb09da3bb7031269bdfe6a3c93425 /security/softhsm2
parente1fa0bd2daea335148a62f5fe63397bd93033fc3 (diff)
downloadports-34d0c11b9be5cf4380c32eb7ba7b3f2a638145f7.tar.gz
ports-34d0c11b9be5cf4380c32eb7ba7b3f2a638145f7.zip
security/softhsm2: fix storage directory
PR: 221212 Submitted by: jaap@NLnetLabs.nl (maintainer) Reported by: dewayne@heuristicsystems.com.au
Notes
Notes: svn path=/head/; revision=448254
Diffstat (limited to 'security/softhsm2')
-rw-r--r--security/softhsm2/Makefile12
-rw-r--r--security/softhsm2/files/pkg-message.in2
-rw-r--r--security/softhsm2/pkg-plist8
3 files changed, 15 insertions, 7 deletions
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 513bd50e18ea..69c2de90ae6e 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= softhsm
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://dist.opendnssec.org/source/ \
http://dist.opendnssec.org/source/testing/
@@ -15,14 +16,17 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir="${PREFIX}/var"
INSTALL_TARGET= install-strip
-USES= libtool ssl
+USES= libtool ssl pkgconfig
+
+SUB_FILES= pkg-message
CONFLICTS= softhsm-1.*
USE_LDCONFIG= yes
+LIB_DEPENDS+= libcppunit.so:devel/cppunit
+
OPTIONS_DEFINE= SQLITE
OPTIONS_SUB= yes
SQLITE_DESC= Build with object store backend DB support (SQLITE3)
@@ -49,4 +53,8 @@ CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
CONFIGURE_ARGS+= --disable-gost
.endif
+.if ${SSL_DEFAULT:Mopenssl-devel}
+CONFIGURE_ARGS+= --disable-gost
+.endif
+
.include <bsd.port.mk>
diff --git a/security/softhsm2/files/pkg-message.in b/security/softhsm2/files/pkg-message.in
new file mode 100644
index 000000000000..858608871a17
--- /dev/null
+++ b/security/softhsm2/files/pkg-message.in
@@ -0,0 +1,2 @@
+As of version 2.3.0_1, the storage directory for softhsm has changed from
+/usr/local/var/lib/softhsm to /var/lib/softhsm
diff --git a/security/softhsm2/pkg-plist b/security/softhsm2/pkg-plist
index 44ce5143ffff..34c6bb40911d 100644
--- a/security/softhsm2/pkg-plist
+++ b/security/softhsm2/pkg-plist
@@ -10,8 +10,6 @@ man/man1/softhsm2-dump-file.1.gz
man/man1/softhsm2-keyconv.1.gz
man/man1/softhsm2-util.1.gz
man/man5/softhsm2.conf.5.gz
-@dir lib/softhsm
-@dir var/lib/softhsm/tokens
-@dir var/lib/softhsm
-@dir var/lib
-@dir var
+@dir /var/lib/softhsm/tokens
+@dir /var/lib/softhsm
+@dir /var/lib