aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm2
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-07-17 15:18:36 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-07-17 15:18:36 +0000
commit4e049717137aa486b6b860ba779bec448bc9d50e (patch)
treeac0169db69dc7ceda4d280fe139a5b07de657cf6 /security/softhsm2
parent09bc85bbd9846c44c456fc79d971aea6d5226584 (diff)
downloadports-4e049717137aa486b6b860ba779bec448bc9d50e.tar.gz
ports-4e049717137aa486b6b860ba779bec448bc9d50e.zip
security/softhsm2: Update to 2.3.0, Fix build with SQLITE3 storage backend
Disable support for GOST if openssl-devel is used Add option SQLITE (optional) to fix build with SQLITE3 storage backend [1] While here: Add LICENSE_FILE Add USES= ssl (Q/A warning) PR: 220744 PR: 218701 [1] Submitted by: jaap@NLnetLabs.nl (maintainer) Submitted by: sergey@akhmatov.ru [1] Approved by: garga (mentor) MFH: 2017Q3 Differential Revision: https://reviews.freebsd.org/D11607
Notes
Notes: svn path=/head/; revision=446078
Diffstat (limited to 'security/softhsm2')
-rw-r--r--security/softhsm2/Makefile23
-rw-r--r--security/softhsm2/distinfo6
-rw-r--r--security/softhsm2/files/patch-src_lib_object__store_DB.h10
-rw-r--r--security/softhsm2/pkg-plist2
4 files changed, 31 insertions, 10 deletions
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 81b379ee7320..8ab060c56de5 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= softhsm
-PORTVERSION= 2.2.0
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= security
MASTER_SITES= http://dist.opendnssec.org/source/ \
http://dist.opendnssec.org/source/testing/
@@ -13,18 +12,21 @@ MAINTAINER= jaap@NLnetLabs.nl
COMMENT= Software implementation of a Hardware Security Module (HSM)
LICENSE= BSD2CLAUSE
-
-LIB_DEPENDS= libsqlite3.so:databases/sqlite3
+LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-sqlite3=${LOCALBASE} --localstatedir="${PREFIX}/var"
+CONFIGURE_ARGS= --localstatedir="${PREFIX}/var"
INSTALL_TARGET= install-strip
-USES= libtool sqlite
+USES= libtool ssl
CONFLICTS= softhsm-1.*
USE_LDCONFIG= yes
+OPTIONS_DEFINE= SQLITE
+OPTIONS_SUB= yes
+SQLITE_DESC= Build with object store backend DB support (SQLITE3)
+
OPTIONS_SINGLE= CRYP
OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
@@ -33,9 +35,12 @@ CRYP_BOTAN_DESC= Build with Botan crypto library
OPTIONS_DEFAULT= CRYP_OPEN
+SQLITE_CONFIGURE_WITH= sqlite3=${LOCALBASE} objectstore-backend-db
+SQLITE_USES= sqlite
+
CRYP_BOTAN_CONFIGURE_ON= --with-crypto-backend=botan
CRYP_BOTAN_LIB_DEPENDS= libbotan-1.10.so:security/botan110
-CRYP_OPEN_USES= ssl
+
CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
.include <bsd.port.options.mk>
@@ -44,4 +49,8 @@ CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
CONFIGURE_ARGS+= --disable-gost
.endif
+.if ${SSL_DEFAULT:Mopenssl-devel}
+CONFIGURE_ARGS+= --disable-gost
+.endif
+
.include <bsd.port.mk>
diff --git a/security/softhsm2/distinfo b/security/softhsm2/distinfo
index d06e28458810..bd28c92bb0a9 100644
--- a/security/softhsm2/distinfo
+++ b/security/softhsm2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480976612
-SHA256 (softhsm-2.2.0.tar.gz) = eb6928ae08da44fca4135d84d6b79ad7345f408193208c54bf69f5b2e71f85f7
-SIZE (softhsm-2.2.0.tar.gz) = 966806
+TIMESTAMP = 1499110463
+SHA256 (softhsm-2.3.0.tar.gz) = 5ed604c89a3a6ef9d7d1ee92c28a2c4b3cd1f86f302c808e2d12c8f39aa2c127
+SIZE (softhsm-2.3.0.tar.gz) = 992417
diff --git a/security/softhsm2/files/patch-src_lib_object__store_DB.h b/security/softhsm2/files/patch-src_lib_object__store_DB.h
new file mode 100644
index 000000000000..eeb8f2e7e81a
--- /dev/null
+++ b/security/softhsm2/files/patch-src_lib_object__store_DB.h
@@ -0,0 +1,10 @@
+--- src/lib/object_store/DB.h.orig 2017-07-13 14:38:02 UTC
++++ src/lib/object_store/DB.h
+@@ -37,6 +37,7 @@
+
+ #include <string>
+ #include <sqlite3.h>
++#include <time.h>
+
+ namespace DB {
+
diff --git a/security/softhsm2/pkg-plist b/security/softhsm2/pkg-plist
index c3854f6ea5f2..44ce5143ffff 100644
--- a/security/softhsm2/pkg-plist
+++ b/security/softhsm2/pkg-plist
@@ -1,10 +1,12 @@
bin/softhsm2-dump-file
+%%SQLITE%%bin/softhsm2-dump-db
bin/softhsm2-keyconv
bin/softhsm2-util
@sample %%ETCDIR%%2.conf.sample
lib/softhsm/libsofthsm2.a
lib/softhsm/libsofthsm2.so
man/man1/softhsm2-dump-file.1.gz
+%%SQLITE%%man/man1/softhsm2-dump-db.1.gz
man/man1/softhsm2-keyconv.1.gz
man/man1/softhsm2-util.1.gz
man/man5/softhsm2.conf.5.gz