aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm2
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-07-27 12:36:54 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-07-27 12:36:54 +0000
commiteb3f193a9388057ccec1181566f8d20ea9ff8e30 (patch)
tree3cb769d3b72aa56a013400569d3360f9ac83bb50 /security/softhsm2
parent6004a788e9931b372b6c1fa248d6aadc29bbc93d (diff)
downloadports-eb3f193a9388057ccec1181566f8d20ea9ff8e30.tar.gz
ports-eb3f193a9388057ccec1181566f8d20ea9ff8e30.zip
security/softhsm2: add MIGRATE option to build the migration tool, as default
PR: 227004 Requested by: Roman <kabalax@gmail.com> Submitted by: jaap@NLnetLabs.nl (maintainer)
Notes
Notes: svn path=/head/; revision=475432
Diffstat (limited to 'security/softhsm2')
-rw-r--r--security/softhsm2/Makefile8
-rw-r--r--security/softhsm2/pkg-plist2
2 files changed, 8 insertions, 2 deletions
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 54d833bb93fa..a67e7b75db2d 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= softhsm
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://dist.opendnssec.org/source/ \
http://dist.opendnssec.org/source/testing/
@@ -26,9 +27,11 @@ USE_LDCONFIG= yes
LIB_DEPENDS+= libcppunit.so:devel/cppunit
-OPTIONS_DEFINE= SQLITE
+OPTIONS_DEFINE= SQLITE MIGRATE
+MIGRATE_IMPLIES= SQLITE
OPTIONS_SUB= yes
SQLITE_DESC= Build with object store backend DB support (SQLITE3)
+MIGRATE_DESC= Build the migration tool
OPTIONS_SINGLE= CRYP
OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
@@ -36,10 +39,11 @@ OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
CRYP_OPEN_DESC= Build with OpenSSL crypto library
CRYP_BOTAN_DESC= Build with Botan crypto library
-OPTIONS_DEFAULT= CRYP_OPEN
+OPTIONS_DEFAULT= CRYP_OPEN SQLITE MIGRATE
SQLITE_CONFIGURE_WITH= sqlite3=${LOCALBASE} objectstore-backend-db
SQLITE_USES= sqlite
+MIGRATE_CONFIGURE_WITH= migrate
CRYP_BOTAN_CONFIGURE_ON= --with-crypto-backend=botan
CRYP_BOTAN_LIB_DEPENDS= libbotan-1.10.so:security/botan110
diff --git a/security/softhsm2/pkg-plist b/security/softhsm2/pkg-plist
index f17ad8e610cd..420f367a62fd 100644
--- a/security/softhsm2/pkg-plist
+++ b/security/softhsm2/pkg-plist
@@ -1,6 +1,7 @@
bin/softhsm2-dump-file
%%SQLITE%%bin/softhsm2-dump-db
bin/softhsm2-keyconv
+%%MIGRATE%%bin/softhsm2-migrate
bin/softhsm2-util
@sample %%ETCDIR%%2.conf.sample
lib/softhsm/libsofthsm2.a
@@ -8,6 +9,7 @@ lib/softhsm/libsofthsm2.so
man/man1/softhsm2-dump-file.1.gz
%%SQLITE%%man/man1/softhsm2-dump-db.1.gz
man/man1/softhsm2-keyconv.1.gz
+%%MIGRATE%%man/man1/softhsm2-migrate.1.gz
man/man1/softhsm2-util.1.gz
man/man5/softhsm2.conf.5.gz
@dir /var/lib/softhsm/tokens