aboutsummaryrefslogtreecommitdiff
path: root/security/srp/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2001-07-25 20:54:33 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2001-07-25 20:54:33 +0000
commitd05a1b1b121a722e19520231cd0324bba3b5bd17 (patch)
tree9e7c3ad50cd325b82b8b19a1b1f6914f8647eafa /security/srp/Makefile
parent69602affa464b61129d70ecbac0b9e722cfdd4d7 (diff)
Notes
Diffstat (limited to 'security/srp/Makefile')
-rw-r--r--security/srp/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/srp/Makefile b/security/srp/Makefile
new file mode 100644
index 000000000000..a558235bd462
--- /dev/null
+++ b/security/srp/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: srp
+# Date created: 07/25/2001
+# Whom: nectar@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= srp
+PORTVERSION= 1.7.3
+CATEGORIES= security net
+MASTER_SITES= http://www-cs-students.stanford.edu/~tjw/srp/source/
+
+MAINTAINER= nectar@FreeBSD.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CC="${CC}" CFLAGS="${CFLAGS}" INSTALL="/usr/bin/install -C"
+CONFIGURE_ARGS= --with-openssl=/usr \
+ --with-zlib \
+ --enable-loginf
+
+PORTDOCS= Acknowledgements Copyrights LICENSE copyright.c \
+ draft-altman-rfc2942bis-00.txt draft-altman-rfc2944bis-01.txt \
+ draft-altman-telnet-fwdx-02.txt \
+ draft-ietf-tn3270e-telnet-tls-05.txt rfc2941.txt rfc2942.txt \
+ rfc2944.txt rfc2945.txt rfc2946.txt rfc2947.txt rfc2948.txt \
+ rfc2949.txt rfc2950.txt rfc2952.txt rfc2953.txt srp.ps
+
+.if !defined(NOPORTDOCS)
+post-install:
+.for f in ${PORTDOCS}
+ ${MKDIR} ${PREFIX}/share/doc/srp
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${PREFIX}/share/doc/srp/${f}
+ @${ECHO} share/doc/srp/${f} >> ${TMPPLIST}
+.endfor
+ @${ECHO} @dirrm share/doc/srp >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>