aboutsummaryrefslogtreecommitdiff
path: root/security/ssh-multiadd
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-05-20 02:40:30 +0000
committerWill Andrews <will@FreeBSD.org>2001-05-20 02:40:30 +0000
commit5e85f2ad57f3c02d0dfe26530d80a040bf219dbb (patch)
tree7dec97109c30796ce3155d586ec33597f7102f9e /security/ssh-multiadd
parent13cc61c6896a1be4a8529dc5f7b781cf9d76da9b (diff)
downloadports-5e85f2ad57f3c02d0dfe26530d80a040bf219dbb.tar.gz
ports-5e85f2ad57f3c02d0dfe26530d80a040bf219dbb.zip
Add ssh-multiadd 1.3, a tool to add multiple ssh keys to the
authentication agent. PR: 26975 Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=42774
Diffstat (limited to 'security/ssh-multiadd')
-rw-r--r--security/ssh-multiadd/Makefile27
-rw-r--r--security/ssh-multiadd/distinfo1
-rw-r--r--security/ssh-multiadd/pkg-comment1
-rw-r--r--security/ssh-multiadd/pkg-descr13
-rw-r--r--security/ssh-multiadd/pkg-plist1
5 files changed, 43 insertions, 0 deletions
diff --git a/security/ssh-multiadd/Makefile b/security/ssh-multiadd/Makefile
new file mode 100644
index 000000000000..9563618eb7c1
--- /dev/null
+++ b/security/ssh-multiadd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ssh-multiadd
+# Date created: 29 April 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssh-multiadd
+PORTVERSION= 1.3
+CATEGORIES= security
+MASTER_SITES= http://www.azstarnet.com/~donut/programs/ssh-multiadd/
+
+MAINTAINER= petef@databits.net
+
+USE_PYTHON= yes
+NO_BUILD= yes
+MAN1= ssh-multiadd.1
+
+post-patch:
+ ${PERL} -pi -e 's!/usr/bin/python2!${PYTHON_CMD}!; \
+ s!#break!break!' ${WRKSRC}/ssh-multiadd
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ssh-multiadd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ssh-multiadd.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/ssh-multiadd/distinfo b/security/ssh-multiadd/distinfo
new file mode 100644
index 000000000000..7d90d52e680e
--- /dev/null
+++ b/security/ssh-multiadd/distinfo
@@ -0,0 +1 @@
+MD5 (ssh-multiadd-1.3.tar.gz) = 1e7ece347bf7ff28e50b2b75f5c35799
diff --git a/security/ssh-multiadd/pkg-comment b/security/ssh-multiadd/pkg-comment
new file mode 100644
index 000000000000..f3aa878afc4a
--- /dev/null
+++ b/security/ssh-multiadd/pkg-comment
@@ -0,0 +1 @@
+Tool to add multiple ssh keys to the authentication agent
diff --git a/security/ssh-multiadd/pkg-descr b/security/ssh-multiadd/pkg-descr
new file mode 100644
index 000000000000..d1b64e009428
--- /dev/null
+++ b/security/ssh-multiadd/pkg-descr
@@ -0,0 +1,13 @@
+ssh-multiadd adds multiple ssh keys to the ssh authentication agent.
+These may use the same passphrase. When run without arguments, it
+adds $HOME/.ssh/identity and $HOME/.ssh/id_dsa. Alternative file
+names can be given on the command line or in the configuration
+file. It uses ssh-askpass if necessary. Unlike ssh-add, if any of
+the keys use the same passphrase, you will only need to enter each
+unique passphrase once, and keys that are already added will not
+be prompted for again.
+
+WWW: http://www.azstarnet.com/~donut/programs/index_s.html#ssh-multiadd
+
+- Pete
+petef@databits.net
diff --git a/security/ssh-multiadd/pkg-plist b/security/ssh-multiadd/pkg-plist
new file mode 100644
index 000000000000..ba11db9e1b5a
--- /dev/null
+++ b/security/ssh-multiadd/pkg-plist
@@ -0,0 +1 @@
+bin/ssh-multiadd