aboutsummaryrefslogtreecommitdiff
path: root/security/sshguard
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-06-17 21:55:21 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-06-17 21:55:21 +0000
commit83e4e3948e4c212d7d6153bda2d0cbb952eae9ef (patch)
tree9f3ef696ce0ad98802771a0e1aa5eb50ad50a0f2 /security/sshguard
parent8de72e58aa65590f92bb36b1d340c481d99bbd76 (diff)
downloadports-83e4e3948e4c212d7d6153bda2d0cbb952eae9ef.tar.gz
ports-83e4e3948e4c212d7d6153bda2d0cbb952eae9ef.zip
Notes
Diffstat (limited to 'security/sshguard')
-rw-r--r--security/sshguard/Makefile1
-rw-r--r--security/sshguard/files/patch-attack_scanner.l11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/sshguard/Makefile b/security/sshguard/Makefile
index 995753dbf610..a68a8e8841b9 100644
--- a/security/sshguard/Makefile
+++ b/security/sshguard/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sshguard
DISTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/security/sshguard/files/patch-attack_scanner.l b/security/sshguard/files/patch-attack_scanner.l
new file mode 100644
index 000000000000..bb14640decf5
--- /dev/null
+++ b/security/sshguard/files/patch-attack_scanner.l
@@ -0,0 +1,11 @@
+--- src/attack_scanner.l.orig Wed May 23 20:53:53 2007
++++ src/attack_scanner.l Sat Jun 16 17:45:43 2007
+@@ -46,7 +46,7 @@ NUMBER [1-9][0-9]*
+ /* an IPv4 address */
+ (25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]([0-9])?)(\.(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]([0-9])?|0)){3} { yylval.str = yytext; return IPv4; }
+ /* an IPv6 address */
+-((([a-fA-F0-9]{1,4}:){2}(:[a-fA-F0-9]{1,4}){1,5})|(:(:[a-fA-F0-9]{1,4}){1,6}|([a-fA-F0-9]{1,4}:)(:[a-fA-F0-9]{1,4}){1,6}|([a-fA-F0-9]{1,4}:){2}(:[a-fA-F0-9]{1,4}){1,5}|([a-fA-F0-9]{1,4}:){3}(:[a-fA-F0-9]{1,4}){1,4}|([a-fA-F0-9]{1,4}:){4}(:[a-fA-F0-9]{1,4}){1,3}|([a-fA-F0-9]{1,4}:){5}(:[a-fA-F0-9]{1,4}){1,2}|([a-fA-F0-9]{1,4}:){6}:[a-fA-F0-9]{1,4})) { yylval.str = yytext; return IPv6; }
++(([a-fA-F0-9]{1,4}(:[a-fA-F0-9]{1,4}){7})|(([a-fA-F0-9]{1,4}:){2}(:[a-fA-F0-9]{1,4}){1,5})|(:(:[a-fA-F0-9]{1,4}){1,6}|([a-fA-F0-9]{1,4}:)(:[a-fA-F0-9]{1,4}){1,6}|([a-fA-F0-9]{1,4}:){2}(:[a-fA-F0-9]{1,4}){1,5}|([a-fA-F0-9]{1,4}:){3}(:[a-fA-F0-9]{1,4}){1,4}|([a-fA-F0-9]{1,4}:){4}(:[a-fA-F0-9]{1,4}){1,3}|([a-fA-F0-9]{1,4}:){5}(:[a-fA-F0-9]{1,4}){1,2}|([a-fA-F0-9]{1,4}:){6}:[a-fA-F0-9]{1,4})) { yylval.str = yytext; return IPv6; }
+
+ /* an host address (PTR) */
+ localhost|([-a-zA-Z0-9]+\.)+[a-zA-Z]+ { yylval.str = yytext; return HOSTADDR; }