aboutsummaryrefslogtreecommitdiff
path: root/security/sslscan
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-05-02 17:23:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-05-02 17:23:53 +0000
commitf6a789336b6ae029452ecaec46f114d99b739517 (patch)
tree0e28e080a8c6ad19f45fa385d7ec3f78470132da /security/sslscan
parentb8ae48cb31c8631b3d992bb38af55fa9c9e283e2 (diff)
downloadports-f6a789336b6ae029452ecaec46f114d99b739517.tar.gz
ports-f6a789336b6ae029452ecaec46f114d99b739517.zip
security/sslscan: linker fix for 10.0 (adding -lcrypto), staging,
pkg-descr reformatted (shorter lines) PR: ports/186478 Submitted by: pi Approved by: jadawin (mentor)
Notes
Notes: svn path=/head/; revision=352830
Diffstat (limited to 'security/sslscan')
-rw-r--r--security/sslscan/Makefile6
-rw-r--r--security/sslscan/files/patch-Makefile6
-rw-r--r--security/sslscan/pkg-descr10
-rw-r--r--security/sslscan/pkg-plist2
4 files changed, 13 insertions, 11 deletions
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
index 02fb819febfe..a23d6f2e1cb2 100644
--- a/security/sslscan/Makefile
+++ b/security/sslscan/Makefile
@@ -10,10 +10,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= matthieu@labs.fr
COMMENT= SSLScan is a fast SSL port scanner
-MAKE_ARGS= CC="${CC}" CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+LICENSE= GPLv3
-MAN1= sslscan.1
-PLIST_FILES= bin/sslscan
+MAKE_ARGS= STAGEDIR=${STAGEDIR} CC="${CC}" CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/sslscan/files/patch-Makefile b/security/sslscan/files/patch-Makefile
index c1433953ab8c..3b08d4424ee8 100644
--- a/security/sslscan/files/patch-Makefile
+++ b/security/sslscan/files/patch-Makefile
@@ -4,13 +4,13 @@
SRCS = sslscan.c
-BINPATH = /usr/bin/
-MANPATH = /usr/share/man/
-+BINPATH = ${PREFIX}/bin/
-+MANPATH = ${PREFIX}/man
++BINPATH = ${STAGEDIR}${PREFIX}/bin/
++MANPATH = ${STAGEDIR}${PREFIX}/man
+CC = ${CC}
all:
- gcc -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
-+ ${CC} -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
++ ${CC} -g -Wall -lssl -lcrypto -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
install:
- cp sslscan $(BINPATH)
diff --git a/security/sslscan/pkg-descr b/security/sslscan/pkg-descr
index 112c7f429b82..b7624915d4c3 100644
--- a/security/sslscan/pkg-descr
+++ b/security/sslscan/pkg-descr
@@ -1,4 +1,6 @@
-SSLScan is a fast SSL port scanner. SSLScan connects to SSL ports and determines
-what ciphers are supported, which are the servers prefered ciphers, which SSL
-protocols are supported and returns the SSL certificate. Client certificates and
-private key can be configured and output is to text / XML.
+SSLScan is a fast SSL port scanner. SSLScan connects to SSL ports
+and determines what ciphers are supported, which are the servers
+prefered ciphers, which SSL protocols are supported and returns the
+SSL certificate. Client certificates and private key can be configured
+and output is to text / XML.
+
diff --git a/security/sslscan/pkg-plist b/security/sslscan/pkg-plist
new file mode 100644
index 000000000000..0166b954ca92
--- /dev/null
+++ b/security/sslscan/pkg-plist
@@ -0,0 +1,2 @@
+bin/sslscan
+man/man1/sslscan.1.gz